Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 314579 - =portage-2.2_rc67 pulls in different packages for fetch+install than for install alone.
Summary: =portage-2.2_rc67 pulls in different packages for fetch+install than for inst...
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on: 161422
Blocks:
  Show dependency tree
 
Reported: 2010-04-10 21:50 UTC by Kobboi
Modified: 2012-09-09 21:03 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Output of emerge -pvuDN world and emerge -fuDN world, with --debug (emerge-debug.tar.gz,399.64 KB, application/octet-stream)
2010-04-10 21:53 UTC, Kobboi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kobboi 2010-04-10 21:50:50 UTC
Logging this as requested by Portage maintainer zmedico.

These are the packages that would be merged, in order:

Calculating dependencies  ........ done!
[ebuild     U ] app-emulation/wine-1.1.42 [1.1.41] USE="X alsa cups dbus gecko jpeg lcms ldap mp3 ncurses opengl perl png ssl threads truetype xml -capi -custom-cflags -esd -fontconfig -gnutls -gphoto2 -gsm -hal -jack -nas -openal -oss -pulseaudio -samba -scanner -test -win64 -xcomposite -xinerama" 0 kB

Total: 1 package (1 upgrade), Size of downloads: 0 kB
Calculating dependencies  ..... done!

>>> Fetching (1 of 2) app-emulation/wine-1.1.42
 * wine-1.1.42.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                   [ ok ]
 * wine_gecko-1.0.0-x86.cab RMD160 SHA1 SHA256 size ;-) ...              [ ok ]
 * checking ebuild checksums ;-) ...                                     [ ok ]
 * checking auxfile checksums ;-) ...                                    [ ok ]
 * checking miscfile checksums ;-) ...                                   [ ok ]

>>> Fetching (2 of 2) dev-python/PyQt4-4.7.2
 * PyQt-x11-gpl-4.7.2.tar.gz RMD160 SHA1 SHA256 size ;-) ...             [ ok ]
 * checking ebuild checksums ;-) ...                                     [ ok ]
 * checking auxfile checksums ;-) ...                                    [ ok ]
 * checking miscfile checksums ;-) ...                                   [ ok ]


Reproducible: Always
Comment 1 Kobboi 2010-04-10 21:53:01 UTC
Created attachment 227315 [details]
Output of emerge -pvuDN world and emerge -fuDN world, with --debug
Comment 2 Zac Medico gentoo-dev 2012-09-09 21:03:34 UTC
The fetchonly graph is different because it ignores slot conflicts (see bug #161422), whereas the other graph backtracked due to a slot conflict:

backtracking due to slot conflict:
   package: ('ebuild', '/', 'dev-python/PyQt4-4.7.2', 'merge')
      slot: dev-python/PyQt4:0