Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 314025 - net-libs/xulrunner-1.9.2.3-r1 www-client/mozilla-firefox{,-bin}-3.6.3 www-client/icecat-3.6.3 stabilization request
Summary: net-libs/xulrunner-1.9.2.3-r1 www-client/mozilla-firefox{,-bin}-3.6.3 www-cli...
Status: RESOLVED DUPLICATE of bug 324735
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Mozilla Gentoo Team
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: 310411 311801 314011 314013 314443
Blocks: 302033 CVE-2010-1121
  Show dependency tree
 
Reported: 2010-04-09 03:39 UTC by Lars Wendler (Polynomial-C)
Modified: 2010-07-21 12:21 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Stabilization list pass #1 (firefox-3.6.3-stable.list,1.08 KB, text/plain)
2010-04-15 12:55 UTC, Nirbheek Chauhan (RETIRED)
Details
Stabilization list pass #2 (firefox-3.6.3-stable.list,996 bytes, text/plain)
2010-04-18 16:13 UTC, Nirbheek Chauhan (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Wendler (Polynomial-C) gentoo-dev 2010-04-09 03:39:24 UTC
necessary due to security reasons (bug #312763)
Comment 1 Nirbheek Chauhan (RETIRED) gentoo-dev 2010-04-15 12:53:46 UTC
Here is a preliminary list for stabilization. The different blocks can be stabilized independent of the other blocks. Block #1 contains packages not maintained by mozilla, but which already have (or had) stabilization bugs.

Note that I'm including packages from bug 314443 here because they need to go stable together.

I'm not sure what we should do about wireless-tools on alpha/ia64/sparc w.r.t bug 197119 comment #2

-------------

# See bug 300145
dev-db/sqlite-3.6.22-r2                                  hppa                         
# See bug 295947 
sys-devel/automake-wrapper-4                                       ppc ppc64           
sys-devel/automake-1.11.1                                          ppc ppc64           
# See bug 197119
net-wireless/wireless-tools-29           alpha                ia64           sparc     

dev-libs/nspr-4.8.4                      alpha amd64 arm hppa ia64 ppc ppc64 sparc x86
dev-libs/nss-3.12.6-r1                   alpha amd64 arm hppa ia64 ppc ppc64 sparc x86

net-libs/xulrunner-1.9.2.3-r1            alpha amd64 arm hppa ia64 ppc ppc64 sparc x86
www-client/epiphany-2.26.3-r4            alpha amd64     hppa ia64 ppc ppc64 sparc x86
www-client/epiphany-extensions-2.26.1-r1 alpha amd64     hppa ia64 ppc       sparc x86
www-client/mozilla-firefox-3.6.3         alpha amd64 arm hppa ia64 ppc ppc64 sparc x86
www-client/firefox-bin-3.6.3                   amd64                               x86
www-client/icecat-3.6.3                        amd64                               x86
Comment 2 Nirbheek Chauhan (RETIRED) gentoo-dev 2010-04-15 12:55:18 UTC
Created attachment 227899 [details]
Stabilization list pass #1

Ugly wrapping of the list in the previous comment, hence attachment.
Comment 3 Pacho Ramos gentoo-dev 2010-04-17 09:18:56 UTC
(In reply to comment #1)
> I'm not sure what we should do about wireless-tools on alpha/ia64/sparc w.r.t
> bug 197119 comment #2

Mask "wifi" USE flag for firefox on their profiles? :-/ Since they don't have hardware to test, maybe firefox[wifi] wasn't even tested on that arches

Other option could be to create a specific revbump for alpha/ia64/sparc without wifi requeriment to get it stabilized... but maybe it could be a headache to maintain in the future :-(
Comment 4 Nirbheek Chauhan (RETIRED) gentoo-dev 2010-04-18 16:13:04 UTC
Created attachment 228289 [details]
Stabilization list pass #2

Alright, so USE=wifi is already masked; so we can skip wireless-tools. This is an updated list. Next, I'll CC arches.
Comment 5 Nirbheek Chauhan (RETIRED) gentoo-dev 2010-04-18 16:15:16 UTC
Hello arches, attached is a list of packages that need to go stable due to security bugs in xulrunner/firefox/firefox-bin/icecat (see bug 312763). 

This depends on a number of packages; please see the dependency list as well.

Thanks in advance.
Comment 6 Pacho Ramos gentoo-dev 2010-04-18 19:35:28 UTC
amd64 stable
Comment 7 Christian Faulhammer (RETIRED) gentoo-dev 2010-04-20 09:46:52 UTC
x86 stable
Comment 8 Pacho Ramos gentoo-dev 2010-05-03 22:01:55 UTC
This is breaking galeon (bug 310411). Seems that some patches are around but I cannot test them just now. Would be nice if anybody could take a look on them and commit if possible.

Thanks a lot
Comment 9 Raúl Porcel (RETIRED) gentoo-dev 2010-05-09 17:11:30 UTC
alpha/arm/ia64/sparc stable
Comment 10 Joe Jezak (RETIRED) gentoo-dev 2010-05-31 19:27:34 UTC
Marked ppc/ppc64 stable.
Comment 11 Nirbheek Chauhan (RETIRED) gentoo-dev 2010-06-26 10:01:14 UTC
@hppa: Let's take this to the newer bug. Marking as dupe.

*** This bug has been marked as a duplicate of bug 324735 ***
Comment 12 Jeroen Roovers (RETIRED) gentoo-dev 2010-07-21 12:21:51 UTC
net-libs/xulrunner-1.9.2.3-r1 www-client/mozilla-firefox{,-bin}-3.6.3 www-client/icecat-3.6.3 stabilization request