Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 31396 - gscmxx ebuild fails with sandbox access violation
Summary: gscmxx ebuild fails with sandbox access violation
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Lars Weiler (RETIRED)
Depends on:
Reported: 2003-10-18 02:27 UTC by Dead Schorsch
Modified: 2004-05-26 08:13 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---

Adds DESTDIR handling to Makefile.PL (gscmxx-0.4.1-destdir.diff,725 bytes, patch)
2003-10-22 13:53 UTC, Doug Weimer
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dead Schorsch 2003-10-18 02:27:23 UTC
gscmxx installation fails when creating directory for install.

Reproducible: Always
Steps to Reproduce:
1. emerge gscmxx

Actual Results:  
Installing /var/tmp/portage/gscmxx-0.4.1/image/usr/share/man/man1/gscmxx.1
Installing /var/tmp/portage/gscmxx-0.4.1/image/usr/share/man/man3/SCMxx.3pm
Installing /var/tmp/portage/gscmxx-0.4.1/image/usr/bin/gscmxx
/usr/bin/perl "-MExtUtils::Command" -e mkpath /usr/share/pixmaps/gscmxx
ACCESS DENIED  mkdir:     /usr/share/pixmaps/gscmxx
mkdir /usr/share/pixmaps/gscmxx: Permission denied at
/usr/lib/perl5/5.8.1/ExtUtils/ line 186
make: *** [pixmaps] Error 255
!!! ERROR: app-misc/gscmxx-0.4.1 failed.
!!! Function perl-module_src_install, Line 78, Exitcode 2
!!! (no error message)
--------------------------- ACCESS VIOLATION SUMMARY
---------------------------LOG FILE = "/tmp/sandbox-gscmxx-0.4.1-1060.log"
mkdir:     /usr/share/pixmaps/gscmxx

king root # emerge info
Portage 2.0.49-r13 (default-x86-1.4, gcc-3.3.1, glibc-2.2.5-r2,2.3.2-r6, 2.4.22)
System uname: 2.4.22 i686 AMD Athlon(tm) XP 2200+
Gentoo Base System version
CFLAGS="-mcpu=athlon-xp -O3 -pipe"
CONFIG_PROTECT="/etc /var/qmail/control /usr/kde/2/share/config /usr/kde/3/share
/config /usr/X11R6/lib/X11/xkb /opt/resin/conf /opt/tomcat/conf /usr/share/texmf
/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/config"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-mcpu=athlon-xp -O3 -pipe"
FEATURES="autoaddcvs sandbox buildpkg ccache distcc userpriv usersandbox fixpack
USE="x86 oss apm avi crypt cups encode foomaticdb jpeg libg++ mad mpeg ncurses n
ls pdflib png spell truetype xml2 xmms xv zlib gtkhtml gdbm berkdb slang readlin
e tetex bonobo svga tcltk java guile postgres X sdl gpm tcpd pam libwww ssl perl
 python esd imlib oggvorbis gtk opengl mozilla ldap cdr scanner alsa doc dvd gd
gnome gtk2 hbci ipv6 moznocompose moznoirc moznomail nocardbus pda samba tiff us
b -arts -gif -mikmod -quicktime -qt -kde -motif"
Comment 1 Doug Weimer 2003-10-22 13:53:32 UTC
Created attachment 19637 [details, diff]
Adds DESTDIR handling to Makefile.PL

The problem is that Makefile.PL doesn't respect DESTDIR. This patch changes
pixmaps and i18n targets to respect DESTDIR and VENDORPREFIX. Save the patch
/usr/portage/app-misc/gscmxx/files/, add: 

src_unpack() {
    unpack ${A}
    cd ${S}
    epatch ${FILESDIR}/${P}-destdir.diff

to the gscmxx-0.4.1.ebuild and reemerge.
Comment 2 Dead Schorsch 2003-11-12 03:00:22 UTC
When will the patch become part of an updated package, because I am unable to implemented it?
Comment 3 Torsten Veller (RETIRED) gentoo-dev 2004-01-21 09:15:38 UTC
hello devs,

could you please fix it? The patch is submitted.
If you don't want to fix it -- remove it from the tree. 
Comment 4 Michael Cummings (RETIRED) gentoo-dev 2004-01-21 12:53:46 UTC
Pylon: even if I got a clean emerge I wouldn't know what this for. Since you posted it, can you take a look? I'll leave on the cc: list in case you need assistance.
Comment 5 Lars Weiler (RETIRED) gentoo-dev 2004-01-21 17:33:13 UTC
Hmm, the ebuild is ages old ;)  I can't remember if we had sandboxing at that time.

Nevertheless I tried to reproduce the error on my system.  Without luck.  I have FEATURES="autoaddcvs ccache cvs digest distcc sandbox strict userpriv usersandbox" enabled.  Or do I have to do something special for this error?

But if you have still problems I can simply add the patch and everybody will be happy.  It does not seem to break anything.  Or what do the Perl-People think?
Comment 6 Torsten Veller (RETIRED) gentoo-dev 2004-01-22 00:46:13 UTC
No special settings are required :) It is reproduceable (at least on my gentoobox). It is the third time that i had these problems (with different perl versions).

Installing /var/tmp/portage/gscmxx-0.4.1/image/usr/bin/gscmxx
Writing /var/tmp/portage/gscmxx-0.4.1/image//usr/lib/perl5/vendor_perl/5.8.3/i686-linux/auto/gscmxx/.packlist
/usr/bin/perl "-MExtUtils::Command" -e mkpath /usr/share/pixmaps/gscmxx
ACCESS DENIED  mkdir:     /usr/share/pixmaps/gscmxx
mkdir /usr/share/pixmaps/gscmxx: Permission denied at /usr/lib/perl5/vendor_perl/5.8.3/ExtUtils/ line 203
make: *** [pixmaps] Error 255

!!! ERROR: app-misc/gscmxx-0.4.1 failed.
!!! Function perl-module_src_install, Line 83, Exitcode 2
!!! (no error message)

$ emerge info

Portage 2.0.50_pre16 (default-x86-1.4, gcc-3.3.2, glibc-2.3.3_pre20040117-r0, 2.4.24-ck1)
System uname: 2.4.24-ck1 i686 AMD Duron(tm) processor
Gentoo Base System version
distcc 2.12.1 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.59
Automake: sys-devel/automake-1.7.8
CFLAGS="-march=athlon-xp -O2 -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.2/share/config /usr/kde/3/share/config /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-march=athlon-xp -O2 -pipe -fomit-frame-pointer"
FEATURES="autoaddcvs ccache cvs sandbox"
USE="3dnow X aalib acl acpi activefilter alsa apache2 avi berkdb bonobo caps cdr composite crypt cscope cups dga dvd encode esd faad fbcon ffmpeg foomaticdb gd gdbm gif gnome gpm gstreamer gtk gtk2 gtkhtml guile imap imlib innodb joystick jpeg lcms libwww lirc mad maildir mcal mmx mozcalendar mpeg mpi mule mysql ncurses nls nvidia offensive oggvorbis opengl pam pdflib png ppds python quicktime readline sasl scanner sdk sdl slang slp snmp spell sse ssl svga t1lib tcltk tcpd tetex tiff transcode truetype type1 unicode usb v4l wmf x86 xface xfs xine xml xml2 xmms xosd xv zlib zvbi video_cards_nvidia linguas_de"
Comment 7 Lars Weiler (RETIRED) gentoo-dev 2004-01-25 18:13:14 UTC
I added the patch to gscmxx and bumped the ebuild to -r1.  May you test it now?
Comment 8 Torsten Veller (RETIRED) gentoo-dev 2004-01-29 01:02:51 UTC
Well, the new ebuild isn't in the tree.
And yes, i patched it myself and it installs without sandbox violation.

Comment 9 Lars Weiler (RETIRED) gentoo-dev 2004-01-29 18:41:22 UTC
Oops.  Seems that I forgot to check-in without the --pretend option ;-)  Thanks for pointing that out.  Now it's really in portage.
Comment 10 Torsten Veller (RETIRED) gentoo-dev 2004-01-30 07:45:38 UTC
It tried this new version -- and it installs without sandbox violation.
Comment 11 Lars Weiler (RETIRED) gentoo-dev 2004-01-31 03:57:19 UTC
Okay, closing.
Comment 12 Dead Schorsch 2004-05-26 08:06:13 UTC
As far as it concerns me, this bug can be closed. No problems any more.
Comment 13 Lars Weiler (RETIRED) gentoo-dev 2004-05-26 08:13:23 UTC
okay, closing