Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 313625 - app-office/akonadi-server: MySQL server log contains warnings
Summary: app-office/akonadi-server: MySQL server log contains warnings
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-07 07:05 UTC by Dennis Schridde
Modified: 2011-01-13 00:45 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Schridde 2010-04-07 07:05:59 UTC
Akonadi reports: The MySQL server log contains warnings:
InnoDB: The InnoDB memory heap is disabled
InnoDB: use atomic builtins.
100407  9:01:29  InnoDB: Started; log sequence number 0 1438513128
100407  9:01:30 [Warning] Can't open and lock time zone table: Table 'mysql.time_zone_leap_second' doesn't exist trying to live without them
100407  9:01:30 [Note] /usr/sbin/mysqld: ready for connections.
Version: '5.0.90-log'  socket: '/home/$USER/.local/share/akonadi/db_misc/mysql.socket'  port: 0  Gentoo Linux mysql-5.0.90-r2

Is this a misconfiguration of Gentoo's MySQL?

Reproducible: Always
Comment 1 Matt Whitlock 2010-04-08 01:24:31 UTC
(In reply to comment #0)
> 100407  9:01:30 [Warning] Can't open and lock time zone table: Table
> 'mysql.time_zone_leap_second' doesn't exist trying to live without them

Did you run 'emerge --config dev-db/mysql' like the ebuild tells you to?
Comment 2 Dennis Schridde 2010-04-08 06:37:05 UTC
Yes, this machine was once running a dedicated MySQL server in the KDE3 days.
Comment 3 Dennis Schridde 2010-04-08 06:38:25 UTC
I tried running it again, just in case:
 * You have already a MySQL database in place.
 * (///var/lib/mysql/*)
 * Please rename or delete it if you wish to replace it.
Comment 4 Jonathan Callen (RETIRED) gentoo-dev 2010-04-08 06:52:12 UTC
(In reply to comment #1)
> (In reply to comment #0)
> > 100407  9:01:30 [Warning] Can't open and lock time zone table: Table
> > 'mysql.time_zone_leap_second' doesn't exist trying to live without them
> 
> Did you run 'emerge --config dev-db/mysql' like the ebuild tells you to?
> 

That is completely irrelevant, as akaondi does *not* use a system instance of mysql, but runs mysqld itself with a data dir in ~/.local/share/akonadi (by default - and looking at the log, it still has those defaults) - in that case, the db in /var/lib/mysql isn't touched at all - so it *does not matter* what's going on there.
Comment 5 Matt Whitlock 2010-04-08 11:09:28 UTC
(In reply to comment #4)
> That is completely irrelevant, as akaondi does *not* use a system instance of
> mysql, but runs mysqld itself with a data dir in ~/.local/share/akonadi

Pardon me.  I run MySQL anyway, so I configured Akonadi to connect to it rather than start up another instance.  I forgot that that is not the default behavior.

So it looks like Akonadi simply doesn't initialize the time zone tables when it sets up a new MySQL instance.
Comment 6 Andreas K. Hüttel gentoo-dev 2010-10-12 19:43:21 UTC
Which akonadi-server version was this, and is the bug still valid?
Comment 7 Philip Nystromer 2010-10-19 13:36:39 UTC
It seems I have the same problem

101019 15:29:45  InnoDB: Started; log sequence number 0 1214821
101019 15:29:45 [Warning] Can't open and lock time zone table: Table 'mysql.time_zone_leap_second' doesn't exist trying to live without them
101019 15:29:45 [ERROR] Can't open and lock privilege tables: Table 'mysql.servers' doesn't exist
101019 15:29:45 [Note] /usr/sbin/mysqld: ready for connections.
Version: '5.1.50-log'  socket: '/home/philip/.local/share/akonadi/db_misc/mysql.socket'  port: 0  Gentoo Linux mysql-5.1.50-r1
Comment 8 Hans Kwint 2010-11-20 02:02:31 UTC
As a workaround:

/usr/bin/mysql_install_db --datadir=$HOME/.local/share/akonadi/db_data

This creates a database called 'mysql' in the Akonadi database. I described this issue here: http://lxer.com/module/newswire/view/144863/
Comment 9 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2011-01-13 00:45:22 UTC
nothing we can do here, try reporting upstream