Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 313177 - kde-base/okular-4.4.2 (via libspectre) fails to open some postscript files
Summary: kde-base/okular-4.4.2 (via libspectre) fails to open some postscript files
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo KDE team
Depends on:
Blocks: 313999
  Show dependency tree
Reported: 2010-04-05 05:13 UTC by Dmitri Pogosian
Modified: 2010-06-07 10:16 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

one of postscript files that fail (,104.46 KB, text/plain)
2010-04-05 16:01 UTC, Dmitri Pogosian

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitri Pogosian 2010-04-05 05:13:03 UTC
1) okular-4.3.5 (libspectre-0.2.2 or 0.2.4, ghostscript-gpl-8.64-r3) fails to open some of the postcript files.  When launched from terminal okular produces the output

$ okular
rangecheck -15
rangecheck -15
QImage::scaled: Image is a null image
rangecheck -15
rangecheck -15
QImage::scaled: Image is a null image
rangecheck -15
rangecheck -15
QImage::scaled: Image is a null image

and no file is rendered in the display area.

2) gv renders the file properly.

3) This error has been reported on kde-bugs (bug #186344 over a year ago, where it was closed
as UPSTREAM with the reference to libspectre bug #17379 on freedesktop site
( )

Discussion of the libspectre bug however stopped in March, 2009 when libspectre was in the version 0.2.2 without any obvious resolution.  

I have tried the latest, libspectre-0.2.4, but still no joy.  libspectre
git archive  does not show activity that I could recognize has effect on this behaviour.

I can supply the postscript files in question.

Reproducible: Always

Steps to Reproduce:

1. $ file PostScript document text conforming DSC level 3.0
2. okular

Actual Results:  
no display (just icon in display area, errors in terminal)

Expected Results:  
postscript file displayed properly.
Comment 1 Dmitri Pogosian 2010-04-05 05:23:22 UTC
$ emerge --info
Portage (default/linux/amd64/10.0, gcc-4.3.4, glibc-2.10.1-r1, 2.6.31-gentoo-r6 x86_64)                                                                
System uname: Linux-2.6.31-gentoo-r6-x86_64-Intel-R-_Core-TM-2_Duo_CPU_L7100_@_1.20GHz-with-gentoo-1.12.13                                                      
Timestamp of tree: Mon, 05 Apr 2010 01:00:01 +0000                              
app-shells/bash:     4.0_p35                                                    
dev-java/java-config: 1.3.7-r1, 2.1.10                                          
dev-lang/python:     2.6.4-r1                                                   
dev-python/pycrypto: 2.1.0_beta1                                                
dev-util/cmake:      2.6.4-r3                                                   
sys-apps/baselayout: 1.12.13                                                    
sys-apps/sandbox:    1.6-r2                                                     
sys-devel/autoconf:  2.13, 2.63-r1                                              
sys-devel/automake:  1.9.6-r2, 1.10.3                                           
sys-devel/binutils:  2.18-r3                                                    
sys-devel/gcc:       4.3.4                                                      
sys-devel/gcc-config: 1.4.1                                                     
sys-devel/libtool:   2.2.6b                                                     
virtual/os-headers:  2.6.30-r1                                                  
CFLAGS="-O2 -pipe -march=native"                                                
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config"                      
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"                                                                          
CXXFLAGS="-O2 -pipe -march=native"                                              
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
LINGUAS="en ru"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X accessibility acl acpi alsa amd64 berkdb bluetooth bzip2 cairo cli cracklib crypt cups cxx dbus djvu dri fontconfig fortran fts3 fuse gmp gpm gtk iconv java jpeg kde latex lcms lyx mad midi mmx modules mp3 mplayer mudflap multilib ncurses nls nptl nptlonly opengl openmp pam pcre pdf perl png pppd python qt3support qt4 readline reflection rtc session smp spell spl sql sqlite sse sse2 ssl ssse3 subversion svg sysfs tcl tcpd tetex threads tiff tk truetype unicode usb wifi xcomposite xine xinerama xorg xosd xulrunner xv xvmc zlib" ALSA_CARDS="hda-intel usb-audio" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="canon ptp2" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en ru" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel"
Comment 2 Dmitri Pogosian 2010-04-05 16:01:55 UTC
Created attachment 226639 [details]
one of postscript files that fail
Comment 3 Dmitri Pogosian 2010-04-06 16:37:25 UTC
Upgrade to ghostscript-gpl-8.71 (-r3) seems have solved the issue. Hope it will go stable soon
Comment 4 Andreas K. Hüttel archtester gentoo-dev 2010-04-30 21:20:02 UTC
Confirmed for 4.4.2.

CC'ing printing herd since this is fixed by a ghostscript-gpl update. 

Comment 5 Tomáš Chvátal (RETIRED) gentoo-dev 2010-06-07 10:16:06 UTC
This bug is fixed in testing. And stablereq 319505 is open so it gets to stable.