Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 311971 - app-crypt/truecrypt-6.3a (and 6.1a) hangs when mounting a volume.
Summary: app-crypt/truecrypt-6.3a (and 6.1a) hangs when mounting a volume.
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Crypto team [DISABLED]
: 311975 (view as bug list)
Depends on:
Reported: 2010-03-29 18:16 UTC by Artem Kuznetsov
Modified: 2010-10-27 16:34 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Artem Kuznetsov 2010-03-29 18:16:51 UTC
After a big emerge -upvD world yesterday (~100 packages and kernel update to 2.6.31-r10 from r6) I can't mount truecrypt volumes.

storage ~ # tc -v /dev/sda5 /mnt/crypto/
Enter password for /dev/sda5:
Enter keyfile [none]:
Protect hidden volume? (y=Yes/n=No) [No]:

Truecrypt hangs after it. Quits by Ctrl-C.

storage ~ # ps ax | grep true
19301 ? Ss 0:00 truecrypt /dev/sda5 /mnt/crypto/
19302 ? S 0:00 truecrypt /dev/sda5 /mnt/crypto/
19303 ? S 0:00 /bin/mount -i -f -t fuse.truecrypt -o rw,nosuid,nodev,allow_other truecrypt /tmp/.truecrypt_aux_mnt1

storage ~ #ls /tmp/.truecrypt_aux_mnt1 - Hangs. 
storage ~ #lsof /tmp - Hangs. 
Nothing related to it in /var/log/messages.

I've tried Fuse, dm* both in-kernel and modules - noo result.
Tried to roll back to 2.6.31-r6 - no result.

kill -9 19301 19302 19303
ls -la /tmp/.truecrypt_aux_mnt1
ls: can't access /tmp/.truecrypt_aux_mnt1: Endpoint is not connected
(Error message translated from Russian. Original: невозможно получить доступ к /tmp/.truecrypt_aux_mnt1: Конечная точка передачи не подсоединена)

Reproducible: Always

Steps to Reproduce:
1. Mount truecrypt volume

Actual Results:  
truecrypt hangs

Expected Results:  
truecrypt volume is mounted

storage log # uname -a
Linux QWERTY1 2.6.31-gentoo-r10 #1 SMP Sun Mar 28 20:58:28 MSD 2010 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 5000+ AuthenticAMD GNU/Linux

storage log # emerge --info
Portage (default/linux/amd64/10.0, gcc-4.3.4, glibc-2.10.1-r1, 2.6.31-gentoo-r10 x86_64)
System uname: Linux-2.6.31-gentoo-r10-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_5000+-with-gentoo-1.12.13
Timestamp of tree: Sun, 28 Mar 2010 20:30:01 +0000
app-shells/bash:     4.0_p35
dev-java/java-config: 2.1.10
dev-lang/python:     2.4.6, 2.5.4-r4, 2.6.4-r1
dev-python/pycrypto: 2.0.1-r8
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.7.9-r2, 1.9.6-r3, 1.10.3
sys-devel/binutils:  2.18-r3
sys-devel/gcc:       4.1.2, 4.3.4
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
CFLAGS="-march=athlon64 -O3 -pipe"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config /var/bind /var/qmail/alias /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=athlon64 -O3 -pipe"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
LINGUAS="en ru"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X acl additions alsa amd64 apache2 berkdb bzip2 cdr clamav cli cracklib crypt cups cxx dbus dri dvd dynamicplugin embedded extras flac fortran gdbm gif gnutls gpm gtk iconv ipp ipv6 jpeg kde mad mmx mng modules mp3 mudflap multilib mysql ncurses nls nptl nptlonly ogg opengl openmp pam pcre perl png pppd python qt3support qt4 readline reflection session sockets spl sse sse2 ssl svg sysfs tcpd unicode userlocales xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en ru" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon"
Comment 1 Chí-Thanh Christopher Nguyễn gentoo-dev 2010-03-29 20:22:35 UTC
*** Bug 311975 has been marked as a duplicate of this bug. ***
Comment 2 Artem Kuznetsov 2010-03-30 17:20:45 UTC
I've just tried to create new Truecrypt container and mount it. The same situation. So it's not a /dev/sda5 problem.
Comment 3 Artem Kuznetsov 2010-03-30 19:18:30 UTC
Something similar...
Comment 4 Artem Kuznetsov 2010-03-31 18:26:58 UTC
strace truecrypt /dev/sda5 /mnt/crypto:
Comment 5 Artem Kuznetsov 2010-04-04 20:38:13 UTC
Downgrade to truecrypt-6.1a didn't help.
Comment 6 Dane Smith (RETIRED) gentoo-dev 2010-10-16 01:16:25 UTC
These versions are no longer in the tree as of 10/14.

Does truecrypt-7.0a address the problem?
Comment 7 Artem Kuznetsov 2010-10-16 09:29:53 UTC
(In reply to comment #6)
> These versions are no longer in the tree as of 10/14.
> Does truecrypt-7.0a address the problem?

6 months to react :)
Pretty good :)

I don't know. I don't use truecrypt with gentoo any more, it's too risky.
Comment 8 Dane Smith (RETIRED) gentoo-dev 2010-10-27 16:34:21 UTC
Closing out. No longer in tree.