Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 311125 - x11-misc/shared-mime-info-0.71: configure: error: XML::Parser perl module is required for intltool
Summary: x11-misc/shared-mime-info-0.71: configure: error: XML::Parser perl module is ...
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-24 14:37 UTC by Bryan Duff
Modified: 2010-03-24 16:53 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bryan Duff 2010-03-24 14:37:12 UTC
Merging shared-mime-info fails with a requirement for XML-Parser (unless it's something else that I'm not aware of).

//start snip
# emerge -p XML-Parser

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] dev-perl/XML-Parser-2.36-r1 
//end snip

Reproducible: Always

Steps to Reproduce:
1. emerge shared-mime-info
2. fail

Actual Results:  
emerge -a shared-mime-info

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] x11-misc/shared-mime-info-0.71 

Would you like to merge these packages? [Yes/No] y

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) x11-misc/shared-mime-info-0.71
 * shared-mime-info-0.71.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...         [ ok ]
 * checking ebuild checksums ;-) ...                                     [ ok ]
 * checking auxfile checksums ;-) ...                                    [ ok ]
 * checking miscfile checksums ;-) ...                                   [ ok ]
 * CPV:  x11-misc/shared-mime-info-0.71
 * REPO: gentoo
 * USE:  amd64 elibc_glibc kernel_linux multilib userland_GNU
>>> Unpacking source...
>>> Unpacking shared-mime-info-0.71.tar.bz2 to /var/tmp/portage/x11-misc/shared
mime-info-0.71/work
>>> Source unpacked in /var/tmp/portage/x11-misc/shared-mime-info-0.71/work
>>> Preparing source in /var/tmp/portage/x11-misc/shared-mime-info-0.71/work/sh
red-mime-info-0.71 ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/x11-misc/shared-mime-info-0.71/work/
hared-mime-info-0.71 ...
./configure --prefix=/usr --build=x86_64-pc-linux-gnu --host=x86_64-pc-linux-gn
 --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysco
fdir=/etc --localstatedir=/var/lib --libdir=/usr/lib64 --disable-dependency-tra
king --disable-update-mimedb
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for x86_64-pc-linux-gnu-gcc... x86_64-pc-linux-gnu-gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether x86_64-pc-linux-gnu-gcc accepts -g... yes
checking for x86_64-pc-linux-gnu-gcc option to accept ISO C89... none needed
checking for style of include used by make... GNU
checking dependency style of x86_64-pc-linux-gnu-gcc... none
checking for an ANSI C-conforming const... yes
checking whether NLS is requested... yes
checking for intltool >= 0.35.0... 0.41.0 found
checking for intltool-update... /usr/bin/intltool-update
checking for intltool-merge... /usr/bin/intltool-merge
checking for intltool-extract... /usr/bin/intltool-extract
checking for xgettext... /usr/bin/xgettext
checking for msgmerge... /usr/bin/msgmerge
checking for msgfmt... /usr/bin/msgfmt
checking for gmsgfmt... /usr/bin/gmsgfmt
checking for perl... /usr/bin/perl
checking for perl >= 5.8.1... 5.10.1
checking for XML::Parser... configure: error: XML::Parser perl module is requir
d for intltool

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/x11-misc/shared-mime-info-0.71/work/shared-mime-info-0.71/
onfig.log
 * ERROR: x11-misc/shared-mime-info-0.71 failed:
 *   econf failed
 * 
 * Call stack:
 *     ebuild.sh, line  54:  Called src_configure
 *   environment, line 224:  Called econf '--disable-dependency-tracking' '--di
able-update-mimedb'
 *     ebuild.sh, line 544:  Called die
 * The specific snippet of code:
 *                      die "econf failed"
 * 
 * If you need support, post the output of 'emerge --info =x11-misc/shared-mime
info-0.71',
 * the complete build log and the output of 'emerge -pqv =x11-misc/shared-mime-
nfo-0.71'.
 * The complete build log is located at '/var/tmp/portage/x11-misc/shared-mime-
nfo-0.71/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-misc/shared-
ime-info-0.71/temp/environment'.
 * S: '/var/tmp/portage/x11-misc/shared-mime-info-0.71/work/shared-mime-info-0.
1'

>>> Failed to emerge x11-misc/shared-mime-info-0.71

Expected Results:  
Successful merge.

# emerge --info
Portage 2.1.8.3 (default/linux/amd64/10.0, gcc-4.3.4, glibc-2.11-r1, 2.6.33-00179-g6ebdc66 x86_64)
=================================================================
System uname: Linux-2.6.33-00179-g6ebdc66-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_6000+-with-gentoo-2.0.1
Timestamp of tree: Tue, 23 Mar 2010 01:45:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p35
dev-lang/python:     2.6.4-r1
dev-util/ccache:     2.4-r8
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.65
sys-devel/automake:  1.10.3
sys-devel/binutils:  2.20.1
sys-devel/gcc:       4.3.4
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=athlon64 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests ccache distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl adns alsa amd64 berkdb bzip2 cli cracklib crypt cups cxx dbus dri dvd fortran gdbm gnome gpm gtk iconv ipv6 jpeg mmx modules mudflap multilib ncurses nls nptl nptlonly opengl openmp pam pcre perl png pppd python readline reflection session snmp spell spl sse sse2 ssl svg sysfs tcpd tiff unicode vorbis xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nv nvidia vesa" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Samuli Suominen gentoo-dev 2010-03-24 14:38:38 UTC

*** This bug has been marked as a duplicate of bug 41124 ***
Comment 2 Bryan Duff 2010-03-24 16:53:42 UTC
The bug that this is a duplicate suggests merging the problem package again:

# emerge XML-Parser

And that fixed it.  Is there some "Common Gentoo Issues" page, so I don't file stupid bugs?