Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 311121 - Packages index badly generated
Summary: Packages index badly generated
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Binary packages support (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 335925
  Show dependency tree
 
Reported: 2010-03-24 14:06 UTC by Gilles Dartiguelongue
Modified: 2010-12-23 17:28 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gilles Dartiguelongue gentoo-dev 2010-03-24 14:06:33 UTC
I using a couple of build chroots (some chained) to build packages for less peachy computers and I have been using the --binpkg-respect-use=y for a while to avoid pulling unwanted dependencies on chroots where it is unneeded.

It goes something like this:

build-base ------> build_chroot_profile_1 -----> computer1, 2, ...
          \-------> build_chroot_profile_2 -----> computer3, 4, ...

My problem is that somehow when I build a package on build_chroot_profile_1 that is also available in build_base but with different USE flags, it correctly builds the package with the proper use flags but somehow computer1 attemps to build the package anyway. After some checking the "Packages" file was not showing correct values for the USE field, although the sha1 and md5 fields where OK.

Since I don't know of any way to regenerate Packages file, I ended up downloading the binary archive by hand in PKGDIR on computer1 and it finally accepted emerging in binary mode.
Comment 1 Jeremy Olexa (darkside) (RETIRED) archtester gentoo-dev Security 2010-03-24 14:13:31 UTC
(In reply to comment #0)

> Since I don't know of any way to regenerate Packages file, I ended up
> downloading the binary archive by hand in PKGDIR on computer1 and it finally
> accepted emerging in binary mode.

A method to regenerate the Packages file is: "emaint --fix binhost" - Does that help the situation?

Furthermore, what portage version? :)
Comment 2 Gilles Dartiguelongue gentoo-dev 2010-03-24 14:20:37 UTC
Need coffee :)
I'm using the same version on portage on every box I have.

I tried the emaint trick and it fixes a couple of md5/sha1 mismatch it seems but not USE changes.

# emerge --info
Portage 2.2_rc67 (default/linux/x86/10.0, gcc-4.4.3, glibc-2.11-r1, 2.6.32-gentoo-r3 i686)
=================================================================
System uname: Linux-2.6.32-gentoo-r3-i686-Pentium_III_-Katmai-with-gentoo-2.0.1
Timestamp of tree: Wed, 24 Mar 2010 07:15:01 +0000
distcc[7168] (dcc_mkdir) ERROR: mkdir '/var/tmp/portage/.distcc/state' failed: No such file or directory [disabled]
app-shells/bash:     4.1_p2
dev-lang/python:     2.6.4-r1, 3.1.1-r1
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.0-r1
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.65
sys-devel/automake:  1.10.3, 1.11.1
sys-devel/binutils:  2.20.1
sys-devel/gcc:       4.4.3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.33
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium2 -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=pentium2 -fomit-frame-pointer -pipe -fvisibility-inlines-hidden"
DISTDIR="/var/tmp/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps=y --complete-graph --jobs=2 --load=4.0 --keep-going --binpkg-respect-use=y"
FEATURES="assume-digests buildpkg distlocks fixpackages getbinpkg multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unmerge-logs unmerge-orphans userfetch usersandbox"
GENTOO_MIRRORS="ftp://91.121.125.139/gentoo-distfiles/ http://91.121.125.139/gentoo-distfiles/ ftp://91.121.124.139/gentoo-distfiles/"
LANG="fr_FR.UTF-8"
LC_ALL="fr_FR.UTF-8"
LDFLAGS="-Wl,-O1,--as-needed,--hash-style=gnu"
LINGUAS="fr en"
MAKEOPTS="-j6 -l4.0"
PKGDIR="/var/tmp/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://shinobu/gentoo-portage"
USE="acl acpi alsa avahi bash-completion bzip2 caps cli cracklib crypt distcc dri extensions fam gmp gnutls gpgme iconv imap iproute2 ipv6 javascript ldap lids logrotate md5sum memlimit mmx modules mudflap ncurses nls no-old-linux nptl nptlonly ntp odbc openmp openssh pam pcre pppd readline reflection sasl session spl ssl sysfs syslog tcpd threads unicode urandom usb userlocales vim vim-syntax x86 xattr xml xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias proxy proxy_http charset_lite" APACHE2_MPMS="worker" ELIBC="glibc" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr en" RUBY_TARGETS="ruby18" USERLAND="GNU" 
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 3 Gilles Dartiguelongue gentoo-dev 2010-03-24 14:25:20 UTC
For the record, the wanted USE is:
berkdb crypt gnutls ipv6 odbc sasl ssl syslog tcpd

The USE on build_base is:
crypt gnutls ipv6 minimal sasl ssl syslog tcpd

The USE on build_chroot_profile_1 Packages file is:
crypt gnutls ipv6 minimal sasl ssl syslog tcpd
Comment 4 Gilles Dartiguelongue gentoo-dev 2010-12-23 11:14:52 UTC
For the record, I'm now running 2.2.0_alpha10 and I have not encountered this bug in a while. Maybe this is due to portage running emaint --fix binhost automatically ?
Comment 5 Zac Medico gentoo-dev 2010-12-23 16:57:55 UTC
Maybe this fixed it:

http://git.overlays.gentoo.org/gitweb/?p=proj/portage.git;a=commit;h=b3c018323e9a78b6bccfe5f20f41c40fdd2eb989

Please re-open if you encounter it again.
Comment 6 Gilles Dartiguelongue gentoo-dev 2010-12-23 17:28:18 UTC
sure, thanks for your time.