Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 310651 - app-portage/layman-1.3.2-r2 fails to update mercurial overlays
Summary: app-portage/layman-1.3.2-r2 fails to update mercurial overlays
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Jesus Rivero (RETIRED)
URL:
Whiteboard:
Keywords:
: 311427 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-03-22 05:51 UTC by Priit Laes (IRC: plaes)
Modified: 2010-03-26 12:17 UTC (History)
12 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
strace layman -a devnull &>log (log,317.47 KB, text/plain)
2010-03-22 18:40 UTC, Doktor Notor
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Priit Laes (IRC: plaes) 2010-03-22 05:51:53 UTC
$ sudo layman -S
* Running command "cd "/var/lib/layman/tryton" && /usr/bin/hg pull -u "http://www.tryton.org/hg/tryton-overlay/""...
Usage: 

layman (-a|-d|-s|-i) OVERLAY
layman -f [-o URL]
layman (-l|-L|-S)

layman: error: no such option: -u
* 
* Errors:
* ------
* 
* Failed to sync overlay "tryton".
* Error was: Syncing overlay "tryton" returned status 512!
* 
dev-vcs/mercurial-1.5  USE="-bash-completion -bugzilla -emacs -gpg -test -tk -zsh-completion"
app-portage/layman-1.3.2-r2  USE="git mercurial subversion -bazaar -cvs -darcs -test"
Comment 1 Konstantin Likhomanov 2010-03-22 05:57:06 UTC
Same problem after upgrading to python-2.6.5
Comment 2 Doktor Notor 2010-03-22 07:46:01 UTC
Confirmed...
<snip>
* Running command "cd "/var/lib/layman/devnull" && /usr/bin/hg pull -u "http://hg.core.ws/devnull""...
sh: line 0: cd: /var/lib/layman/devnull: No such file or directory


* 
* Errors:
* ------
* 
* Failed to sync overlay "devnull".
* Error was: Syncing overlay "devnull" returned status 256!
* 
</snip>

Please note in summary that this happens w/ python-2.6.5 only.
Comment 3 Doktor Notor 2010-03-22 07:48:59 UTC
More phun:

* Running command "/usr/bin/hg clone "http://hg.core.ws/devnull/" "/var/lib/layman/devnull""...
* Successfully added overlay "devnull".

Well, nothing is added at all... but - success *g*
Comment 4 tman 2010-03-22 08:24:36 UTC
yes i can also confirm this problem with: devnull and lxde overlay after upgrade python
Comment 5 Sebastian Pipping gentoo-dev 2010-03-22 17:33:53 UTC
So does this work outside of layman for you?

  hg clone "http://hg.core.ws/devnull/" devnull
  cd devnull
  hg pull -u "http://hg.core.ws/devnull/"

Fruther does

  hg pull --help

still list option "-u" for you?
Comment 6 Doktor Notor 2010-03-22 17:42:42 UTC
(In reply to comment #5)
> So does this work outside of layman for you?
>   hg clone "http://hg.core.ws/devnull/" devnull

Works.

>   cd devnull
>   hg pull -u "http://hg.core.ws/devnull/"

Works.

> Fruther does
>   hg pull --help
> 
> still list option "-u" for you?

Sure. 
Comment 7 Sebastian Pipping gentoo-dev 2010-03-22 18:34:02 UTC
Even with 2.6.5 it seems I cannot reproduce it, see below.
Any hints?


$ python --version
Python 2.6.5

$ layman --version
1.3.2_p2

$ hg --version | head -n 1
Mercurial Distributed SCM (version 1.5)

$ sudo layman -a devnull
* Running command "/usr/bin/hg clone "http://hg.core.ws/devnull/" "/var/lib/layman/devnull""...
Not trusting file /home/sping/__playground/devnull/.hg/hgrc from untrusted user sping, group sping
requesting all changes
adding changesets
adding manifests
adding file changes
added 922 changesets with 2411 changes to 898 files
updating to branch default
196 files updated, 0 files merged, 0 files removed, 0 files unresolved
* Successfully added overlay "devnull".

$ sudo layman -s devnull
* Running command "cd "/var/lib/layman/devnull" && /usr/bin/hg pull -u "http://hg.core.ws/devnull""...
pulling from http://hg.core.ws/devnull
searching for changes
no changes found
* 
* Success:
* ------
* 
* Successfully synchronized overlay "devnull".
Comment 8 Doktor Notor 2010-03-22 18:40:49 UTC
Created attachment 224749 [details]
strace layman -a devnull &>log

(In reply to comment #7)
> Even with 2.6.5 it seems I cannot reproduce it, see below.
> Any hints?

Well, no, not really.  I attached strace in case it'd help :)
Comment 9 Ben de Groot (RETIRED) gentoo-dev 2010-03-22 18:49:18 UTC
I get the same failure:

# layman -s lxde
* Running command "cd "/var/repos/lxde" && /usr/bin/hg pull -u
"http://bitbucket.org/yngwin/lxde-overlay/""...
Usage: 

layman (-a|-d|-s|-i) OVERLAY
layman -f [-o URL]
layman (-l|-L|-S)

layman: error: no such option: -u
* 
* Errors:
* ------
* 
* Failed to sync overlay "lxde".
* Error was: Syncing overlay "lxde" returned status 512!
* 
Comment 10 Ivan Grynko 2010-03-22 18:50:52 UTC
Same here, but downgrade to python-2.6.4-r1 solved it for me.
Comment 11 Doktor Notor 2010-03-22 19:04:34 UTC
(In reply to comment #10)
> Same here, but downgrade to python-2.6.4-r1 solved it for me.

Yeah, this is definitely python-related. I checked the patchsets, and they are virtually identical for 2.6.4-r1 and 2.6.5. Here's the relavant part of ebuild diff b/w those ebuild versions:

-	if tc-is-cross-compiler; then
-		epatch "${FILESDIR}/python-2.5-cross-printf.patch"
-		epatch "${FILESDIR}/python-2.6-chflags-cross.patch"
-		epatch "${FILESDIR}/python-2.6-test-cross.patch"
-	else
+	if ! tc-is-cross-compiler; then
 		rm "${WORKDIR}/${PV}"/*_all_crosscompile.patch
 	fi

So, that shows just 3 dropped cross-compile related patches presumably merged upstream. Looking at those, doesn't really look like a good candidate for causing this borkage either. NFC.
Comment 12 Sebastian Pipping gentoo-dev 2010-03-22 20:51:00 UTC
Calling for help from the Python team: Python-related, cannot reproduce
Comment 13 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2010-03-22 20:58:52 UTC
(In reply to comment #12)

Could you create a small reproduction script?
Comment 14 Doktor Notor 2010-03-22 21:08:17 UTC
(In reply to comment #13)
> (In reply to comment #12)
> 
> Could you create a small reproduction script?

Well, if he can't reproduce, it will be kinda hard I'd say *g*

# layman -a devnull 
(or any other mercurial-based overlay) -> claims success but nothing fetched

# layman -S (with mercurial-based overlay already fetched) -> failure in different ways (comment #0, comment #1 + Comment #9)

Comment 15 Dirkjan Ochtman gentoo-dev 2010-03-23 09:40:58 UTC
Wow, that's pretty weird. I'll try to find out more from the hg side of things.
Comment 16 Eugene Shalygin 2010-03-24 00:14:46 UTC
However, something like layman-2.6 -a devnull works fine
Comment 17 Optimus 2010-03-24 05:04:11 UTC
layman -s devnull
* Running command "cd "/usr/local/overlays/layman/devnull" && /usr/bin/hg pull -u "http://hg.core.ws/devnull""...
Usage:

layman (-a|-d|-s|-i) OVERLAY
layman -f [-o URL]
layman (-l|-L|-S)

layman: error: no such option: -u
*
* Errors:
* ------
*
* Failed to sync overlay "devnull".
* Error was: Syncing overlay "devnull" returned status 512!
*

layman-2.6 -s devnull
* Running command "cd "/usr/local/overlays/layman/devnull" && /usr/bin/hg pull -u "http://hg.core.ws/devnull""...
pulling from http://hg.core.ws/devnull
searching for changes
no changes found
*
* Success:
* ------
*
* Successfully synchronized overlay "devnull".
Comment 18 Dennis Schridde 2010-03-24 07:56:36 UTC
Confirming for oss-overlay:
* Running command "cd "/var/cache/portage/layman/oss-overlay" && /usr/bin/hg pull -u "http://hg.atheme.org/users/majeru/portage-overlay/""...
[...skipping already known part...]
Comment 19 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2010-03-24 08:07:09 UTC
I fixed a bug in a patch for Python. Please wait about 1 hour, synchronize the tree, reinstall Python and check if you can still reproduce this bug.
Comment 20 Doktor Notor 2010-03-24 08:43:19 UTC
(In reply to comment #19)
> I fixed a bug in a patch for Python. Please wait about 1 hour, synchronize the
> tree, reinstall Python and check if you can still reproduce this bug.

Please post a URL to the patchset since it's missing on the mirrors. (And on that note, similar changes require a revbump). 

Comment 21 Doktor Notor 2010-03-24 09:15:16 UTC
Ok, here's a working URL for those who cannot fetch it... http://gentoo.osuosl.org/distfiles/python-gentoo-patches-2.6.5-r1.tar.bz2

Whatever, FIXED for me. I assume the 61_all_process_data.patch was at fault here w/ python-2.6.5 :)
Comment 22 Nikolaj Šujskij 2010-03-24 09:48:53 UTC
Works for me too.
+1 for revbump.
Comment 23 Alex D-Bug 2010-03-24 09:53:26 UTC
Seems, working correctly, thanks =)
Comment 24 tman 2010-03-24 14:38:46 UTC
is this patch already in portage? if not please put to there and set this as resolved.

thx
Comment 25 Ben de Groot (RETIRED) gentoo-dev 2010-03-24 15:05:34 UTC
It is in portage, but python needs a revbump for this to be properly solved.
Comment 26 Brian Harring gentoo-dev 2010-03-24 21:49:34 UTC
(In reply to comment #25)
> It is in portage, but python needs a revbump for this to be properly solved.

Bad Arfie, you know better then to change the install image w/out a revbump...
Comment 27 Petteri Räty (RETIRED) gentoo-dev 2010-03-24 22:01:08 UTC
(In reply to comment #26)
> (In reply to comment #25)
> > It is in portage, but python needs a revbump for this to be properly solved.
> 
> Bad Arfie, you know better then to change the install image w/out a revbump...
> 

There's no entry in ChangeLog either.
Comment 28 Alexandre Ney 2010-03-25 12:49:15 UTC
Hello all,

i re-emerged python 2.6.5 and layman is now working for mercurial overlays.

Python should get bumped because the cause of the error is really not obvious.

Thanks for your work !
Comment 29 Marcus Becker 2010-03-25 20:08:38 UTC
after emerge --oneshot python-2.6.5 it works here as well, thanks :)
Comment 30 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2010-03-25 20:26:36 UTC
dev-lang/python-2.6.5-r1 was added to fix other bugs, so this bug can be closed.

I was planning to add new revision after confirmation that the change fixes anything. If people in bug #286191 had tested the last attached patches, then they might have found problem with layman earlier.
Comment 31 Ben de Groot (RETIRED) gentoo-dev 2010-03-26 12:17:56 UTC
*** Bug 311427 has been marked as a duplicate of this bug. ***