Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 310373 - media-libs/libdvdread-4.1.3_p1168 fails to build whilst attempting to run aclocal
Summary: media-libs/libdvdread-4.1.3_p1168 fails to build whilst attempting to run acl...
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Portage team
URL: http://zeeraks.pastebin.com/sW5fmtfk
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-20 13:20 UTC by Zeerak Waseem
Modified: 2010-03-24 08:42 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,1.92 KB, text/plain)
2010-03-20 13:32 UTC, Samuli Suominen
Details
Build log with --debug option (build.log,92.68 KB, text/plain)
2010-03-22 19:52 UTC, Zeerak Waseem
Details
.bashrc for user (.bashrc,706 bytes, text/plain)
2010-03-22 19:57 UTC, Zeerak Waseem
Details
emerge --info (emerge.info,9.74 KB, text/plain)
2010-03-22 19:58 UTC, Zeerak Waseem
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zeerak Waseem 2010-03-20 13:20:00 UTC
When emerge -uDN @world prompts for media-libs/libdvdread-4.1.3_p1168 to be updated, the emerge begins and the first "error" (I'm not sure it really is an error as such) seems to be that the eclass autotools is inherented illegally.
Second error seems to be that the wrong source is unpacked, and thus the correct source cannot be found and then the final error is aclocal failing.

It should also be said that I have tried more than one rsync mirror and attempted to cleanup /var/tmp/portage/

Reproducible: Always

Steps to Reproduce:
1. Add '=media-libs/libdvdread-4.1.3_p1168 ~amd64' to package.keywords
2. Emerge/Update libdvdread
3. Let the error unfold

Actual Results:  
Ebuild unpacks wrong source and thus fails to build

Expected Results:  
Ebuild unpacks correct source and builds

# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-march=core2 -O2 -pipe"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
USE="-gtk -gnome -kde -qt4 -qt3 -hal -firefox -thunar -dri -pam -consolekit -gstreamer -cairo X branding usb truetype acpi alsa dts dvd dvdr ldap libnotify mad opengl spell xml lm_sensors"
MAKEOPTS="-j4"
ACCEPT_KEYWORDS="~amd64"

GENTOO_MIRRORS="ftp://ftp.df.lth.se/pub/gentoo/" 
# GENTOO_MIRRORS="http://ftp.klid.dk/ftp/gentoo/"
# GENTOO_MIRRORS="ftp://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/"

# SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
SYNC="rsync://rsync21.us.gentoo.org/gentoo-portage"

VIDEO_CARDS="nv"
INPUT_DEVICES="keyboard synaptics"
ALSA_CARDS="hda-intel"
LINGUAS="en_GB"
# License Options
ACCEPT_LICENSE=""

# Emerge Options
EMERGE_DEFAULT_OPTS="--ask --verbose --alphabetic --tree --with-bdeps=y"
PORTAGE_BINHOST="http://tinderbox.dev.gentoo.org/default-linux/amd64/"

# Overlay stuff 
source /var/lib/layman/make.conf
Comment 1 Samuli Suominen gentoo-dev 2010-03-20 13:32:56 UTC
Created attachment 224371 [details]
build.log

Attach build.log here from pastebin in $url ...

Please don't use pastebin links in bugzilla because they expire, thanks.
Comment 2 Zac Medico gentoo-dev 2010-03-21 00:07:09 UTC
Do you have anything in /etc/portage/bashrc or /etc/portage/env that might cause this? If not, please try again with --debug and post the log. Also, please post emerge --info.
Comment 3 Zeerak Waseem 2010-03-22 19:52:10 UTC
Created attachment 224765 [details]
Build log with --debug option
Comment 4 Zeerak Waseem 2010-03-22 19:54:31 UTC
Comment on attachment 224765 [details]
Build log with --debug option

I can't imagine what there should be. But I'll attach my emerge --info and my .bashrc
Comment 5 Zeerak Waseem 2010-03-22 19:57:38 UTC
Created attachment 224769 [details]
.bashrc for user

There doesn't exist any .bashrc file for root.
Comment 6 Zeerak Waseem 2010-03-22 19:58:08 UTC
Created attachment 224771 [details]
emerge --info
Comment 7 Zeerak Waseem 2010-03-22 20:00:57 UTC
Comment on attachment 224765 [details]
Build log with --debug option

I just realized that you asked for /etc/portage/bashrc (and i'll correct the attatchment) but I've never edited either of the files (and sorry for spamming, I couldn't quite see how to attatch more than one file at a time)
Comment 8 Zac Medico gentoo-dev 2010-03-23 00:13:41 UTC
For some reason, it seems to be getting the wrong metadata from the cache. This triggers the warning about illegal autotools inherit, since the INHERITED value from the cache is wrong. The same goes for SRC_URI. So, we need to see where that cache value is coming from. Please check to see whether these two files exist and what their content is:

  /var/cache/edb/dep/usr/portage/media-libs/libdvdread-4.1.3_p1168
  /usr/portage/metadata/cache/media-libs/libdvdread-4.1.3_p1168
Comment 9 Zeerak Waseem 2010-03-23 11:57:30 UTC
I don't seem to have /var/cache/edb/dep/usr/portage/media-libs/libdvdread-4.1.3_p1168 (and I don't have the files /etc/portage/bashrc and /etc/portage/env either)
The other file I do have however and the contents of it are:
------

0
http://www.ijg.org/files/jpegsrc.v8a.tar.gz mirror://debian/pool/main/libj/libjpeg7/libjpeg7_7-1.diff.gz

http://jpegclub.org/ http://www.ijg.org/
as-is
Library to load, handle and manipulate images in the JPEG format
~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris
eutils libtool multilib portability toolchain-funcs




2

configur

------
An additional comment, I tried keywording the atom and then do the update, which resulted in the same error but with another package, cmake. In this case it unpacks the source of term-ansicolor (but I thought I'd wait and see with this bug first and then file a bug)
Comment 10 Zac Medico gentoo-dev 2010-03-23 16:15:55 UTC
(In reply to comment #9)
> http://www.ijg.org/files/jpegsrc.v8a.tar.gz
> mirror://debian/pool/main/libj/libjpeg7/libjpeg7_7-1.diff.gz

It looks like you definitely have some file corruption inside /usr/portage/metadata/cache/. You should probably just remove your whole portage tree and start with a new one. The emerge-webrsync program is probably the best way to do that.
Comment 11 Zeerak Waseem 2010-03-24 00:58:05 UTC
(In reply to comment #10)
> (In reply to comment #9)
> > http://www.ijg.org/files/jpegsrc.v8a.tar.gz
> > mirror://debian/pool/main/libj/libjpeg7/libjpeg7_7-1.diff.gz
> 
> It looks like you definitely have some file corruption inside
> /usr/portage/metadata/cache/. You should probably just remove your whole
> portage tree and start with a new one. The emerge-webrsync program is probably
> the best way to do that.
> 

Yup you were absolutely right. There was some file corruption (the partition however was fine). I changed portdir etc. got the tarball and tried to run the update and it's working like a charm.
Thanks for the help.
I wasn't sure whether to change the resolution to fixed or invalid so I'll leave that up to you :-)
Comment 12 Zac Medico gentoo-dev 2010-03-24 08:42:45 UTC
Given the current cache format, there's nothing we can do to detect cases like this. However, we might add some more validation data in the future.