Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 310317 - media-plugins/audacious-plugins-2.3_beta2: USF plugin does not compile on 32-bit X86 platforms
Summary: media-plugins/audacious-plugins-2.3_beta2: USF plugin does not compile on 32-...
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Tony Vroon
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-20 06:56 UTC by Cyril42e
Modified: 2010-03-24 01:02 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info =media-plugins/audacious-plugins-2.3_beta2 (audacious-plugins-2.3_beta2.info.log,4.82 KB, text/plain)
2010-03-20 06:58 UTC, Cyril42e
Details
emerge -pqv =media-plugins/audacious-plugins-2.3_beta2 (audacious-plugins-2.3_beta2.pqv.log,275 bytes, text/plain)
2010-03-20 06:59 UTC, Cyril42e
Details
build.log (audacious-plugins-2.3_beta2.build.log,23.67 KB, text/plain)
2010-03-20 06:59 UTC, Cyril42e
Details
environment (audacious-plugins-2.3_beta2.env.log,98.84 KB, text/plain)
2010-03-20 06:59 UTC, Cyril42e
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cyril42e 2010-03-20 06:56:53 UTC
When compiling the package with gcc 4.4.3 or 4.3.2 or 4.1.2 on x86 I get the following error:
usf/memory.c:68: error: ‘MAP_32BIT’ undeclared (first use in this function)



Reproducible: Always

Steps to Reproduce:
1.emerge -avt =media-plugins/audacious-plugins-2.3_beta2
Actual Results:  
Entering directory usf.
[...]
memory.c:68: error: ‘MAP_32BIT’ undeclared (first use in this function)

Expected Results:  
Successfully compiled memory.c.


emerge --info, emerge -pqv, build.log, environment attached
Comment 1 Cyril42e 2010-03-20 06:58:15 UTC
Created attachment 224327 [details]
emerge --info =media-plugins/audacious-plugins-2.3_beta2
Comment 2 Cyril42e 2010-03-20 06:59:05 UTC
Created attachment 224329 [details]
emerge -pqv =media-plugins/audacious-plugins-2.3_beta2
Comment 3 Cyril42e 2010-03-20 06:59:28 UTC
Created attachment 224331 [details]
build.log
Comment 4 Cyril42e 2010-03-20 06:59:50 UTC
Created attachment 224333 [details]
environment
Comment 5 Bartosz Brachaczek 2010-03-20 18:54:20 UTC
Same here. Probably the fix is: http://hg.atheme.org/audacious-plugins/audacious-plugins/rev/cf740d37e431
Comment 6 Andrey Falko 2010-03-21 02:07:42 UTC
I'm seeing the same exact issue on my x86 box. Here is my emerge --info just in it helps: 

Portage 2.1.8.3 (default/linux/x86/10.0, gcc-4.4.3, glibc-2.11-r1, 2.6.30.6 i686)                
=================================================================                                
System uname: Linux-2.6.30.6-i686-AMD_Phenom-tm-_9850_Quad-Core_Processor-with-gentoo-2.0.1      
Timestamp of tree: Sat, 20 Mar 2010 15:30:01 +0000                                               
distcc 3.1 i686-pc-linux-gnu [disabled]                                                          
app-shells/bash:     4.1_p2                                                                      
dev-java/java-config: 2.1.10                                                                     
dev-lang/python:     2.6.4-r1, 3.1.1-r1                                                          
dev-python/pycrypto: 2.1.0                                                                       
dev-util/cmake:      2.8.1                                                                       
sys-apps/baselayout: 2.0.1                                                                       
sys-apps/openrc:     0.6.0-r1                                                                    
sys-apps/sandbox:    2.2                                                                         
sys-devel/autoconf:  2.13, 2.65                                                                  
sys-devel/automake:  1.7.9-r1, 1.9.6-r3, 1.10.3, 1.11.1                                          
sys-devel/binutils:  2.20.1                                                                      
sys-devel/gcc:       4.4.3                                                                       
sys-devel/gcc-config: 1.4.1                                                                      
sys-devel/libtool:   2.2.6b                                                                      
virtual/os-headers:  2.6.33                                                                      
ACCEPT_KEYWORDS="x86 ~x86"                                                                       
ACCEPT_LICENSE="* -@EULA ut2003 dlj-1.1 skype-eula QUAKE4"                                       
CBUILD="i686-pc-linux-gnu"                                                                       
CFLAGS="-O2 -march=athlon64 -pipe"                                                               
CHOST="i686-pc-linux-gnu"                                                                        
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb"                       
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"    
CXXFLAGS="-O2 -march=athlon64 -pipe"                                                             
DISTDIR="/in/portage"                                                                            
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"                                                   
GENTOO_MIRRORS="http://distfiles.gentoo.org"                                                     
LDFLAGS="-Wl,-O1"
LINGUAS="en ru"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/gnash-cvs /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acl alsa apache2 arts bash-completion berkdb branding bzip2 cairo cdda cddb cli cracklib crypt cups curl cxx dbus dri dts dvb dvd dvdread encode enscript exif fax fbcon ffmpeg firefox flac foomaticdb fortran gd gdbm gif gimpprint gphoto2 gpm gstreamer hal iconv imap imlib iproute2 ipv6 java jpeg kde kpathsea lame libwww lirc lm_sensors mad maildir matroska mikmod mjpeg mng modules motif mp3 mpeg mplayer mudflap mysql ncurses nls nptl nptlonly nsplugin nvidia offensive ogg openal opengl openmp optimisememory oss pam pcre pdf perl php png postfix postgres ppds pppd python qt3support qt4 quicktime readline reflection rpm rtsp sasl scanner sdl sdl-image secure-delete semantic-desktop session snmp sound speex spell spl sql ssl ssse3 stream subversion svg sysfs tcpd tetex theora threads tiff tk truetype unicode usb v4l v4l2 vcd vim-syntax vorbis webdav win32codecs wxwindows x264 x86 xcb xinerama xml xorg xv xvid zlib" ALSA_CARDS="usb-usx2y hdsp hdspm" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" FOO2ZJS_DEVICES="hp1020" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en ru" LIRC_DEVICES="hauppauge" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 7 Paul Bredbury 2010-03-21 04:14:01 UTC
(In reply to comment #5)
> Same here. Probably the fix is:
> http://hg.atheme.org/audacious-plugins/audacious-plugins/rev/cf740d37e431

Yes, this fixes the compilation. Raw patch download URL:
http://hg.atheme.org/audacious-plugins/audacious-plugins/raw-rev/cf740d37e431
Comment 8 geoscope 2010-03-23 11:43:20 UTC
I like having some plugins for audacious, but I can't imagine wanting to ever have or play game console music. I know some people might. Seems like a good case for a USE flag (if that is possible), particularly since in this case, the error is directly related to an experimental plugin.

I realize that is not a fix for a compile error, and that the patch described should fix it, but when I encountered this error, and read up through the configure process to see what the error was related to, my first thought was, "I never had a Nintendo64 or NintendoDS, would never want the music, and what the heck is audacious-plugins building *experimental* plugins for without asking me?"

  Input Plugins
  -------------
  MPEG 1/2/3 (madplug):                   yes
  MPEG 4 Audio (AAC):                     yes
  FFaudio (ffaudio):                      yes
  Module decoder (modplug):               yes
  MIDI modular plugin (amidi-plug):       no
    -> ALSA backend:                      yes
    -> FluidSynth backend:                no
  CD Digital Audio (cdaudio_ng):          yes
  sndfile extensions:                     no
  Tone Generator:                         yes
  Ogg Vorbis (vorbis):                    yes
  Free Lossless Audio Codec (flacng):     yes
  Commodore 64 audio (SID):               no 
    -> libSIDPlay1 support:               
    -> libSIDPlay2 support:               
    -> distortion patched libSIDPlay2:    
  Game music (spc, nsf & gbs):            yes
  PlayStation (psf/psf2) audio (psf):     yes
  Nintendo 64 audio (usf):                yes experimental
  Nintendo DS audio (xsf):                yes experimental
  AdLib synthesizer (adplug):             no
  Apple Lossless Audio Codec (alac):      yes
  WavPack 4.31+ (wavpack):                no
  Metronom:                               yes


The only catch I see is that the .configure script itself doesn't seem to have enable/disable flags for those plugins (see below). Maybe a request needs to made upstream?

./configure --prefix=/usr --build=i686-pc-linux-gnu --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --enable-chardet --enable-dbus --enable-modplug --enable-neon --disable-projectm --disable-adplug --enable-aac --enable-alsa --enable-bluetooth --enable-amidiplug-alsa --disable-coreaudio --disable-dockalbumart --disable-bs2b --enable-cdaudio --disable-cue --disable-debug --disable-esd --enable-ffaudio --enable-flacng --disable-amidiplug-flsyn --enable-filewriter_flac --enable-icecast --enable-ipv6 --disable-jack --enable-gnomeshortcuts --disable-filewriter_mp3 --disable-lirc --enable-mp3 --disable-amidiplug --disable-mtp_up --enable-nls --disable-oss --disable-projectm-1.0 --disable-pulse --disable-paranormal --disable-sid --disable-sndfile --enable-sse2 --enable-vorbis --enable-filewriter_vorbis --disable-wavpack


I'm new to putting modified ebuilds in a local overlay, picking through portage logs to understand what errors occur and bug reporting, so if any of my assumptions are wrong, please correct me. Those assumptions being:

1. None of my current USE flags enable the game console plugins
2. No current USE flag can be set/unset to disable their being built
3. Not everyone would want the set of game console plugins  (I would think few people would)
4. Experimental plugins ought to have a .configure option to enable/disable.
5. There are no such options shown during the configure process.
6. This isn't a gentoo/portage/ebuild issue (aside from using a patch file, and currently -- a local ebuild, with an epatch line -- to correctly build a plugin I wouldn't use anyway.)

7. More a question than an assumption, are these plugins new since the version bump from 2.2?

Also, if this isn't the right place to be asking these questions (IE I should be posting in the forums), please pm me, and apologies.
Comment 9 Sunit Das 2010-03-23 16:12:55 UTC
Same failure here... will also test the patch when I have time
Comment 10 Tony Vroon gentoo-dev 2010-03-23 21:54:49 UTC
(In reply to comment #5)
> Same here. Probably the fix is:
> http://hg.atheme.org/audacious-plugins/audacious-plugins/rev/cf740d37e431

No, that is not the proper fix. See later upstream commits that beat the plugin into shape.
Comment 11 Sunit Das 2010-03-23 22:57:25 UTC
Bump for beta3?
Comment 12 Tony Vroon gentoo-dev 2010-03-24 00:01:17 UTC
+*audacious-plugins-2.3_beta3 (23 Mar 2010)
+
+  23 Mar 2010; <chainsaw@gentoo.org> -audacious-plugins-2.3_beta2.ebuild,
+  +audacious-plugins-2.3_beta3.ebuild:
+  New beta, USF plugin now disabled by default. A dozen of free minor bug
+  fixes to boot.
Comment 13 Weeve 2010-03-24 00:24:53 UTC
For clarification, this was happening on SPARC as well (32 bit userland).
Comment 14 Tony Vroon gentoo-dev 2010-03-24 01:02:29 UTC
(In reply to comment #13)
> For clarification, this was happening on SPARC as well (32 bit userland).

Yes, this is why USF is now restricted to X86 & AMD64 Linux platforms and has to be manually enabled (defaults to off).