Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 310297 - dev-libs/icu-4.4 doesn't install libicutest.so.44 needed by icuinfo
Summary: dev-libs/icu-4.4 doesn't install libicutest.so.44 needed by icuinfo
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Arfrever Frehtes Taifersar Arahesis (RETIRED)
URL: https://bugs.icu-project.org/trac/tic...
Whiteboard:
Keywords:
: 310359 312741 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-03-19 22:07 UTC by Lars Wendler (Polynomial-C)
Modified: 2010-07-27 13:43 UTC (History)
48 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
icu-4.4-ctestfw-makefilein.patch (icu-4.4-ctestfw-makefilein.patch,1.16 KB, patch)
2010-03-19 22:09 UTC, Lars Wendler (Polynomial-C)
Details | Diff
icu-4.4.ebuild.diff (icu-4.4.ebuild.diff,693 bytes, patch)
2010-03-19 22:11 UTC, Lars Wendler (Polynomial-C)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Wendler (Polynomial-C) gentoo-dev 2010-03-19 22:07:48 UTC
After upgrading to icu-4.4 revdep-rebuild complains about the following lib missing on the system:

[ 12% ]  *   broken /usr/bin/icuinfo (requires libicutest.so.44)

It seems like the Makefile{,.in} is missing some lines in the install section.

I _blindly_ copy'n'pasted the install section from another Makefile.in and that seems to fix the problem.

Reproducible: Always

Steps to Reproduce:
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2010-03-19 22:09:26 UTC
Created attachment 224287 [details, diff]
icu-4.4-ctestfw-makefilein.patch

Please give this file a thorough review. I'm in no way a Makefile-guru and simply copied these lines from another Makefile.in which I found in the icu package.
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2010-03-19 22:11:49 UTC
Created attachment 224289 [details, diff]
icu-4.4.ebuild.diff
Comment 3 Doktor Notor 2010-03-20 07:05:26 UTC
You are missing inherit autotools there... WFM otherwise. Wondering about the amount of testing this receives upstream before releasing, b/c this is just plain WTF.

(And warning for the maintainer, do not attempt full eautoreconf or this piece of junk fails miserably.)
Comment 4 Doktor Notor 2010-03-20 07:08:23 UTC
While at it, append-flags -fno-strict-aliasing please, the amount of QA warnings produced is quite alarming.
Comment 5 Lars Wendler (Polynomial-C) gentoo-dev 2010-03-20 08:50:30 UTC
(In reply to comment #3)
> You are missing inherit autotools there...

You better have another look at icu-4.4.ebuild.diff again. I didn't forget it.
Comment 6 Doktor Notor 2010-03-20 08:53:35 UTC
(In reply to comment #5)
> You better have another look at icu-4.4.ebuild.diff again. I didn't forget it.

Yeah, I apparently need another bucket of my morning coffee *g*

Comment 7 Lars Wendler (Polynomial-C) gentoo-dev 2010-03-20 09:18:56 UTC
Someone filed this upstream already (see URL)
Comment 8 Pacho Ramos gentoo-dev 2010-03-20 11:03:48 UTC
*** Bug 310359 has been marked as a duplicate of this bug. ***
Comment 9 Chris Smith 2010-03-20 18:08:50 UTC
Ditto
Comment 10 Stephan Friedrichs 2010-03-23 20:59:01 UTC
I suggest to mask =dev-libs/icu-4.4 until it's patched or a new version is pulled in from upstream.
Comment 11 Thomas Raschbacher gentoo-dev 2010-03-24 14:41:46 UTC
the question is will masking 4.4 cause another problem cuz of deps already rebuilt for this version?
- otherwise i'm all for a mask as my webkit-gtk won'T build either..
Comment 12 Juergen Rose 2010-03-24 15:09:09 UTC
But webkit-gtk can be installed with icu-4.4 and the Comment  webkit-icu-4.4-portage.patch of Comment #18 of Bug #308699.
Comment 13 Daniel Lin 2010-03-24 15:10:39 UTC
(In reply to comment #10)
> I suggest to mask =dev-libs/icu-4.4 until it's patched or a new version is
> pulled in from upstream.

Nothing aside from /usr/bin/icuinfo links against libicutest.so.44, as far as I'm aware.  So it's annoying, but is it serious enough to warrant a mask?

(In reply to comment #11)
> the question is will masking 4.4 cause another problem cuz of deps already
> rebuilt for this version?
> - otherwise i'm all for a mask as my webkit-gtk won'T build either..

Yes, everything you built against the libicu*.so.44 sonames will have to be rebuilt if you go back down to libicu*.so.42.

There's a fix for webkit-gtk building with ICU 4.4 in bug #308699.
Comment 14 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2010-03-24 15:12:47 UTC
This bug isn't serious enough to mask =dev-libs/icu-4.4*.
Comment 15 Doktor Notor 2010-03-24 15:48:27 UTC
Uh, don't mask this. People will have to recompile lots of compile-intensive stuff yet again (notably, Openoffice).
Comment 16 Stephan Friedrichs 2010-03-24 17:17:20 UTC
(In reply to comment #15)
> Uh, don't mask this. People will have to recompile lots of compile-intensive
> stuff yet again (notably, Openoffice).
> 

Then mask it to save them from compiling openoffice twice (once for the update of icu and once for the downgrade, because icu is (a) broken and (b) because webkit-gtk doesn't work with it, either)!
Comment 17 Doktor Notor 2010-03-24 17:20:43 UTC
(In reply to comment #16)
> Then mask it to save them from compiling openoffice twice (once for the update
> of icu and once for the downgrade, because icu is (a) broken and (b) because
> webkit-gtk doesn't work with it, either)!

How about that someone goes and commits the darned patches instead? Masking doesn't fix any issue. 

Comment 18 Thomas Raschbacher gentoo-dev 2010-03-24 17:53:37 UTC
i did not have to re-compile openoffice but xulrunner / mozilla stuff and sqlite
Comment 19 Doktor Notor 2010-03-24 17:58:51 UTC
(In reply to comment #18)
> i did not have to re-compile openoffice but xulrunner / mozilla stuff and
> sqlite

Well, that's kinda very weird and sounds like OO.org bundling its own icu yet again despite depending on >=dev-libs/icu-4, a.k.a. a bug. 

Comment 20 Thomas Raschbacher gentoo-dev 2010-03-25 09:23:52 UTC
wellto be honest i didn'T try to use OOo but revdep-rebuild dit not find anything to do with it afaik

so anyway .. does the patch attached here work now or not? if yes i vote for adding it .. ;)
Comment 21 Stephan Friedrichs 2010-03-25 09:47:08 UTC
(In reply to comment #17)
> (In reply to comment #16)
> > Then mask it to save them from compiling openoffice twice (once for the update
> > of icu and once for the downgrade, because icu is (a) broken and (b) because
> > webkit-gtk doesn't work with it, either)!
> 
> How about that someone goes and commits the darned patches instead? Masking
> doesn't fix any issue. 
> 

Please don't get me wrong - that would be my favourite solution as well! I suggested masking icu, because patching seems to take ages :(
Comment 22 Lars Wendler (Polynomial-C) gentoo-dev 2010-03-25 16:10:05 UTC
The patch works (I'm using it on all of my machines) but as long as there's not even a single comment from upstream about the bug and a proper fix (I still don't know if the patch I attached here is the right solution) we cannot simply add a patch that might lead to other (maybe even more severe) problems.
If you cannot wait till this is fixed, just copy the ebuild to your local overlay and apply the patch there.
Comment 23 josef.95 2010-03-25 17:35:31 UTC
(In reply to comment #22)
> The patch works (I'm using it on all of my machines) but as long as there's not
> even a single comment from upstream about the bug and a proper fix (I still
> don't know if the patch I attached here is the right solution) we cannot simply
> add a patch that might lead to other (maybe even more severe) problems.
> If you cannot wait till this is fixed, just copy the ebuild to your local
> overlay and apply the patch there.
> 
Good Idea
Here works fine
thank you!
Comment 24 hirakendu 2010-03-27 20:04:14 UTC
thank you :)
Comment 25 Matti Bickel (RETIRED) gentoo-dev 2010-03-27 20:11:38 UTC
Seems to be accepted as a bug as of today.
Comment 26 Lars Wendler (Polynomial-C) gentoo-dev 2010-03-30 02:48:21 UTC
Seems like upstream included the patch:

https://bugs.icu-project.org/trac/changeset/27878

But the bug is still open (for review?) so maybe we should still wait with fixing this in our package...
Comment 27 Robert Cabrera 2010-03-31 00:35:06 UTC
Please add these fixes to portage ASAP. I was having all kinds of problems with this and couldn't figure it out. Posted in the forums and got no help. I even went as far as to rebuild my entire system over the weekend to try and fix revdep-rebuild to no avail. Then I found this bug report. 

What a waste of 32 hours that I could have avoided if I had found this earlier! 

If it's already been included upstream then can't we just go ahead and ad it now? It's a heck of a lot simpler to rebuild this than have to rebuild Open Office! On my machine it takes damn near 6 hours to rebuild OO. 

Again, please fix this ASAP. TIA
Comment 28 Jochen Schlick 2010-04-01 23:13:19 UTC
patch works fine on AMD64 and i386 platform
Comment 29 Lars Wendler (Polynomial-C) gentoo-dev 2010-04-02 04:39:09 UTC
*** Bug 312741 has been marked as a duplicate of this bug. ***
Comment 30 Bruno Barão 2010-04-04 10:36:01 UTC
The patch also works for me.
Comment 31 Budanov "r0g3r" Eugene 2010-04-05 14:49:17 UTC
Thanks for patch. It works.
Comment 32 Matthias Fulz 2010-04-08 12:47:57 UTC
patch is working for me.
Comment 33 Timothy Miller 2010-04-08 14:44:04 UTC
I think I'm running into this same problem.  Every time I revdep-rebuild, it re-emerges dev-libs/icu because /usr/bin/icuinfo requires libicutest.so.44., which is missing.  I'm on ~amd64.

[ebuild   R   ] dev-libs/icu-4.4  USE="-debug -doc -examples" 0 kB
Comment 34 Patrick Lerner 2010-04-10 05:48:11 UTC
Patch fixed the issue I've had for the past weeks, too. That is, revdep-rebuild always rebuilding dev-libs/icu.
Comment 35 Dan Ziemba 2010-04-12 22:08:48 UTC
Patch works for me as well on ~amd64
Comment 36 Lars Wendler (Polynomial-C) gentoo-dev 2010-04-15 17:28:18 UTC
arfrever can I get your permission to finally fix this bug? It's been open long enough now and upstream has scheduled the fix for icu-4.4.1 so no need to wait any longer IMHO...
Comment 37 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2010-04-15 23:33:06 UTC
Fixed in dev-libs/icu-4.4-r1.
Comment 38 Steven R. Loomis 2010-04-20 05:08:53 UTC
http://bugs.icu-project.org/trac/ticket/7567
upstream bug has been reviewed and targetted for release in http://bugs.icu-project.org/trac/milestone/4.4.1
 
Note, this library should not be required for this particular task, and may be removed from install in the future.

Mea culpa.
Comment 39 Steven R. Loomis 2010-04-20 05:09:57 UTC
Also, I will try to watch here for downstream bugs. Thanks for filing the bug in ICU.

(srl,  Tech lead, ICU for C/C++)