Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 310133 - x11-misc/xkeyboard-config: missing dependency dev-perl/XML-Parser
Summary: x11-misc/xkeyboard-config: missing dependency dev-perl/XML-Parser
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High minor (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-18 20:33 UTC by Michael Mounteney
Modified: 2013-12-19 15:29 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Mounteney 2010-03-18 20:33:18 UTC
during emerge of xkeyboard-config, the following message appears during the configuration phase:

error:  XML::Parser... configure: error: XML::Parser perl module is required for intltool

Reproducible: Always

Steps to Reproduce:
1. start with a clean system without XML::Parser
2. emerge xkeyboard-config
Actual Results:  
The error message given in the 'description' step above, appears.

Expected Results:  
The message should not appear.  The package should be configured and installed.

Obtained with a fresh installation of Gentoo Linux.   Copied the /var/lib/portage/world from the old installation and ran emerge -quDN world.

Workaround:  emerge -q1 dev-perl/XML-Parser, then emerge -quDN world.
Comment 1 Doktor Notor 2010-03-18 20:57:18 UTC
RDEPEND="x11-apps/xkbcomp"
DEPEND="${RDEPEND}
        >=dev-util/intltool-0.30
        dev-perl/XML-Parser"

You *must* run perl-cleaner after upgrading perl versions, as told by the elog message.

Comment 2 Michael Mounteney 2010-03-18 21:20:48 UTC
My apology.  As it was a new installation, there were 100s of packages and I missed perl-cleaner message in the elog.
Comment 3 Jeroen Roovers gentoo-dev 2013-12-19 15:29:19 UTC

*** This bug has been marked as a duplicate of bug 41124 ***