Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 309957 - media-libs/mesa-7.8_rc1: kwin desktop effects stopped working after mesa upgrade, bug in drivers/dri/intel/intel_context.c
Summary: media-libs/mesa-7.8_rc1: kwin desktop effects stopped working after mesa upgr...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
: 309973 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-03-17 16:36 UTC by Piotrek Juzwiak
Modified: 2010-07-27 13:43 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
intel_context.patch (intel_context.patch,859 bytes, patch)
2010-03-18 11:23 UTC, Johannes Hirte
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Piotrek Juzwiak 2010-03-17 16:36:11 UTC
After upgrading my system to libdrm-2.4.19 and mesa to 7.8_rc1 kwin can't turn desktop effects on. After running kwin with "kwin --replace --sync" then turning on desktop-effects it reported composite is not working or disabled (i have no xorg conf). Xorg.0.log reports composite as enabled.

After upgrading mesa i recompiled xorg-server (1.7.5.902)and all the drivers (xf86-video-intel xf86-input-mouse/evdev/keyboard). While the Xrender backend works it is painfully slow. Please tell me what more should i provide to resolve this issue.

Reproducible: Always

Steps to Reproduce:
1.Turn on desktop effects in KDE's system settings
2.
3.
Actual Results:  
It fails setting this up

Expected Results:  
It should turn on desktop-effects without complaining.
Comment 1 Andreas K. Hüttel gentoo-dev 2010-03-17 17:09:36 UTC
*** Bug 309973 has been marked as a duplicate of this bug. ***
Comment 2 Piotrek Juzwiak 2010-03-17 17:38:17 UTC
I try to troubleshoot it as much as i can.

I tried kwin --replace --sync and then tried to setup desktop-effects, that's where it failed...

kwin(2789) KWin::Workspace::setupCompositing: OpenGL compositing
kwin(2789) KWin::SceneOpenGL::initBufferConfigs: Drawable visual (depth  24 ): 0x "9e"
kwin(2789) KWin::SceneOpenGL::initBufferConfigs: Drawable visual (depth  32 ): 0x "59"
kwin(2789) KWin::SceneOpenGL::initBuffer: Buffer visual (depth  24 ): 0x "a0"
WARNING: Application calling GLX 1.3 function "glXCreatePixmap" when GLX 1.3 is not supported!  This is an application bug!
WARNING: Application calling GLX 1.3 function "glXQueryDrawable" when GLX 1.3 is not supported!  This is an application bug!
WARNING: Application calling GLX 1.3 function "glXDestroyPixmap" when GLX 1.3 is not supported!  This is an application bug!
kwin(2789): Compositing self-check failed, disabling compositing. 
kwin(2789): Failed to initialize compositing, compositing disabled 

I am using the 7.8_rc1 mesa (which apparently after much googling is it's fault since the earlier version worked flawlessly).
Comment 3 Piotrek Juzwiak 2010-03-17 17:45:31 UTC
When searching with google it looks that compiz would also be affected by that mesa upgrade.
Comment 4 Piotrek Juzwiak 2010-03-17 18:25:28 UTC
Just by changing mesa to 7.7.rc1 (and nothing else) i resolved the issue and when starting desktop-effects i get no messages about GLX 1.3
Comment 5 Johannes Hirte 2010-03-17 22:51:26 UTC
This is caused by git commit d449627829e1a4a3250a1a723af2f4e3cd5fd194 in mesa (had bisected it). Don't know if this is a bug in mesa or window manager.
Comment 6 Piotrek Juzwiak 2010-03-17 23:41:28 UTC
Maybe this thread will help (thouth it is compiz they are talking about i guess it should still apply?)

https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/433488

In other words IF i understood it fine it is kwin's fault?
Comment 7 Piotrek Juzwiak 2010-03-17 23:54:50 UTC
I submitted this bug to kde bugs in case it is kwin's fault and posted the link to this bug thread.
Comment 8 Piotrek Juzwiak 2010-03-18 03:16:45 UTC
I received a message from KDE developer:

"--- Comment #1 from Lucas Murray <lmurray undefinedfire com>  2010-03-18 03:32:06 ---
After a quick discussion with Kristian Høgsberg (Author of the bisected commit)
this is a Mesa regression and he is currently working on a fix."

Comment 9 Johannes Hirte 2010-03-18 11:23:15 UTC
Created attachment 224091 [details, diff]
intel_context.patch
Comment 10 Johannes Hirte 2010-03-18 11:25:13 UTC
patched upstream by Kristian Høgsberg

patch is trivial, if someone want's to apply to mesa in portage
Comment 11 Piotrek Juzwiak 2010-03-18 17:08:35 UTC
Unfortunatelly after patching it still doesn't work BUT i get another message now:

kwin(2134) KWin::SceneOpenGL::initRenderingContext: Couldn't initialize rendering context ("error: GLXBadContextTag[168], request: <unknown>[152], resource: 0x3201098")
kwin(2134): Failed to initialize compositing, compositing disabled

So the patch is a no go.
Comment 12 Johannes Hirte 2010-03-18 17:12:45 UTC
(In reply to comment #11)
> Unfortunatelly after patching it still doesn't work BUT i get another message
> now:
> 
> kwin(2134) KWin::SceneOpenGL::initRenderingContext: Couldn't initialize
> rendering context ("error: GLXBadContextTag[168], request: <unknown>[152],
> resource: 0x3201098")
> kwin(2134): Failed to initialize compositing, compositing disabled
> 
> So the patch is a no go.
> 

Ok, I have to look deeper in this. Git head works for me, so there must be some other change too for this.
Comment 13 Piotrek Juzwiak 2010-03-18 17:16:24 UTC
(In reply to comment #12)
> (In reply to comment #11)
> > Unfortunatelly after patching it still doesn't work BUT i get another message
> > now:
> > 
> > kwin(2134) KWin::SceneOpenGL::initRenderingContext: Couldn't initialize
> > rendering context ("error: GLXBadContextTag[168], request: <unknown>[152],
> > resource: 0x3201098")
> > kwin(2134): Failed to initialize compositing, compositing disabled
> > 
> > So the patch is a no go.
> > 
> 
> Ok, I have to look deeper in this. Git head works for me, so there must be some
> other change too for this.
> 

The patch is a no go BUT i was at least getting some screen (completely garbled) but still, without the patch i just got black screen with only my mouse pointer working :)
Comment 14 Piotrek Juzwiak 2010-03-18 17:33:56 UTC
BTW, would compiling kwin with -debug flag help?
Comment 15 Vasily 2010-03-18 17:46:13 UTC
Patched mesa works for me.
Comment 16 Piotrek Juzwiak 2010-03-18 17:49:08 UTC
(In reply to comment #15)
> Patched mesa works for me.
> 

What graphic card you got?
Comment 17 Andreas Sturmlechner gentoo-dev 2010-03-18 18:11:59 UTC
(In reply to comment #16)
> (In reply to comment #15)
> > Patched mesa works for me.
> > 
> 
> What graphic card you got?
> 

Confirmed for xf86-video-intel-9999 with GMA4500
Comment 18 Piotrek Juzwiak 2010-03-18 18:17:44 UTC
(In reply to comment #17)
> (In reply to comment #16)
> > (In reply to comment #15)
> > > Patched mesa works for me.
> > > 
> > 
> > What graphic card you got?
> > 
> 
> Confirmed for xf86-video-intel-9999 with GMA4500

How do you make it to work?

I setup local portage, i did put the patch in the files folder, after unpacking and while it was compiling i confirmed that this patch has been applied, after that i recompiled xorg-server 1.7.6 xf86-video-intel 2.10 and still it wasn't working. Maybe i have too low version of the intel drivers or what?
> 

Comment 19 Andreas Sturmlechner gentoo-dev 2010-03-18 18:39:21 UTC
(In reply to comment #18)
> (In reply to comment #17)
> > (In reply to comment #16)
> > > (In reply to comment #15)
> > > > Patched mesa works for me.
> > > > 
> > > 
> > > What graphic card you got?
> > > 
> > 
> > Confirmed for xf86-video-intel-9999 with GMA4500
> 
> How do you make it to work?
> 
> I setup local portage, i did put the patch in the files folder, after unpacking
> and while it was compiling i confirmed that this patch has been applied, after
> that i recompiled xorg-server 1.7.6 xf86-video-intel 2.10 and still it wasn't
> working. Maybe i have too low version of the intel drivers or what?
> > 
> 

1.) Applied it to the ebuild like that:

--- a/media-libs/mesa/mesa-7.8_rc1.ebuild    2010-03-16 16:27:10.000000000 +0100
+++ b/media-libs/mesa/mesa-7.8_rc1.ebuild    2010-03-18 17:50:47.000000000 +0100
@@ -101,6 +101,10 @@
                EPATCH_SUFFIX="patch" \
                epatch
        fi
+
+       # bug 309957 (patch from upstream git)
+        epatch "${FILESDIR}/0002-intel_context.patch"
+
        # FreeBSD 6.* doesn't have posix_memalign().
        [[ ${CHOST} == *-freebsd6.* ]] && \
                sed -i -e "s/-DHAVE_POSIX_MEMALIGN//" configure.ac

2.) Only updated to xorg-server-1.7.6 afterwards as xf86-video-intel is on latest commit. Also, i915-KMS built in kernel-2.6.33, just for the record
Comment 20 Vasily 2010-03-18 19:48:37 UTC
(In reply to comment #16)
> (In reply to comment #15)
> > Patched mesa works for me.
> > 
> 
> What graphic card you got?
> 
intel 945gm, used same way as Andreas did (custom overlay with customized mesa ebuild), but I'm using xf86-video-intel-2.10.0-r1.
Comment 21 Piotrek Juzwiak 2010-03-18 20:02:04 UTC
Seems i didn't understand the wiki about local portage and thought that patches are automatically pulled from the files directory.

And before that i just changed the file without resolving to patch and compressed back which didn't work as it looks.

But after properly applying the patch it works i can confirm it. Works with no problems.
Comment 22 Andreas K. Hüttel gentoo-dev 2010-03-18 20:20:04 UTC
Reassigning to x11 team. Removing amd64 from CC.
Comment 23 Tassilo Horn 2010-03-19 07:11:04 UTC
I can also confirm that the patch works for me using x11-drivers/xf86-video-intel-2.10.0-r1.
Comment 24 darkbasic 2010-03-24 10:37:35 UTC
Shouldn't the bug be closed? It is fixed (at least for me) with mesa7.8_rc2...

Intel GMA x4500
xf86-video-intel-2.10.903
linux-2.6.33.1
mesa-7.8_rc2
Comment 25 Piotrek Juzwiak 2010-03-24 13:34:04 UTC
Intel GMA 950
xf86-video-intel-2.10-r1
linux-2.6.33
mesa-7.8_rc2

Also works with me. Should we mark this bug as resolved upstream?
Comment 26 Andreas Sturmlechner gentoo-dev 2010-03-24 13:41:32 UTC
I guess we should. There's still Bug 310079 but that seems to be another problem.
Comment 27 Rémi Cardona gentoo-dev 2010-03-24 23:48:53 UTC
Closing fixed then.

Thanks for the follow ups, it's greatly appreciated.
Comment 28 Patrick Lorazo 2010-04-14 00:53:51 UTC
(In reply to comment #27)
> Closing fixed then.
> 
> Thanks for the follow ups, it's greatly appreciated.
>
It looks as if this bug is also part of media-libs/mesa-7.7.1. Everything had always been working fine until I did the following upgrade on April 10th (output from genlop) :

     Sat Apr 10 09:20:16 2010 >>> x11-base/xorg-drivers-1.7
     Sat Apr 10 09:20:42 2010 >>> x11-misc/util-macros-1.6.1
     Sat Apr 10 09:22:31 2010 >>> x11-libs/libdrm-2.4.18_pre20100211-r1
     Sat Apr 10 09:23:00 2010 >>> x11-proto/dri2proto-2.3
     Sat Apr 10 09:23:22 2010 >>> x11-proto/xf86bigfontproto-1.2.0
     Sat Apr 10 09:23:53 2010 >>> x11-proto/xf86vidmodeproto-2.3
     Sat Apr 10 09:24:21 2010 >>> x11-proto/xextproto-7.1.1
     Sat Apr 10 09:24:48 2010 >>> x11-proto/fixesproto-4.1.1
     Sat Apr 10 09:25:14 2010 >>> x11-proto/xineramaproto-1.2
     Sat Apr 10 09:25:46 2010 >>> x11-proto/inputproto-2.0
     Sat Apr 10 09:26:15 2010 >>> x11-proto/recordproto-1.14
     Sat Apr 10 09:26:40 2010 >>> x11-proto/scrnsaverproto-1.2.0
     Sat Apr 10 09:27:10 2010 >>> x11-proto/xf86dgaproto-2.1
     Sat Apr 10 09:27:34 2010 >>> x11-proto/xcb-proto-1.6
     Sat Apr 10 09:30:01 2010 >>> x11-libs/libxcb-1.5
     Sat Apr 10 09:36:29 2010 >>> x11-libs/libX11-1.3.3
     Sat Apr 10 09:37:28 2010 >>> x11-libs/libXext-1.1.1
     Sat Apr 10 09:38:50 2010 >>> x11-libs/libXt-1.0.8
     Sat Apr 10 09:39:19 2010 >>> x11-apps/luit-1.0.5
     Sat Apr 10 09:40:18 2010 >>> x11-libs/libXi-1.3
     Sat Apr 10 09:40:52 2010 >>> x11-libs/libXxf86vm-1.1.0
     Sat Apr 10 09:41:28 2010 >>> x11-libs/libXScrnSaver-1.2.0
     Sat Apr 10 09:42:00 2010 >>> x11-libs/libXinerama-1.1
     Sat Apr 10 09:42:35 2010 >>> x11-libs/libXxf86dga-1.1.1
     Sat Apr 10 09:43:08 2010 >>> x11-libs/libXtst-1.1.0
     Sat Apr 10 09:43:38 2010 >>> x11-apps/xinput-1.5.1
     Sat Apr 10 09:44:06 2010 >>> x11-apps/xmessage-1.0.3
     Sat Apr 10 09:44:48 2010 >>> sys-apps/man-pages-3.23
     Sat Apr 10 09:54:20 2010 >>> media-libs/mesa-7.7.1
     Sat Apr 10 10:05:14 2010 >>> x11-base/xorg-server-1.7.6
     Sat Apr 10 10:07:15 2010 >>> x11-drivers/xf86-video-ati-6.12.6
     Sat Apr 10 10:11:24 2010 >>> net-print/hplip-3.9.12-r1

As recommended, I re-emerged some packages :

     Sat Apr 10 11:11:24 2010 >>> app-portage/portage-utils-0.2.1
     Sat Apr 10 11:20:13 2010 >>> media-libs/mesa-7.7.1
     Sat Apr 10 11:31:34 2010 >>> x11-base/xorg-server-1.7.6
     Sat Apr 10 11:32:13 2010 >>> x11-drivers/xf86-input-evdev-2.3.2
     Sat Apr 10 11:32:54 2010 >>> x11-drivers/xf86-input-keyboard-1.4.0
     Sat Apr 10 11:33:35 2010 >>> x11-drivers/xf86-input-mouse-1.5.0
     Sat Apr 10 11:35:47 2010 >>> x11-drivers/xf86-video-ati-6.12.6
     Sat Apr 10 11:36:43 2010 >>> x11-drivers/xf86-video-fbdev-0.4.1
     Sat Apr 10 11:37:25 2010 >>> x11-drivers/xf86-video-vesa-2.3.0

Nothing else has later been changed. Since then, compositing is stopped after a few minutes with the following message from KDE :

<<Compositing was too slow and has been suspended. If this was only a temporary problem, you can resume using [...]>>

Typing "kwin --replace --sync" gives :

<<WARNING: Application calling GLX 1.3 function "glXQueryDrawable" when GLX 1.3 is not supported!  This is an application bug!>>

Here is the output from "emerge --info" :

Portage 2.1.7.17 (default/linux/x86/10.0/desktop, gcc-4.3.4, glibc-2.10.1-r1, 2.6.31-gentoo-r10 i686)
=================================================================
System uname: Linux-2.6.31-gentoo-r10-i686-Intel-R-_Pentium-R-_4_CPU_2.60GHz-with-gentoo-1.12.13
Timestamp of tree: Tue, 13 Apr 2010 23:45:02 +0000
app-shells/bash:     4.0_p37
dev-java/java-config: 2.1.10
dev-lang/python:     2.4.6, 2.5.4-r4, 2.6.4-r1
dev-python/pycrypto: 2.0.1-r8
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.18-r3
sys-devel/gcc:       4.1.2, 4.3.4
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium4 -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=pentium4 -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://mirrors.tera-byte.com/pub/gentoo http://gentoo.mirrors.tera-byte.com/ ftp://gentoo.arcticnetwork.ca/pub/gentoo/ http://mirror.csclub.uwaterloo.ca/gentoo-distfiles/ http://gentoo.arcticnetwork.ca/ ftp://mirror.csclub.uwaterloo.ca/gentoo-distfiles/ "
LC_ALL="fr_CA.utf8"
LDFLAGS="-Wl,-O1"
LINGUAS="fr pl"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="3dnow X Xaw3d a52 aac aalib accessibility acl acpi addbookmarks aiglx alias alsa apm arts asf audacious avahi avi bash-completion berkdb bidi bitmap-fonts bluetooth branding browserplugin bzip2 cairo cdda cdio cdparanoia cdr cjk cli connectionstatus consolekit contactnotes cracklib crypt cups cupsddk cxx dbus dri dts dvd dvdr emboss emovix encode exif extraicons f77 fam fax ffmpeg firefox flac foomaticdb fortran freetype gadu gdbm gif gimp gimpprint glitz gnome gnutls gphoto2 gpm gtk gtk2 hal hddtemp highlight history httpd iconv imagemagick imlib ipod ipv6 java jpeg jpeg2k kde kpathsea lcms ldap libg++ libnotify libwww live logitech-mouse mad mdnsresponder-compat mikmod mmx mng modules motif mozilla mozsvg mp3 mp4 mpeg mudflap mysql nano-syntax ncurses nls nowlistening nptl nptlonly nsplugin oav ogg openal opengl openmp oss pam pango pcre pdf perl png povray ppds pppd python qt qt-static qt3support qt4 quicktime readline reflection samba scanner sdl semantic-desktop session slang sms speex spell spl sql sqlite sse sse2 ssl startup-notification stream svg svga sysfs tcpd texteffect theora threads tiff timidity tk translator truetype truetype-fonts type1-fonts unicode usb v4l vcd vidix vlm vorbis webkit webpresence win32codecs winpopup wxwindows x264 x86 xanim xcb xcomposite xine xml xml2 xorg xosd xpm xprint xulrunner xv xvid xvmc zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr pl" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev radeon vesa" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 29 Vasily 2010-04-14 14:10:34 UTC
I reproduced this bug with mesa-7.8.1 :\
Comment 30 Vasily 2010-04-14 14:17:11 UTC
(In reply to comment #29)
> I reproduced this bug with mesa-7.8.1 :\
> 

But it seems to be another bug, as intel_context.patch is already included in mesa-7.8.1.
Comment 31 Chí-Thanh Christopher Nguyễn gentoo-dev 2010-04-14 14:45:51 UTC
If you see a different bug, please open a separate bug report.
Comment 32 Patrick Lorazo 2010-04-15 01:47:13 UTC
(In reply to comment #31)
> If you see a different bug, please open a separate bug report.
> 
Issue has been added under bug 315367. Thank you.