Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 309365 - virtual/mpi - for what it exists?
Summary: virtual/mpi - for what it exists?
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Cluster Team
URL:
Whiteboard:
Keywords:
: 309367 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-03-14 12:50 UTC by marek wojciechowski
Modified: 2010-09-10 19:01 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description marek wojciechowski 2010-03-14 12:50:00 UTC
I observed today that many packages which can use MPI demand directly openpmi library instead of virtual/mpi (e.g. vtk, boost). So the question arises what is the reason for virtual/mpi if only one library for message passing have to be installed anyway. Actually this situation prevents us from using for example mpich2, because different MPI implementations block each other.

Is this possible to demand in ebuilds for boost, vtk, etc. just virtual/mpi? If not let's remove it from potage just to not pretend we have a choice for MPI library.



Reproducible: Always
Comment 1 Markos Chandras (RETIRED) gentoo-dev 2010-03-14 16:09:34 UTC
*** Bug 309367 has been marked as a duplicate of this bug. ***
Comment 2 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-03-23 17:59:51 UTC
Not sure. Assigning to maintainers

RDEPEND="|| (
	sys-cluster/openmpi[cxx?,fortran?,romio?]
	sys-cluster/mpich2[cxx?,fortran?,romio?]
	sys-cluster/lam-mpi[fortran?,romio?]
)"

Comment 3 Justin Bronder (RETIRED) gentoo-dev 2010-03-23 21:25:00 UTC
(In reply to comment #0)
> I observed today that many packages which can use MPI demand directly openpmi
> library instead of virtual/mpi (e.g. vtk, boost). So the question arises what
> is the reason for virtual/mpi if only one library for message passing have to
> be installed anyway. Actually this situation prevents us from using for example
> mpich2, because different MPI implementations block each other.
> 
> Is this possible to demand in ebuilds for boost, vtk, etc. just virtual/mpi? If
> not let's remove it from potage just to not pretend we have a choice for MPI
> library.
> 

It depends on both upstream and the maintainer.  Testing against multiple mpi implementations is a hassle that both tend to skip.  Also, lam-mpi is no longer actively developed and doesn't support some of the newer MPI extensions.

If you are willing to help testing a package with other implementations and then filing a bug with your results would be helpful.  This, of course, does require you to fix the deps in a local overlay first.
Comment 4 Justin Bronder (RETIRED) gentoo-dev 2010-07-03 01:04:21 UTC
Closing as the original question appears to have been answered.