Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 309055 - media-gfx/inkscape should depend on || (media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick])
Summary: media-gfx/inkscape should depend on || (media-gfx/imagemagick media-gfx/graph...
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Graphics Project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 314431
  Show dependency tree
 
Reported: 2010-03-11 20:18 UTC by Priit Laes (IRC: plaes)
Modified: 2017-09-09 12:27 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Diff against current 0.47 ebuild (add-graphicsmagick.diff,408 bytes, patch)
2010-04-09 21:43 UTC, Ian Whyman (thev00d00)
Details | Diff
PATCH: Allow linking against GraphisMagick as an alternative to ImageMagick (0001-Allow-linking-against-GraphisMagick-as-an-alternativ.patch,2.52 KB, patch)
2017-09-09 11:16 UTC, Dennis Schridde
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Priit Laes (IRC: plaes) 2010-03-11 20:18:21 UTC
graphicsmagick is drop-in replacement for imagemagick, so the dep should be  || (media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick])
Comment 1 Tristan Heaven (RETIRED) gentoo-dev 2010-04-01 19:22:11 UTC
Should be media-gfx/imagemagick[cxx]
Comment 2 Ian Whyman (thev00d00) gentoo-dev 2010-04-09 21:43:22 UTC
Created attachment 227175 [details, diff]
Diff against current 0.47 ebuild
Comment 3 Samuli Suominen gentoo-dev 2010-04-16 11:08:19 UTC
Did someone really test this without having imagemagick installed?
It's linking to the ImageMagick libraries.

$ qlist inkscape | grep bin | xargs objdump -p |grep -i magic
  NEEDED               libMagick++.so.3
  NEEDED               libMagick++.so.3
Comment 4 maurerpe 2011-02-16 19:21:48 UTC
I did some looking into this today.  Samuli Suominen is correct, but it was not obvious to me why he was correct.  I had to do some research first.

GraphicsMagick is a library that forked from ImageMagick.  GraphicsMagick can be installed on the same machine as imagemagick as it provides different header files, library names, and executable names.  It also provides an imagemagick compatibility option that allows programs/scripts that used the imagemagick executables (such as convert) to access the same features via the old command names.  When this feature is active, imageMagick cannot be installed on the same machine without conflict (the GraphicsMagick ebuild properly blocks this).

There is no compatibility layer provided for the header files or shared libraries.  Samuli's test proves that inkscape uses shared libraries from ImageMagick instead of the more rare but possible approach of forking and exec'ing ImageMagick executables, such as convert.

This means that although it is probably possible to get inkscape to work with GraphicsMagick it will require changes to the source code.  Such changes are likely non-trivial.  This type of changes is, in my opinion, something that should be dealt with upstream and only then should a gentoo bug be opened.  Therefore, the RESOLVED INVALID designation is appropriate.

As a final note, the above ebuild did "work" on my system, but not as intended.  I had GraphicsMagick install and ImageMagick NOT installed, so the intent of the ebuild is to link against GraphicsMagick.  It compiled, installed, and ran, but when Examining the config.log this happened because inkscape could not find imagemagick and build with support for neither imagemagick nor graphicsmagic.  In this sense, imagemagick is not a true dependency of inkscape.
Comment 6 Dennis Schridde 2017-09-09 11:16:24 UTC
Created attachment 493506 [details, diff]
PATCH: Allow linking against GraphisMagick as an alternative to ImageMagick

A patch for the upcoming CMake-based build-system of Inkscape has been posted upstream at: https://bugs.launchpad.net/inkscape/+bug/375202/comments/5
Comment 7 Dennis Schridde 2017-09-09 12:27:22 UTC
Keywords: PATCH