Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 308389 - sys-boot/grub-1.9* should be able to build as efi
Summary: sys-boot/grub-1.9* should be able to build as efi
Status: RESOLVED DUPLICATE of bug 308385
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-07 21:52 UTC by Benedikt Reinartz
Modified: 2010-03-08 11:15 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Benedikt Reinartz 2010-03-07 21:52:53 UTC
Grub 2 has support for EFI, yet the ebuild doesn't support it and just builds the BIOS variant. I'd really like to have a proper EFI installation in portage, preferably enabled by USE=efi.

This is already implemented in Bug #291851.

Reproducible: Always

Steps to Reproduce:
1. emerge >grub-1
Actual Results:  
Builds the BIOS version on x86.

Expected Results:  
Build the EFI version.
Comment 1 Rafał Mużyło 2010-03-08 11:15:38 UTC

*** This bug has been marked as a duplicate of bug 308385 ***