Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 308293 - app-arch/createrepo: Verify and potentially improve Python-related code
Summary: app-arch/createrepo: Verify and potentially improve Python-related code
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All All
: Highest normal (vote)
Assignee: Python Gentoo Team
Depends on:
Blocks: 308257
  Show dependency tree
Reported: 2010-03-07 17:07 UTC by Arfrever Frehtes Taifersar Arahesis (RETIRED)
Modified: 2011-11-13 02:39 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

createrepo-0.9.8-r1.ebuild (createrepo-0.9.8-r1.ebuild,1.34 KB, text/plain)
2010-05-02 23:03 UTC, David Abbott
createrepo-0.9.8-r1.ebuild (createrepo-0.9.8-r1.ebuild,1.32 KB, text/plain)
2010-05-03 20:37 UTC, David Abbott
ebuild patch (createrepo.patch,1.97 KB, patch)
2011-11-12 08:05 UTC, Ian Delaney (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2010-03-07 17:07:03 UTC
- If this package could support installation for multiple versions of Python,
  then please try to adjust the ebuilds to support it.
- Ensure that the ebuilds do not use deprecated functions or variables.
- Please check if Python 3 is supported by this package.
- If this package does not support Python 3:
  - Specify dependency on Python 2.
    You can use PYTHON_DEPEND helper variable, which should be set before
    inheriting of python eclass.
  - If this package cannot support installation for multiple versions of
    Python, then set active version of Python using
  - Ensure that shebangs in installed scripts specify correct version of
    Python. If shebangs are too generic (e.g. '#!/usr/bin/python'), then you
    can use python_convert_shebangs() to convert shebangs.
    (Wrapper scripts generated by python_generate_wrapper_scripts() do not
    require any changes.)

Please see documentation [1] for more details.
Comment 1 David Abbott gentoo-dev 2010-05-02 23:03:04 UTC
Created attachment 230091 [details]

Installs with 2 or 3 but will only work with 2 because of old style print statements.
Comment 2 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2010-05-03 16:47:01 UTC
You can also remove dev-lang/python from RDEPEND, because PYTHON_DEPEND="2" already changes DEPEND/RDEPEND.
Comment 3 David Abbott gentoo-dev 2010-05-03 20:37:03 UTC
Created attachment 230201 [details]
Comment 4 Ian Delaney (RETIRED) gentoo-dev 2011-11-12 08:05:09 UTC
Created attachment 292257 [details, diff]
ebuild patch

python2 2.5 2.6 2.7 3.1 3.2.  Fails on python 2.5
Adjusted to EAPI 3, minor change D -> ED
Comment 5 Ian Delaney (RETIRED) gentoo-dev 2011-11-12 08:07:22 UTC
re-assigned.  python team please review.
Comment 6 Ian Delaney (RETIRED) gentoo-dev 2011-11-12 08:42:09 UTC

@@ -2,7 +2,12

-        >=dev-python/urlgrabber-2.9.0

Had not read comment 2
Comment 7 Maxim Koltsov (RETIRED) gentoo-dev 2011-11-12 19:35:57 UTC
Fixed, thanks Ian.
Comment 8 Arfrever Frehtes Taifersar Arahesis 2011-11-13 02:39:46 UTC
(In reply to comment #4 and comment #7)

Portage itself requires Python >=2.6 and it has no relation to Python version
required by other packages. If you install sys-apps/portage with USE="python3",
then you will be able to set active version of Python 2 to 2.4 or 2.5 and still
use Portage (Portage will use active version of Python 3 regardless of active
version of Python 2).