Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 307343 - net-libs/libsoup breaks with net-libs/gnutls-2.10
Summary: net-libs/libsoup breaks with net-libs/gnutls-2.10
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Low normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL: https://bugzilla.gnome.org/show_bug.c...
Whiteboard:
Keywords:
: 325945 326055 326359 326587 326977 327455 (view as bug list)
Depends on:
Blocks: 292025 324227
  Show dependency tree
 
Reported: 2010-03-01 17:47 UTC by Derek Dolney
Modified: 2011-05-08 08:17 UTC (History)
11 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Derek Dolney 2010-03-01 17:47:30 UTC
Tested gnutls-2.9.8 and 2.9.9. With either, evolution hangs very early on startup. Downgrade to 2.8.5 fixes.

I have two accounts configured: an imap account (configured to use SSL), and an exchange account. I'm not sure which is sticking. I could figure it out if it would help.
Comment 1 Derek Dolney 2010-03-02 00:55:54 UTC
So gnutls-2.9* is masked, but somehow my package.mask was deleted when I synced. See my comment #2 in 307317.

Feel free to close this. I don't know if anyone wants to pursue problems with packages that are masked.
Comment 2 Derek Dolney 2010-03-02 01:00:52 UTC
Uh, yeah. I mean bug 307317 comment 2.
Comment 3 Gilles Dartiguelongue gentoo-dev 2010-03-02 19:28:35 UTC
it will probably be handled in a later release of evolution or when there is a tracker for handling gnutls-2.9 breakage.
Comment 4 Pacho Ramos gentoo-dev 2010-06-13 20:15:20 UTC
Does it also fail with 2.30?
Comment 5 Derek Dolney 2010-06-26 20:24:30 UTC
I tested gnutls-2.9.12 + evolution-2.30.1.2-r1 and still no good. But it fails a little differently: evolution starts but can't connect to my Exchange server. It keeps asking for the password.
Comment 6 Derek Dolney 2010-06-27 02:30:05 UTC
Tested gnutls-2.10.0 + evolution-2.30.2 + evolution-exchange-2.30.2 and that fails. It can't connect to the exchange (OWA) server, just keeps asking for the password.

And gnutls-2.10 was just pushed into amd64 and ~x86. This probably broke a lot of people who use evolution-exchange.
Comment 7 Priit Laes (IRC: plaes) 2010-06-27 07:59:26 UTC
It also seems to break epiphany which is using libsoup (IIRC, evolution might be also using libsoup).

https://bugzilla.gnome.org/show_bug.cgi?id=622857
Comment 8 Dan Ost 2010-06-28 19:24:01 UTC
2.10.0 broke Evolution as described (infinite loop of password prompts).

Masking 2.10.0 and going back to 2.8.6 solved the issue.

A co-worker of mine had an identical experience.
Comment 9 Priit Laes (IRC: plaes) 2010-06-30 08:20:54 UTC
This patch should fix issue with ssl websites, could you guys test whether it works for exchange too:
http://git.gnome.org/browse/libsoup/commit/?id=01a43ad9824fba77384534c6d588e0e0d653986e
Comment 10 Dan Ost 2010-06-30 20:56:16 UTC
My co-worker applied that patch to libsoup and the evolution issue is resolved.
Comment 11 Dan Ost 2010-06-30 20:58:15 UTC
Any idea when the libsoup patch will make it into portage?
Comment 12 Pacho Ramos gentoo-dev 2010-06-30 21:34:44 UTC
*** Bug 325945 has been marked as a duplicate of this bug. ***
Comment 13 Pacho Ramos gentoo-dev 2010-06-30 21:35:50 UTC
*** Bug 326055 has been marked as a duplicate of this bug. ***
Comment 14 Pacho Ramos gentoo-dev 2010-06-30 21:36:21 UTC
*** Bug 326359 has been marked as a duplicate of this bug. ***
Comment 15 onip 2010-07-01 12:23:56 UTC
applying this patch solved my issues with liferea-1.6.4 (and trunk) and google authentication.
Comment 16 Jonathan Callen (RETIRED) gentoo-dev 2010-07-01 22:44:47 UTC
This is fixed in 2.28.2-r1 and 2.30.2-r1.
Comment 17 Doug 2010-07-02 01:51:41 UTC
(In reply to comment #16)
> This is fixed in 2.28.2-r1 and 2.30.2-r1.
> 

Um, at the risk of sounding like a dumb-ass or a smart-ass, 2.28.2-r1 and 2.30.2-r1 of what?  Evolution, or evolution-exchange, or something else.  Thanks :).
Comment 18 Jonathan Callen (RETIRED) gentoo-dev 2010-07-02 02:01:45 UTC
(In reply to comment #17)
> (In reply to comment #16)
> > This is fixed in 2.28.2-r1 and 2.30.2-r1.
> > 
> 
> Um, at the risk of sounding like a dumb-ass or a smart-ass, 2.28.2-r1 and
> 2.30.2-r1 of what?  Evolution, or evolution-exchange, or something else. 
> Thanks :).
> 
net-libs/libsoup
Comment 19 Doug 2010-07-02 02:53:39 UTC
(In reply to comment #18)
> (In reply to comment #17)
> > (In reply to comment #16)
> > > This is fixed in 2.28.2-r1 and 2.30.2-r1.
> > > 
> > 
> > Um, at the risk of sounding like a dumb-ass or a smart-ass, 2.28.2-r1 and
> > 2.30.2-r1 of what?  Evolution, or evolution-exchange, or something else. 
> > Thanks :).
> > 
> net-libs/libsoup


Ahh, yeah.  I was way off :).  Thanks.
> 

Comment 20 Pacho Ramos gentoo-dev 2010-07-02 10:07:38 UTC
(In reply to comment #16)
> This is fixed in 2.28.2-r1 and 2.30.2-r1.
> 

Thanks! My dev system is busy with libpng update (it's a bit old) and cannot get into this :-(
Comment 21 Pacho Ramos gentoo-dev 2010-07-02 10:11:21 UTC
*** Bug 326587 has been marked as a duplicate of this bug. ***
Comment 22 Nick White 2010-07-02 18:33:47 UTC
(In reply to comment #16)
> This is fixed in 2.28.2-r1 and 2.30.2-r1.

Thanks, works 2.28.2-r1 works great for me. Can someone mark it stable please?
Comment 23 Pacho Ramos gentoo-dev 2010-07-02 21:04:30 UTC
You are looking for bug 326589 ;-)
Comment 24 Pacho Ramos gentoo-dev 2010-07-05 15:55:13 UTC
*** Bug 326977 has been marked as a duplicate of this bug. ***
Comment 25 Pacho Ramos gentoo-dev 2010-07-05 16:02:57 UTC
tests now fail with this :-S

timeout-test: OK
PASS: timeout-test
uri-parsing: OK
PASS: uri-parsing
forms-test: 23 error(s). Run with '-d' for details
FAIL: forms-test
server-auth-test: 140 error(s). Run with '-d' for details
FAIL: server-auth-test
SYNCHRONOUS SSL TEST PASSED
ASYNCHRONOUS SSL TEST PASSED
PASS: ssl-test
====================
2 of 16 tests failed
====================
make[2]: *** [check-TESTS] Error 1
make[2]: Leaving directory `/var/tmp/portage/net-libs/libsoup-2.28.2-r1/work/libsoup-2.28.2/tests'
make[1]: *** [check-am] Error 2
make[1]: Leaving directory `/var/tmp/portage/net-libs/libsoup-2.28.2-r1/work/libsoup-2.28.2/tests'
make: *** [check-recursive] Error 1

Comment 26 Pacho Ramos gentoo-dev 2010-07-05 16:05:46 UTC
But they pass on 2.30, only failing on 2.28... maybe we could simply skip offending tests since they are not likely to be fixed in 2.28 branch
Comment 27 Nick White 2010-07-05 22:14:01 UTC
(In reply to comment #26)
> But they pass on 2.30, only failing on 2.28... maybe we could simply skip
> offending tests since they are not likely to be fixed in 2.28 branch

FWIW, the libsoup-2.30.2-r1 seems to work fine on my otherwise almost entirely stable x86.
Comment 28 Pacho Ramos gentoo-dev 2010-07-08 09:49:07 UTC
*** Bug 327455 has been marked as a duplicate of this bug. ***