Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 307295 - emerge kde-meta Fail due to circular dependencies
Summary: emerge kde-meta Fail due to circular dependencies
Status: RESOLVED DUPLICATE of bug 175808
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: AMD64 Linux
: High major (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-01 10:55 UTC by Daniel
Modified: 2010-03-01 11:01 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel 2010-03-01 10:55:17 UTC
As I Said in the summary when i try to emerge kde-meta it failed because of circular dependencies.

Reproducible: Always

Steps to Reproduce:
1. emerge kde-meta

Actual Results:  
These are the packages that would be merged, in order:

Calculating dependencies  ..^H^H... done!


[nomerge      ] kde-base/kde-meta-4.3.5  USE="nls -accessibility (-aqua) (-kdeprefix)"
[nomerge      ]  kde-base/kdeedu-meta-4.3.5  USE="(-aqua) (-kdeprefix)"
[nomerge      ]   kde-base/kmplot-4.3.5  USE="handbook (-aqua) -debug (-kdeenablefinal) (-kdeprefix)"
[nomerge      ]    x11-libs/qt-gui-4.5.3-r2  USE="accessibility cups dbus glib mng qt3support (-aqua) -debug -gtk -nas -nis -pch -raster -tiff -xinerama"
[ebuild  N    ]     net-print/cups-1.3.11-r1  USE="X acl dbus pam perl png python ssl -avahi -gnutls -java -jpeg -kerberos -ldap -php -ppds -samba -slp -static -tiff -xinetd -zeroconf"LINGUAS="-de -en -es -et -fr -he -id -it -ja -pl -sv -zh_TW"
[ebuild  N    ]      app-text/poppler-0.12.3-r3  USE="abiword lcms png qt4 utils xpdf-headers -cairo -cjk -debug -doc -exceptions -jpeg -jpeg2k"
[ebuild  N    ]       x11-libs/qt-gui-4.5.3-r2  USE="accessibility cups dbus glib mng qt3support (-aqua) -debug -gtk -nas -nis -pch -raster -tiff -xinerama"
[ebuild  N    ]       dev-util/cmake-2.6.4-r3  USE="qt4 -emacs -vim-syntax"

 * Error: circular dependencies:

('ebuild', '/', 'x11-libs/qt-gui-4.5.3-r2', 'merge') depends on
  ('ebuild', '/', 'net-print/cups-1.3.11-r1', 'merge') (buildtime)
('ebuild', '/', 'dev-util/cmake-2.6.4-r3', 'merge') depends on
  ('ebuild', '/', 'x11-libs/qt-gui-4.5.3-r2', 'merge') (buildtime)
('ebuild', '/', 'net-print/cups-1.3.11-r1', 'merge') depends on
  ('ebuild', '/', 'app-text/poppler-0.12.3-r3', 'merge') (runtime)
('ebuild', '/', 'app-text/poppler-0.12.3-r3', 'merge') depends on
  ('ebuild', '/', 'x11-libs/qt-gui-4.5.3-r2', 'merge') (buildtime)
  ('ebuild', '/', 'dev-util/cmake-2.6.4-r3', 'merge') (buildtime)

 * Note that circular dependencies can often be avoided by temporarily
 * disabling USE flags that trigger optional dependencies.

Expected Results:  
KDE emerged

Portage 2.1.7.16 (default/linux/amd64/10.0, gcc-4.3.4, glibc-2.10.1-r1, 2.6.31-gentoo-r6 x86_64)
=================================================================
System uname: Linux-2.6.31-gentoo-r6-x86_64-Intel-R-_Core-TM-2_CPU_6700_@_2.66GHz-with-gentoo-1.12.13
Timestamp of tree: Fri, 26 Feb 2010 14:15:01 +0000
ccache version 2.4 [disabled]
app-shells/bash:     4.0_p35
dev-lang/python:     2.6.4
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.63-r1
sys-devel/automake:  1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc:       4.3.4
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://cesium.di.uminho.pt/pub/gentoo/ http://ftp.rnl.ist.utl.pt/pub/gentoo/gentoo-distfiles/ ftp://darkstar.ist.utl.pt/pub/gentoo/ http://darkstar.ist.utl.pt/gentoo/
ftp://ftp.rnl.ist.utl.pt/pub/gentoo/gentoo-distfiles/ http://ftp.dei.uc.pt/pub/linux/gentoo/ http://cesium.di.uminho.pt/pub/gentoo/ ftp://ftp.dei.uc.pt/pub/linux/gentoo/ "
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X acl amd64 berkdb bzip2 cli cracklib crypt cups cxx dbus dri fortran gdbm gpm iconv ipv6 kde mmx mng modules mudflap multilib mysql ncurses nls nptl nptlonly opengl openmp pam pcre
perl png pppd python qt qt3support qt4 readline reflection session spl sql sse sse2 ssl svg sysfs tcpd unicode webkit xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106
cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare
dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias
authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env
expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias"
ELIBC="glibc" INPUT_DEVICES="keyboard virtualbox evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" RUBY_TARGETS="ruby18"
USERLAND="GNU" VIDEO_CARDS="virtualbox"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Samuli Suominen gentoo-dev 2010-03-01 11:01:31 UTC
Emerge with USE="-cups" and enable it later on if you need it.

*** This bug has been marked as a duplicate of bug 175808 ***