anki-0.9.9.8.6 needs PyQt4-4.7 if you want to generate graphs. If an older version is installed the error message "Your PyQt installation is broken. Please upgrade or downgrade PyQt" is displayed.
I suggest that the use flag graph depends on PyQt4-4.7
more info in this mail: http://groups.google.com/group/ankisrs/msg/6734c908979fb762?dmode=source
copy paste from mail:
"Some crashing bugs have been fixed on Linux. If you are using PyQt4.6
however, you may find things are quite broken. Upgrading to PyQt4.7 is
There are known issues in PyQt 4.6 which will cause random crashes -
and with the graphs it was frequent enough that I disabled them as a
protective measure. You can hack out the check if you want, but I
imagine they'll crash for you too.
Steps to Reproduce:
reassign to anki maintainer, this is not a python or qt issue!
+ 18 Aug 2010; Patrick Lauer <email@example.com> anki-0.9.9.8.6-r1.ebuild:
+ Fixing PyQt deps for #307035