Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 306761 - ati-drivers-10.2 does not compile with gentoo-sources-2.6.33
Summary: ati-drivers-10.2 does not compile with gentoo-sources-2.6.33
Status: VERIFIED DUPLICATE of bug 306771
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-25 08:31 UTC by Sebastian Lüttich
Modified: 2010-02-28 17:34 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
patch for ati-drivers-10.2.ebuild (ati-drivers-10.2.ebuild.patch,391 bytes, patch)
2010-02-25 08:36 UTC, Sebastian Lüttich
Details | Diff
needed patch to compile ati-drivers (2.6.33-10.2-fix_compilation.patch,1.23 KB, patch)
2010-02-25 08:36 UTC, Sebastian Lüttich
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Lüttich 2010-02-25 08:31:36 UTC
ati-drivers doesn't compile against 2.6.33. I changed the old patch.

2.6.33 puts autoconf.h and utsrelease.h in include/generated/. To change this in the source of ati-drivers would be to much, therefor I put a symbolic link from include/generated/[autoconf|utsrelease].h to include/linux/ in the kernel source tree.

Reproducible: Always
Comment 1 Sebastian Lüttich 2010-02-25 08:36:06 UTC
Created attachment 221057 [details, diff]
patch for ati-drivers-10.2.ebuild

patch -p0 < ati-drivers-10.2.ebuild.patch
Comment 2 Sebastian Lüttich 2010-02-25 08:36:55 UTC
Created attachment 221059 [details, diff]
needed patch to compile ati-drivers

put this file into $FILESDIR/kernel/
Comment 3 Rémi Cardona gentoo-dev 2010-02-26 06:36:47 UTC

*** This bug has been marked as a duplicate of bug 306771 ***
Comment 4 Helmut Jarausch 2010-02-26 16:32:33 UTC
(In reply to comment #2)
> Created an attachment (id=221059) [details]
> needed patch to compile ati-drivers
> 
> put this file into $FILESDIR/kernel/
> 

I fear that doesn't suffice here - from the log
Applying 2.6.33-10.2-fix_compilation.patch
...
common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:31:28: error: linux/autoconf.h: No such file or directory
...
common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:166:30: error: linux/utsrelease.h: No such file or directory


Comment 5 Sebastian Lüttich 2010-02-26 16:51:16 UTC
(In reply to comment #4)
> (In reply to comment #2)
> > Created an attachment (id=221059) [details] [details]
> > needed patch to compile ati-drivers

> I fear that doesn't suffice here - from the log
> Applying 2.6.33-10.2-fix_compilation.patch

Read the source Luke!

|2.6.33 puts autoconf.h and utsrelease.h in include/generated/. To change this
|in the source of ati-drivers would be to much, therefor I put a symbolic link
|from include/generated/[autoconf|utsrelease].h to include/linux/ in the kernel
|source tree.

from my initial post.

Happy gl-ing, 

Sebastian
Comment 6 Attila Oláh 2010-02-26 20:26:07 UTC
For me the attached patch only solves half of the problem. I still get these errors:

/var/tmp/portage/x11-drivers/ati-drivers-10.2/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function '__ke__cmpxchg':                                             
/var/tmp/portage/x11-drivers/ati-drivers-10.2/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1473: error: variable or field '__ret' declared void                      
/var/tmp/portage/x11-drivers/ati-drivers-10.2/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1473: error: variable or field '__old' declared void                      
/var/tmp/portage/x11-drivers/ati-drivers-10.2/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1473: error: variable or field '__new' declared void 
Comment 7 Attila Oláh 2010-02-27 00:00:22 UTC
Correction:

The patch worked great. It looks like I applied it on a wrong copy; silly me...