Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 305485 - app-office/dia-0.97.1 fails to compile if XML::Parser is missing
Summary: app-office/dia-0.97.1 fails to compile if XML::Parser is missing
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-17 08:19 UTC by Frédéric COIFFIER
Modified: 2010-02-17 08:23 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frédéric COIFFIER 2010-02-17 08:19:39 UTC
Emerging dia fails on XML::Parser presence check :

...
checking for utime.h... yes                                                                                                                                                                                       
checking for an ANSI C-conforming const... yes                                                                                                                                                                    
checking for select... yes                                                                                                                                                                                        
checking for strcspn... yes                                                                                                                                                                                       
checking for strdup... yes                                                                                                                                                                                        
checking for strtol... yes                                                                                                                                                                                        
checking whether NLS is requested... yes                                                                                                                                                                          
checking for intltool >= 0.35.0... 0.40.6 found                                                                                                                                                                   
checking for intltool-update... /usr/bin/intltool-update                                                                                                                                                          
checking for intltool-merge... /usr/bin/intltool-merge                                                                                                                                                            
checking for intltool-extract... /usr/bin/intltool-extract                                                                                                                                                        
checking for xgettext... /usr/bin/xgettext                                                                                                                                                                        
checking for msgmerge... /usr/bin/msgmerge                                                                                                                                                                        
checking for msgfmt... /usr/bin/msgfmt                                                                                                                                                                            
checking for gmsgfmt... /usr/bin/gmsgfmt
checking for perl... /usr/bin/perl
checking for perl >= 5.8.1... 5.10.1
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool


Reproducible: Always

Steps to Reproduce:
1. emerge -1 =app-office/dia-0.97.1
Comment 1 Samuli Suominen gentoo-dev 2010-02-17 08:23:11 UTC
You upgraded perl, but didn't run "perl-cleaner --reallyall" for it.

*** This bug has been marked as a duplicate of bug 41124 ***