Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 305299 - app-emulation/virtualbox-ose fails with USE flags opengl -qt4
Summary: app-emulation/virtualbox-ose fails with USE flags opengl -qt4
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Low normal (vote)
Assignee: Patrick Lauer
URL:
Whiteboard:
Keywords:
: 316717 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-02-15 18:47 UTC by Ooblick
Modified: 2010-07-18 11:57 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,339.34 KB, text/plain)
2010-02-15 18:48 UTC, Ooblick
Details
emerge --info (emerge.info,3.86 KB, text/plain)
2010-02-15 18:49 UTC, Ooblick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ooblick 2010-02-15 18:47:41 UTC
Emerging virtualbox-ose-3.1.4 with the opengl USE flag doesn't build VBoxTestOGL which seems to be needed to install it:

>>> Install virtualbox-ose-3.1.4 into /tmp/portage/app-emulation/virtualbox-ose-3.1.4/image/ category app-emulation
 * Fallback PaX marking -m
 *      /tmp/portage/app-emulation/virtualbox-ose-3.1.4/image//usr/lib64/virtualbox-ose/VBoxSDL
 TYPE    PAX   FILE 
ET_EXEC --mxe- /tmp/portage/app-emulation/virtualbox-ose-3.1.4/image//usr/lib64/virtualbox-ose/VBoxSDL 
 * Fallback PaX marking -m
 *      /tmp/portage/app-emulation/virtualbox-ose-3.1.4/image//usr/lib64/virtualbox-ose/VBoxHeadless
 TYPE    PAX   FILE 
ET_EXEC --mxe- /tmp/portage/app-emulation/virtualbox-ose-3.1.4/image//usr/lib64/virtualbox-ose/VBoxHeadless 
install: cannot stat `VBoxTestOGL': No such file or directory
!!! doins: VBoxTestOGL does not exist
 * ERROR: app-emulation/virtualbox-ose-3.1.4 failed:
 *   (no error message)
 * 
 * Call stack:
 *     ebuild.sh, line  54:  Called src_install
 *   environment, line 4025:  Called die
 * The specific snippet of code:
 *               doins VBoxTestOGL || die;
 * 
 * If you need support, post the output of 'emerge --info =app-emulation/virtualbox-ose-3.1.4',
 * the complete build log and the output of 'emerge -pqv =app-emulation/virtualbox-ose-3.1.4'.
 * The complete build log is located at '/tmp/portage/app-emulation/virtualbox-ose-3.1.4/temp/build.log'.
 * The ebuild environment file is located at '/tmp/portage/app-emulation/virtualbox-ose-3.1.4/temp/environment'.
 * S: '/tmp/portage/app-emulation/virtualbox-ose-3.1.4/work/VirtualBox-3.1.4_OSE'
 * QA Notice: file does not exist:
 * 
 * 	doins: VBoxTestOGL does not exist

Simply emerging without this flag works.
Comment 1 Ooblick 2010-02-15 18:48:10 UTC
Created attachment 219807 [details]
build.log
Comment 2 Ooblick 2010-02-15 18:49:14 UTC
Created attachment 219809 [details]
emerge --info
Comment 3 Patrick Lauer gentoo-dev 2010-03-02 00:30:32 UTC
>>> /usr/lib64/virtualbox-ose/VBoxTestOGL

works for me - do you have USE="-qt4" ?
Comment 4 Björn Michaelsen 2010-03-03 01:57:24 UTC
This happens with USE="-headless -qt4 opengl".
Comment 5 Ooblick 2010-03-11 11:00:44 UTC
Yes, this is with -qt4
Comment 6 Nikolay Engyozov 2010-03-22 15:04:50 UTC
Same problem here, on x86_64 gentoo
Comment 7 Oleg Mikheev 2010-03-22 19:15:11 UTC
-opengl fixes it for me
Comment 8 Christopher Dale 2010-03-23 19:21:17 UTC
Agreed, -opengl fixes this for me as well.
Comment 9 Oleg Mikheev 2010-03-24 19:58:49 UTC
(In reply to comment #7)
> -opengl fixes it for me

unfortunately it doesn't build VirtualBox executable for me (no UI).
$ equery uses virtualbox-ose
[ Searching for packages matching virtualbox-ose... ]
[ Colour Code : set unset ]
[ Legend : Left column  (U) - USE flags from make.conf              ]
[        : Right column (I) - USE flags packages was installed with ]
[ Found these USE variables for app-emulation/virtualbox-ose-3.1.4 ]
 U I
 + + additions  : Install Guest System Tools ISO
 + + alsa       : Adds support for media-libs/alsa-lib (Advanced Linux Sound Architecture)
 + + hal        : Enable Hardware Abstraction Layer (HAL) support
 - - headless   : Build without any graphic frontend
 - - opengl     : Adds support for OpenGL (3D graphics)
 - - pulseaudio : Adds support for PulseAudio sound server
 + + python     : Adds support/bindings for the Python language
 - - qt4        : Adds support for the Qt GUI/Application Toolkit version 4.x
 - - sdk        : Enable building of SDK
 - - vboxwebsrv : Build and install the VirtualBox webservice
Comment 10 Oleg Mikheev 2010-03-25 06:42:42 UTC
(In reply to comment #9)
> unfortunately it doesn't build VirtualBox executable for me (no UI).
>  - - qt4        : Adds support for the Qt GUI/Application Toolkit version 4.x

just didn't know VirtualBox was using Qt for UI :)
Comment 11 Yoda Wu 2010-03-30 07:36:28 UTC
(In reply to comment #10)
> (In reply to comment #9)
> > unfortunately it doesn't build VirtualBox executable for me (no UI).
> >  - - qt4        : Adds support for the Qt GUI/Application Toolkit version 4.x
> 
> just didn't know VirtualBox was using Qt for UI :)
> 

Is there any possible way to keep opengl flag on ?
Comment 12 Lars Wendler (Polynomial-C) gentoo-dev 2010-05-19 17:09:11 UTC
*** Bug 316717 has been marked as a duplicate of this bug. ***
Comment 13 Lars Wendler (Polynomial-C) gentoo-dev 2010-06-08 11:55:22 UTC
This should be fixed with >=app-emulation/virtualbox-ose-3.1.8
Comment 14 Ooblick 2010-06-15 04:36:48 UTC
Confirmed fixed (tested with app-emulation/virtualbox-ose-3.2.4-r1)
Comment 15 Marcin Rybarski 2010-07-18 11:50:33 UTC
(In reply to comment #13)
> This should be fixed with >=app-emulation/virtualbox-ose-3.1.8
> 

It is not. I think we need with opengl flag also remove VBoxTestOGL entry in ebuild.