Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 305291 - gnome-extra/libgsf-1.14.17 fails to build, complains XML::Parser required for intltool
Summary: gnome-extra/libgsf-1.14.17 fails to build, complains XML::Parser required for...
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-15 17:37 UTC by Leeman Strout
Modified: 2010-02-15 17:41 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Leeman Strout 2010-02-15 17:37:31 UTC
checking for perl... /usr/bin/perl
checking for perl >= 5.8.1... 5.10.1
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool


Reproducible: Always

Steps to Reproduce:
1. something I have apparently depends on libgsf
2. emerge --update --deep world
3. failed build of libgsf

Actual Results:  
checking for perl... /usr/bin/perl
checking for perl >= 5.8.1... 5.10.1
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool

!!! Please attach the following file when seeking support:
!!! /data/tmp/portage/gnome-extra/libgsf-1.14.17/work/libgsf-1.14.17/config.log
 * ERROR: gnome-extra/libgsf-1.14.17 failed:
 *   econf failed
 * 
 * Call stack:
 *     ebuild.sh, line   54:  Called src_configure
 *   environment, line 4690:  Called gnome2_src_configure
 *   environment, line 2787:  Called econf '--with-gio' '--disable-static' '--with-bz2' '--without-gnome-vfs' '--without-bonobo' '--with-python' '--with-gdk-pixbuf' '--without-gconf' '--disable-gtk-doc'
 *     ebuild.sh, line  544:  Called die
 * The specific snippet of code:
 *   			die "econf failed"
 * 
 * If you need support, post the output of 'emerge --info =gnome-extra/libgsf-1.14.17',
 * the complete build log and the output of 'emerge -pqv =gnome-extra/libgsf-1.14.17'.
 * The complete build log is located at '/data/tmp/portage/gnome-extra/libgsf-1.14.17/temp/build.log'.
 * The ebuild environment file is located at '/data/tmp/portage/gnome-extra/libgsf-1.14.17/temp/environment'.
 * S: '/data/tmp/portage/gnome-extra/libgsf-1.14.17/work/libgsf-1.14.17'

>>> Failed to emerge gnome-extra/libgsf-1.14.17, Log file:


Expected Results:  
successful build

Portage 2.1.7.17 (default/linux/amd64/10.0, gcc-4.4.3, glibc-2.11-r1, 2.6.32-gentoo x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.32-gentoo-x86_64-Intel-R-_Xeon-TM-_CPU_3.20GHz-with-gentoo-2.0.1
Timestamp of tree: Mon, 15 Feb 2010 16:15:01 +0000
app-shells/bash:     4.1_p2
dev-java/java-config: 2.1.10
dev-lang/python:     2.6.4-r1, 3.1.1-r1
dev-util/cmake:      2.8.0-r1
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.0-r1
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.10.3, 1.11.1
sys-devel/binutils:  2.20
sys-devel/gcc:       4.4.3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.32
ACCEPT_KEYWORDS="amd64 ~amd64 ~x86"
ACCEPT_LICENSE="* -@EULA dlj-1.1 PUEL"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=core2 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://lug.mtu.edu/gentoo/ http://distro.ibiblio.org/pub/linux/distributions/gentoo/ http://www.gtlib.gatech.edu/pub/gentoo"
LDFLAGS="-Wl,-O1"
LINGUAS="en_US en"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/vmware /usr/local/portage/local"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="X accessibility acpi amd64 bash-completion bzip2 cddb cleartype cli consolekit cracklib crypt cups curl dbus fam glib glx gtk hal iconv jpeg libnotify logrotate midi mmx multilib ncurses nls nptl nptlonly nsplugin ntp opengl pam pcf pcre perl pmu png python qt3support readline samba session sqlite sse sse2 ssl startup-notification svg tcpd tiff truetype unicode xcomposite xinerama xorg xrender xscreensaver xulrunner xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_US en" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="dummy" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Leeman Strout 2010-02-15 17:40:39 UTC
emerge dev-perl/XML-Parser                followed by
emerge gnome-extra/libgsf-1.14.17         succeeds in building
Comment 2 Samuli Suominen gentoo-dev 2010-02-15 17:41:46 UTC
Closing as duplicate of ancient bug.

Basically you haven't done perl-cleaner after perl upgrade. 

I suggest "perl-cleaner --reallyall".

*** This bug has been marked as a duplicate of bug 41124 ***