Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 305133 - preserved-rebuild doesn't remove /usr/lib64/xulrunner-1.9.2/libsqlite3.so after emerging mail-client/mozilla-thunderbird-3.0.1-r1
Summary: preserved-rebuild doesn't remove /usr/lib64/xulrunner-1.9.2/libsqlite3.so aft...
Status: RESOLVED DUPLICATE of bug 289180
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: preserve-libs
  Show dependency tree
 
Reported: 2010-02-14 19:35 UTC by Enrico Tagliavini
Modified: 2011-07-16 18:21 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Enrico Tagliavini 2010-02-14 19:35:40 UTC
Today i updated dev-db/sqlite from current stable 3.6.20-r1 to lastest ~arch 3.6.22-r2 couse the mozilla-firefox-3.6-r2 revision bump needs it, in the update process xulrunner and firefox were rebuilded too due to the revision bump. After that i had few preserved-rebuild packages (i use portage 2.2_rc62), including mail-client/mozilla-thunderbird-3.0.1-r1. I launched emerge @preserved-rebuild but after the thunderbird compilation i get 

!!! existing preserved libs:
>>> package: net-libs/xulrunner-1.9.2-r2
 *  - /usr/lib64/xulrunner-1.9.2/libsqlite3.so
 *      used by /usr/lib64/mozilla-thunderbird/components/libstoragecomps.so (mail-client/mozilla-thunderbird-3.0.1-r1)

i then launched it again.... same result.

I'm going to try to remove /usr/lib64/xulrunner-1.9.2/libsqlite3.so && revdep-rebuild

Reproducible: Always
Comment 1 Enrico Tagliavini 2010-02-14 19:43:17 UTC
i moved /usr/lib64/xulrunner-1.9.2/libsqlite3.so away but revdep-rebuild can't find errors. if i start thunderbird now (without rebuild it!) it starts normally and seems to work well
Comment 2 Vlastimil Babka (Caster) (RETIRED) gentoo-dev 2010-02-15 13:28:17 UTC
Same here. The background is that xulrunner bundled own libsqlite3.so and now uses system one in /usr/lib.
The ld.so.conf contains these relevant entries:
/usr/lib64
...
/usr/lib64/xulrunner-1.9.2

So there used to be two libsqlite3.so in the ld.so.conf paths, and portage doesn't take it into account, and doesn't allow one of them to be removed. IMHO thanks to the order, thunderbird uses the one in /usr/lib64 anyway.

Might be a dupe of some other bug but I'm not sure.
Comment 3 Zac Medico gentoo-dev 2011-07-16 18:21:58 UTC
(In reply to comment #2)
> Might be a dupe of some other bug but I'm not sure.

It seems to be the same issue described in bug #289180, comment #12.

*** This bug has been marked as a duplicate of bug 289180 ***