Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 305005 - sys-cluster/openmpi-1.4.1 blocks world
Summary: sys-cluster/openmpi-1.4.1 blocks world
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-14 00:52 UTC by Juergen Rose
Modified: 2010-03-12 14:45 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Juergen Rose 2010-02-14 00:52:17 UTC
'emerge -uvDNt world' fails with:
root@lynx:/root(14)# emerge -vuNDt world
These are the packages that would be merged, in reverse order:
Calculating dependencies... done!
...[nomerge      ] sci-mathematics/octave-forge-meta-1.0  [2]
[nomerge      ]  sci-mathematics/octave-forge-octcdf-1.0.13  [2]
[nomerge      ]   sci-libs/netcdf-4.0.1-r1  USE="cxx doc fortran hdf5 szip"  [0]
[nomerge      ]    sci-libs/hdf5-1.8.4-r2  USE="cxx examples fortran mpi szip threads zlib"  [2]
[nomerge      ]     virtual/mpi-2.0  USE="cxx fortran romio"  [0]
[ebuild  N    ]      sys-cluster/openmpi-1.4.1  USE="cxx fortran ipv6 romio threads -debug -heterogeneous -infiniband -mpi-threads -pbs -vt" 6,418 kB [2]
...
[blocks B     ] sys-cluster/mpich2 ("sys-cluster/mpich2" is blocking sys-cluster/openmpi-1.4.1)
[blocks B     ] sys-cluster/openmpi ("sys-cluster/openmpi" is blocking sys-cluster/mpich2-1.2.1)

Total: 21 packages (18 upgrades, 1 new, 2 in new slots), Size of downloads: 65,011 kB
Conflict: 2 blocks (2 unsatisfied)
Portage tree and overlays:
 [0] /usr/portage
 [1] /usr/local/portage
 [2] /var/lib/layman/science

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  ('installed', '/', 'sys-cluster/mpich2-1.2.1', 'nomerge') pulled in by
    sys-cluster/mpich2 required by world
    sys-cluster/mpich2[cxx] required by ('installed', '/', 'sci-libs/vtk-5.4.2-r1', 'nomerge')
    sys-cluster/mpich2[cxx,fortran,romio] required by ('installed', '/', 'virtual/mpi-2.0', 'nomerge')
    (and 1 more)

  ('ebuild', '/', 'sys-cluster/openmpi-1.4.1', 'merge') pulled in by
    >=sys-cluster/openmpi-1.2.9[cxx] required by ('ebuild', '/', 'dev-libs/boost-1.39.0', 'merge')
    >=sys-cluster/openmpi-1.2.9[cxx] required by ('installed', '/', 'dev-libs/boost-1.41.0-r3', 'nomerge')
    sys-cluster/openmpi[cxx,fortran,romio] required by ('installed', '/', 'virtual/mpi-2.0', 'nomerge')


Reproducible: Always




root@lynx:/root(15)# emerge --info
Portage 2.1.7.17 (default/linux/amd64/10.0/desktop, gcc-4.4.3, glibc-2.11-r1, 2.6.32-gentoo-r5 x86_64)
=================================================================
System uname: Linux-2.6.32-gentoo-r5-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T8300_@_2.40GHz-with-gentoo-2.0.1
Timestamp of tree: Sat, 13 Feb 2010 21:30:01 +0000
app-shells/bash:     4.0_p37
dev-java/java-config: 2.1.10
dev-lang/python:     2.6.4-r1, 3.1.1-r1
dev-python/pycrypto: 2.1.0
dev-util/cmake:      2.8.0-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.0-r1
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.7.9-r2, 1.8.5-r3, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20
sys-devel/gcc:       4.4.3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.32
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA PUEL dlj-1.1 skype-eula"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=nocona -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
FFLAGS="-march=nocona -O2 -pipe -fomit-frame-pointer"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1"
LINGUAS="de fr"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/dotnet /var/lib/layman/java-overlay /var/lib/layman/lordvan /var/lib/layman/n4g /var/lib/layman/science /var/lib/layman/suka /var/lib/layman/x11 /var/lib/layman/zugaina /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="64bit X Xaw3d a52 aac acl acpi administrator afs alsa amd64 ao aotuv apache2 asf aspell atlas audacious audiofile automount bash-completion beagle berkdb blas bluetooth boo boost branding bzip2 c++ cairo cardbus cdda cddb cdf cdio cdparanoia cdr cgi chm cli consolekit corba cracklib crypt cups curl cxx daap dbus device-mapper dga dia djvu doc dri ds2490 dts dv dvb dvd dvdr dvi dxr3 eds elf emacs emboss encode epiphany esd evo examples exif expat extensions extra extras fam fame ffmpeg fftw firefox fits flac fltk foomaticdb fortran fpx fts3 fuse galago garmin gd gdal gdbm geolocation geos gif gimp ginac git glade glib glitz gml gmp gnokii gnome gnome-keyring gnuplot gnutls gphoto2 gpm graphics graphtft graphviz gs gsl gsm gstreamer gtk guile hal harness hddtemp hdf hdf5 hlapi http httpd hvm iconv icq icu id3 ide imagemagick imap innodb ipod ipv6 irda ithreads jabber jadetex java java5 java6 jbig john jpeg jpeg2k kde kdrive kerberos kexi kpathsea kvm ladspa lame lapack laptop latex lcms ldap libffi libgda libnotify libsamplerate lirc lua lzo mad mail maildir mailwrapper math matroska mikmod mmx mmxext mng modules mono moonlight motif mozdevelop mozilla mp3 mp4 mpeg mpi mplayer mtp mudflap multilib musicbrainz mysql mysqli nautilus ncurses neXt netcdf netpbm network networking networkmanager nfs nls nntp nptl nptlonly nsplugin ntfs ntp numarray numeric nvidia obex objc ocaml octave odbc ogdi ogg ole openexr opengl openmp overview pae pam pcre pda pdf perl plotutils plugins png podcast policykit posix postgres postscript ppds pppd preview-latex proj projectx pstricks pulseaudio pymol python qhull qt3support qt4 quicktime readline reflection reiserfs rle romio rpc rrdcgi rrdtool samba sasl science sdl secure-delete semantic-desktop server session slang slp smbclient smp sndfile snmp soup sox speex spell spl sql sqlite sse sse2 ssl startup-notification stlport subtitles subversion suexec svg swig sysfs szip t1lib tcl tcpd tex tex4ht texmacs theora thinkpad threads thunar thunderbird tidy tiff tk tntc tools truetype udev unicode usb userlocales utempter v4l2 virtualbox vorbis wav webdav webdav-serf webkit wifi wmf wxwidgets x264 xattr xcb xemacs xext xine xml xmlreader xmlrpc xorg xpm xulrunner xv xvid xvmc zlib zvbi" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CAMERAS="canon" DVB_CARDS="usb-wt220u" ELIBC="glibc" INPUT_DEVICES="keyboard mouse                evdev                synaptics               " KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de fr" NETBEANS_MODULES="apisupport cnd dlight enterprise ergonomics groovy gsf harness ide identity j2ee java mobility nb php profiler ruby websvccommon xml" QEMU_SOFTMMU_TARGETS="i386 ppc ppc64 x86_64" QEMU_USER_TARGETS="arm i386 x86_64" RUBY_TARGETS="ruby18 jruby" USERLAND="GNU" VIDEO_CARDS="nv nvidia nouveau vesa" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Sebastian Luther (few) 2010-02-14 07:16:55 UTC
You can't install openmpi and mpich2 simultaneously (at least not without hacks). I think everything that requires mpich2 on your system could use openmpi, but some packges don't work with mpich2 (boost-1.39). If you really want to stay with mpich2 and you really need boost-1.39, then there is an ebuild for boost-1.39 that works with mpich2 in my overlay [1].

[1] http://github.com/few/few-s-gentoo-overlay
Comment 2 Juergen Rose 2010-02-14 08:07:38 UTC
In the last weeks I had several issues with openmpi, compare e.g. Bug 302056 and Bug 296518, which disappeared after removing openmpi and installing mpich2.
So I did not actively try to install openmpi but it is installed as a dependency of octave-forge-octcdf:

[nomerge      ]  sci-mathematics/octave-forge-octcdf-1.0.13  [2]
[nomerge      ]   sci-libs/netcdf-4.0.1-r1  USE="cxx doc fortran hdf5 szip" 
[0]
[nomerge      ]    sci-libs/hdf5-1.8.4-r2  USE="cxx examples fortran mpi szip
threads zlib"  [2]
[nomerge      ]     virtual/mpi-2.0  USE="cxx fortran romio"  [0]
[ebuild  N    ]      sys-cluster/openmpi-1.4.1  USE="cxx fortran ipv6 romio


What should I do, mask openmpi and have perhaps difficulties with octave-forge-octcdf or mask mpich2, reemerge all mpi dependent packages (vtk, etc ) and have perhaps again the issues described in Bug 302056 and Bug 296518?
Comment 3 Juergen Rose 2010-02-14 22:32:52 UTC
At some computers I tried to remove mpich2 and to emerge world, which was successful. Then I remerged the directly mpi depending packages:

root@condor:/(62)# for p in `equery -qC hasuse mpi` ; do emerge -v1 =$p ; done

which was also successful. Then I tried to reemerge the packages which has mpi related issues:


root@condor:/(63)# emerge -v1 netcdf octave gdal

The first two packages also reemerge successful, but gdal fails with the error  (Bug 296790):

x86_64-pc-linux-gnu-g++ -Wl,-O1 gdalinfo.o  -L/var/tmp/portage/sci-libs/gdal-1.6.2/work/gdal-1.6.2 -lgdal  -L/usr/lib64 -lgeos_c -I/usr/include -lsqlite3 -lodbc -lodbcinst -L/usr/lib -lexpat -L/usr/lib -lxerces-c -lpthread -ljasper -lhdf5 -L/usr/lib64 -L/usr/lib64/lib -logdi31 -ljpeg -lgeotiff -ltiff -lpng -lnetcdf -lcfitsio -lpq -L/usr/lib64/postgresql-8.3/lib64 -lpq -lz -lpthread -lm -lrt -ldl    -lcurl -lldap -lrt -L/usr/lib64 -Wl,-rpath -Wl,/usr/lib64 -march=nocona -O2 -pipe -fomit-frame-pointer -g0 -Wno-system-headers -lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err -lresolv -ldl -L/usr/lib64 -Wl,-rpath -Wl,/usr/lib64 -march=nocona -O2 -pipe -fomit-frame-pointer -g0 -Wno-system-headers -lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err -lresolv -ldl -lz -lgnutls   -L/usr/lib64/mysql -lmysqlclient -lz -lcrypt -lnsl -lm -L/usr/lib64 -lssl -lcrypto -o gdalinfo
/var/tmp/portage/sci-libs/gdal-1.6.2/work/gdal-1.6.2/libgdal.so: undefined reference to `ompi_mpi_cxx_op_intercept'
/var/tmp/portage/sci-libs/gdal-1.6.2/work/gdal-1.6.2/libgdal.so: undefined reference to `MPI::Datatype::Free()'
/var/tmp/portage/sci-libs/gdal-1.6.2/work/gdal-1.6.2/libgdal.so: undefined reference to `MPI::Comm::Comm()'
/var/tmp/portage/sci-libs/gdal-1.6.2/work/gdal-1.6.2/libgdal.so: undefined reference to `MPI::Win::Free()'
collect2: ld returned 1 exit status

This happens at least on two computers. Any hint is appreciated.

Comment 4 Sebastian Luther (few) 2010-02-15 05:37:43 UTC
(In reply to comment #2)
> What should I do, mask openmpi and have perhaps difficulties with
> octave-forge-octcdf or mask mpich2, reemerge all mpi dependent packages (vtk,
> etc ) and have perhaps again the issues described in Bug 302056 and Bug 296518?

That's up to you. Do what causes you less headache.

># emerge -v1 netcdf octave gdal
>The first two packages also reemerge successful, but gdal fails with the error 
>(Bug 296790):
[...]
>This happens at least on two computers. Any hint is appreciated.

bug 296790 comment 7 has a one line fix. Put the gdal ebuild in a local overlay and add the line on top of src_configure. (Or just wait for someone to fix the ebuild)
Comment 5 Steve Arnold gentoo-dev 2010-03-04 01:26:26 UTC
If you have mpich2 installed, which satisfies the virtual, then there must be something hard-dep'd on openmpi when it should really depend on virtual/mpi instead.  This may also be true for certain packages that still depend on mpich2 directly (but I can't think of any right now).

It looks like vtk-5.4.2-r1 still uses the old combo-depend on the actual mpi packages, and openmpi is first in the list (which would be why it's being pulled in preference to mpich2).

My recent experiences with openmpi vs mpich2 echo the posts here, in that I just had several build failures with packages related to openmpi, but everything works just fine with mpich2 (everything but boost apparently).

IMHO, right now openmpi is broken, so whether it comes first in the virtual or first in a combo-depend, it still causes breakage either way.  I just went through this argument recently over my fix for mpich2, and I couldn't convince the current package maintainers that unresolved symbols in mpi libs equals a broken library rather than a failure to use the mpi wrappers.

The mpich2 upstream guys ended the argument for me by fixing their build setup (rendering my patch obsolete) but openmpi appears to have the exact same problem.  Again, adding an "mpi wrapper" work-around to half a dozen packages does not fix the broken openmpi libs.  Period.
Comment 6 Juergen Rose 2010-03-05 13:03:49 UTC
At some computers I removed mpich2 ,  followed bug 296790 comment 7, could install gdal, octave etc and I am satisfied. Thanks for the hints.
Comment 7 Thomas Sachau gentoo-dev 2010-03-12 14:45:38 UTC
I currently dont see any reason, why openmpi should be pulled in, when mpich2 is installed. The above emerge output suggests virutal/mpi, but it also accepts mpich2 as dependency. If this issue is still existing, please reopen this bug and add some informations about packages, which want mpich2 and which want openmpi