Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 304489 - media-video/vlc-1.0.4 and media-libs/libcaca-0.99_beta16 fail to build due to missing /usr/lib/libGLU.la
Summary: media-video/vlc-1.0.4 and media-libs/libcaca-0.99_beta16 fail to build due to...
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
: 332587 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-02-11 02:21 UTC by DEMAINE Benoît-Pierre, aka DoubleHP
Modified: 2010-08-17 10:24 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
/tmp/emerge--info (emerge--info,14.10 KB, text/plain)
2010-02-11 02:22 UTC, DEMAINE Benoît-Pierre, aka DoubleHP
Details
/var/log/portage/media-video:vlc-1.0.4:20100211-015334.log (media-video:vlc-1.0.4:20100211-015334.log,548.66 KB, text/plain)
2010-02-11 02:22 UTC, DEMAINE Benoît-Pierre, aka DoubleHP
Details

Note You need to log in before you can comment on or make changes to this bug.
Description DEMAINE Benoît-Pierre, aka DoubleHP 2010-02-11 02:21:47 UTC
uranus ~ # emerge -va media-video/vlc
These are the packages that would be merged, in order:
Calculating dependencies... done!
[ebuild  N    ] media-video/vlc-1.0.4  USE="X a52 aac aalib alsa avahi bidi
cdda cddax cddb cdio dbus dc1394 dirac directfb dts dvb dvd fbcon ffmpeg flac
fluidsynth gcrypt ggi gnome gnutls hal httpd id3tag ieee1394 jack kate libass
libcaca libnotify libtiger libv4l2 lirc live lua matroska mmx modplug mp3 mpeg
mtp musepack ncurses nsplugin ogg opengl oss png pulseaudio pvr qt4 rtsp samba
schroedinger sdl sdl-image shout skins speex sse stream svg taglib theora
truetype twolame udev upnp v4l v4l2 vcdinfo vcdx vlm vorbis wma-fixed x264
xinerama xml xosd xv (-altivec) -atmo -debug -fontconfig -libproxy -libsysfs
-optimisememory (-pda) -remoteosd -run-as-root -shine (-svga) (-win32codecs)
-xcb -zvbi" 0 kB
[...]
libtool: link: x86_64-pc-linux-gnu-gcc -std=gnu99 -shared 
.libs/libpulse_plugin_la-pulse.o  -Wl,--whole-archive
../../compat/.libs/libcompat.a -Wl,--no-whole-archive  -Wl,-rpath
-Wl,/var/tmp/portage/media-video/vlc-1.0.4/work/vlc-1.0.4/src/.libs -lpulse
-Wl,--as-needed ../../src/.libs/libvlccore.so -L/usr/lib64 /usr/lib64/libhal.so
-luuid /usr/lib64/libdbus-1.so -lrt -lpthread -ldl -lm  -march=athlon64  
-Wl,-soname -Wl,libpulse_plugin.so -o .libs/libpulse_plugin.so
libtool: link: x86_64-pc-linux-gnu-gcc -std=gnu99 -shared 
.libs/libalsa_plugin_la-alsa.o  -Wl,--whole-archive
../../compat/.libs/libcompat.a -Wl,--no-whole-archive  -Wl,-rpath
-Wl,/var/tmp/portage/media-video/vlc-1.0.4/work/vlc-1.0.4/src/.libs
-Wl,--as-needed /usr/lib64/libasound.so ../../src/.libs/libvlccore.so
-L/usr/lib64 /usr/lib64/libhal.so -luuid /usr/lib64/libdbus-1.so -lrt -lpthread
-ldl -lm  -march=athlon64   -Wl,-soname -Wl,libalsa_plugin.so -o
.libs/libalsa_plugin.so
/bin/grep: /usr/lib/libGLU.la: No such file or directory
/bin/sed: can't read /usr/lib/libGLU.la: No such file or directory
libtool: link: `/usr/lib/libGLU.la' is not a valid libtool archive
make[4]: *** [libaout_sdl_plugin.la] Error 1
make[4]: *** Waiting for unfinished jobs....

This bug seems similar to bug #38425

Stable AMD64 with unmasked stuff

Linux uranus 2.6.31-xen-r10-Gentoo-uranus-1-12 #5 SMP Sat Jan 16 05:54:35 CET 2010 x86_64 AMD Phenom(tm) II X4 965 Processor AuthenticAMD GNU/Linux

dhp@uranus ~ $ emerge -va mesa
superuser access is required... adding --pretend to options
These are the packages that would be merged, in order:
Calculating dependencies... done!
[ebuild   R   ] media-libs/mesa-7.6.1  USE="motif nptl xcb -debug (-gallium) -pic" VIDEO_CARDS="radeon radeonhd -intel -mach64 -mga -none -r128 -s3virge -savage -sis (-sunffb) -tdfx -trident -via" 0 kB
Total: 1 package (1 reinstall), Size of downloads: 0 kB
dhp@uranus ~ $
Comment 1 DEMAINE Benoît-Pierre, aka DoubleHP 2010-02-11 02:22:07 UTC
Created attachment 219179 [details]
/tmp/emerge--info
Comment 2 DEMAINE Benoît-Pierre, aka DoubleHP 2010-02-11 02:22:26 UTC
Created attachment 219181 [details]
/var/log/portage/media-video:vlc-1.0.4:20100211-015334.log
Comment 3 Rafał Mużyło 2010-02-11 12:42:25 UTC
While 'ls -l /usr/lib/libGL*' may be interesting,
while revdep-rebuild is the ultimate solution,
lafilefixer should be good for a quick fix.
Comment 4 DEMAINE Benoît-Pierre, aka DoubleHP 2010-02-11 17:13:06 UTC
ls -l /usr/lib/libGL*
-rw-r--r-- 1 root root 446274 2010-01-15 02:45 /usr/lib/libGLEW.a
lrwxrwxrwx 1 root root     16 2010-01-15 02:45 /usr/lib/libGLEW.so -> libGLEW.so.1.5.1
lrwxrwxrwx 1 root root     16 2010-01-15 02:45 /usr/lib/libGLEW.so.1.5 -> libGLEW.so.1.5.1
-rwxr-xr-x 1 root root 325528 2010-01-15 02:45 /usr/lib/libGLEW.so.1.5.1
lrwxrwxrwx 1 root root     32 2010-01-30 06:54 /usr/lib/libGL.so -> opengl/xorg-x11/lib/libGL.so.1.2
lrwxrwxrwx 1 root root     11 2010-01-19 18:01 /usr/lib/libGLU.so -> libGLU.so.1
lrwxrwxrwx 1 root root     20 2010-01-19 18:01 /usr/lib/libGLU.so.1 -> libGLU.so.1.3.070601
-rwxr-xr-x 1 root root 453104 2010-01-19 18:00 /usr/lib/libGLU.so.1.3.070601
lrwxrwxrwx 1 root root     11 2010-01-19 18:01 /usr/lib/libGLw.so -> libGLw.so.1
lrwxrwxrwx 1 root root     15 2010-01-19 18:01 /usr/lib/libGLw.so.1 -> libGLw.so.1.0.0
-rwxr-xr-x 1 root root  26592 2010-01-19 18:00 /usr/lib/libGLw.so.1.0.0


uranus ~ # lafilefixer
bash: lafilefixer: command not found
uranus ~ #

I thought revdep-rebuild was deprecated by portage-2.2 ...

revdep-rebuild itself failed:
Failed to emerge media-libs/libcaca-0.99_beta16
/bin/grep: /usr/lib/libGLU.la: No such file or directory
/bin/sed: can't read /usr/lib/libGLU.la: No such file or directory
Comment 5 DEMAINE Benoît-Pierre, aka DoubleHP 2010-02-11 17:18:16 UTC
emerge -va1 mesa
...
uranus piklab # ls /usr/lib/libGLU*
/usr/lib/libGLU.so  /usr/lib/libGLU.so.1  /usr/lib/libGLU.so.1.3.070601
uranus piklab #

So, the deep problem lays in fact in mesa ?

[ebuild   R   ] media-libs/mesa-7.6.1  USE="motif nptl xcb -debug (-gallium) -pic" VIDEO_CARDS="radeon radeonhd -intel -mach64 -mga -none -r128 -s3virge -savage -sis (-sunffb) -tdfx -trident -via" 0 kB
Comment 6 DEMAINE Benoît-Pierre, aka DoubleHP 2010-02-11 17:25:04 UTC
On the old system: media-libs/mesa-7.3-r1:
uranus / # equery f media-libs/mesa | grep -i glu
/usr/include/GL/glu.h
/usr/include/GL/glu_mangle.h
/usr/lib/libGLU.la
/usr/lib/libGLU.so
/usr/lib/libGLU.so.1
/usr/lib/libGLU.so.1.3.070300
/usr/lib/pkgconfig/glu.pc
uranus / #

On the new one: media-libs/mesa-7.6.1
uranus ~ # equery f media-libs/mesa | grep -i glu
/usr/include/GL/glu.h
/usr/include/GL/glu_mangle.h
/usr/lib64/libGLU.so
/usr/lib64/libGLU.so.1
/usr/lib64/libGLU.so.1.3.070601
/usr/lib64/pkgconfig/glu.pc
uranus ~ #

Old one: 
uranus / # equery b /usr/bin/lafilefixer
[ Searching for file(s) /usr/bin/lafilefixer in *... ]
dev-util/lafilefixer-0.5 (/usr/bin/lafilefixer)
uranus / #

Installing it on the new system ... run it ... 

uranus ~ # lafilefixer
uranus ~ # ls /usr/lib/libGLU*
/usr/lib/libGLU.so  /usr/lib/libGLU.so.1  /usr/lib/libGLU.so.1.3.070601
uranus ~ #

=> not better.

Try to remerege libcaca (who knows) (it's faster to bug than VLC).
=> same problem.
Comment 7 Rafał Mużyło 2010-02-11 20:26:47 UTC
It's 'lafilefixer --justfixit', IIRC.
And anyway, '--help' is nearly always helpful.
Comment 8 DEMAINE Benoît-Pierre, aka DoubleHP 2010-02-11 21:43:15 UTC
After
lafilefixer --justfixit


dhp@uranus ~ $ ls -l /usr/lib/libGL*
-rw-r--r-- 1 root root 446274 2010-01-15 02:45 /usr/lib/libGLEW.a
lrwxrwxrwx 1 root root     16 2010-01-15 02:45 /usr/lib/libGLEW.so -> libGLEW.so.1.5.1
lrwxrwxrwx 1 root root     16 2010-01-15 02:45 /usr/lib/libGLEW.so.1.5 -> libGLEW.so.1.5.1
-rwxr-xr-x 1 root root 325528 2010-01-15 02:45 /usr/lib/libGLEW.so.1.5.1
lrwxrwxrwx 1 root root     32 2010-02-11 18:16 /usr/lib/libGL.so -> opengl/xorg-x11/lib/libGL.so.1.2
lrwxrwxrwx 1 root root     11 2010-02-11 18:16 /usr/lib/libGLU.so -> libGLU.so.1
lrwxrwxrwx 1 root root     20 2010-02-11 18:16 /usr/lib/libGLU.so.1 -> libGLU.so.1.3.070601
-rwxr-xr-x 1 root root 453104 2010-02-11 18:15 /usr/lib/libGLU.so.1.3.070601
lrwxrwxrwx 1 root root     11 2010-02-11 18:16 /usr/lib/libGLw.so -> libGLw.so.1
lrwxrwxrwx 1 root root     15 2010-02-11 18:16 /usr/lib/libGLw.so.1 -> libGLw.so.1.0.0
-rwxr-xr-x 1 root root  26592 2010-02-11 18:15 /usr/lib/libGLw.so.1.0.0
dhp@uranus ~ $

so ... still no hope to compile libcaca or vlc.

Mesa should do it by itself !!!
Comment 9 Rafał Mużyło 2010-02-12 15:49:47 UTC
lafilefixer doesn't create la files
- it removes references to other la files from them.

If you missed the note: those Mesa la files are *correctly*
no longer there.
Comment 10 Thomas Sachau gentoo-dev 2010-03-11 21:18:11 UTC
There was a news item about removal of .la files for opengl.

It suggested to install lafilefixer and run it with "lafilefixer --justfixit". This would remove any existing reference to the removed .la files. After that, both packages should be able to compile and install again. Since this issue is nothing, which can be fixed by vlc or libcaca maintainers, i will close it as invalid.
Comment 11 Samuli Suominen gentoo-dev 2010-08-17 10:24:27 UTC
*** Bug 332587 has been marked as a duplicate of this bug. ***