Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 304377 - net-print/cups-1.3.11-r1 circular dependency with USE="cups cairo"
Summary: net-print/cups-1.3.11-r1 circular dependency with USE="cups cairo"
Status: RESOLVED DUPLICATE of bug 175808
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-10 19:32 UTC by Rob
Modified: 2010-02-10 22:28 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rob 2010-02-10 19:32:38 UTC
net-print/cups-1.3.11-r1 creates a circular dependency with the USE flags +cups and +cairo. Cups requires poppler. Poppler with USE="cairo" will depend on GTK+. GTK+ with USE="cups" will require cups, which we are trying to install.

Reproducible: Always

Steps to Reproduce:
1.have cups and cairo USE flags set
2.emerge cups or anything that depends on cups




Expected Results:  
cups emerges without any blocks
Comment 1 Samuli Suominen gentoo-dev 2010-02-10 22:28:44 UTC

*** This bug has been marked as a duplicate of bug 175808 ***