Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 304093 - mail-filter/maildrop-2.4.0 complains about (Unknown character set: ANSI_X3.4-1968 )
Summary: mail-filter/maildrop-2.4.0 complains about (Unknown character set: ANSI_X3.4-...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Server (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Net-Mail Packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-09 04:35 UTC by nuitari
Modified: 2010-02-16 19:11 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nuitari 2010-02-09 04:35:25 UTC
I use qmail-scanner, and mail-filter/maildrop-2.4.0 keeps complaining about Unknown character set: ANSI_X3.4-1968.

This causes qmail-scanner to fail and qq to issue a 451 temporary local problem message instead of receiving the email.

Reproducible: Always
Comment 1 Peter Volkov (RETIRED) gentoo-dev 2010-02-09 07:05:44 UTC
Do you have all required locales installed? Try to configure locale on server:
http://www.gentoo.org/doc/en/guide-localization.xml Does this help?
Comment 2 nuitari 2010-02-09 18:36:49 UTC
www ~ # cat /etc/env.d/02locale
LANG="en_US"
LC_COLLATE="C"

did env-update && source /etc/profile

www ~ # locale
LANG=en_US
LC_CTYPE="en_US"
LC_NUMERIC="en_US"
LC_TIME="en_US"
LC_COLLATE=C
LC_MONETARY="en_US"
LC_MESSAGES="en_US"
LC_PAPER="en_US"
LC_NAME="en_US"
LC_ADDRESS="en_US"
LC_TELEPHONE="en_US"
LC_MEASUREMENT="en_US"
LC_IDENTIFICATION="en_US"
LC_ALL=

So we know the changes happenned.
Restarted svscan 
Still having the problem.
Comment 3 Peter Volkov (RETIRED) gentoo-dev 2010-02-10 07:28:10 UTC
And what is the output of locale-gen -l? Also try the following solution:
http://bitprison.net/gnome-terminal_character_encoding_utf-8

Also there was discussion:
http://sourceware.org/ml/libc-alpha/2000-11/msg00013.html
and http://markmail.org/message/dryvwfkzpxyw7hzv

So it's possible that maildrop just missed setlocale(LC_ALL, ""); call.
Comment 4 nuitari 2010-02-10 16:50:56 UTC
www ~ # locale-gen -l
en_US.ISO-8859-1
en_US.UTF-8
fr_FR.UTF-8
fr_CA.UTF-8

I tried using en_US.UTF-8, but the problem persists.

I've added
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
to /etc/environment


I've added some tracing calls to qmail-scanner.pl, and it looks like LANG resets to C.
Comment 5 Torsten Veller (RETIRED) gentoo-dev 2010-02-16 11:09:01 UTC
Please try mail-filter/maildrop-2.4.1 and close the bug if that version works for you. 
Comment 6 nuitari 2010-02-16 19:11:34 UTC
The new version works