Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 303615 - net-libs/xulrunner:1.9 slot conflict between mozilla-firefox-3.6-r1 and vlc-1.0.5
Summary: net-libs/xulrunner:1.9 slot conflict between mozilla-firefox-3.6-r1 and vlc-1...
Status: RESOLVED DUPLICATE of bug 290318
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Alexis Ballier
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-05 19:32 UTC by Paramonov Valeriy
Modified: 2010-02-12 15:55 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paramonov Valeriy 2010-02-05 19:32:22 UTC
Hi! I have a trouble in slot conflict. See emerge error below:
---
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

net-libs/xulrunner:1.9

  ('ebuild', '/', 'net-libs/xulrunner-1.9.2-r1', 'merge') pulled in by
    ~net-libs/xulrunner-1.9.2[java,libnotify,-wifi] required by ('ebuild', '/', 'www-client/mozilla-firefox-3.6-r1', 'merge')
    (and 5 more)

  ('installed', '/', 'net-libs/xulrunner-1.9.1.7', 'nomerge') pulled in by
    <net-libs/xulrunner-1.9.2 required by ('installed', '/', 'media-video/vlc-1.0.5', 'nomerge')
    (and 5 more)
---

Reproducible: Always

Steps to Reproduce:
Comment 1 Jory A. Pratt gentoo-dev 2010-02-07 19:44:52 UTC
If you downgrade xulrunner, you must download firefox, once you do this you will see that vlc is fine. There is a patch avaliable for vlc on another bug report, that will allow you to compile vlc-1.0.5 against xulrunner-1.9.2 or you may refer to my dev overlay which has it already applied.

http://git.overlays.gentoo.org/gitweb/?p=dev/anarchy.git;a=tree;f=media-video/vlc;h=68e5589824bb3db92edbb494b203123d23b31365;hb=6b0ce09818c70d5d44aadcf95f2570084bfc9b94
Comment 2 Paramonov Valeriy 2010-02-08 07:09:53 UTC
(In reply to comment #1)
> If you downgrade xulrunner, you must download firefox, once you do this you
> will see that vlc is fine.

I see.

> There is a patch avaliable for vlc on another bug
> report, that will allow you to compile vlc-1.0.5 against xulrunner-1.9.2 or you
> may refer to my dev overlay ...

Thanks.
Comment 3 Jim Ramsay (lack) (RETIRED) gentoo-dev 2010-02-11 13:54:49 UTC
(In reply to comment #1)
> http://git.overlays.gentoo.org/gitweb/?p=dev/anarchy.git;a=tree;f=media-video/vlc;h=68e5589824bb3db92edbb494b203123d23b31365;hb=6b0ce09818c70d5d44aadcf95f2570084bfc9b94

Full speed ahead!  Let's throw that patch in the main tree then?
Comment 4 Samuli Suominen (RETIRED) gentoo-dev 2010-02-12 15:55:05 UTC

*** This bug has been marked as a duplicate of bug 290318 ***