Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 303138 - Working with a fresh install of Gentoo, portage reports circular dependencies when emerging kde
Summary: Working with a fresh install of Gentoo, portage reports circular dependencies...
Status: RESOLVED DUPLICATE of bug 175808
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-01 19:37 UTC by Shaun Oleson
Modified: 2010-02-02 07:03 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shaun Oleson 2010-02-01 19:37:30 UTC
I am running into the following circular dependency errors when trying to emerge some of the kde4 sets. This issue also happened with dev-util/git until I disabled the qt3, qt4 and gtk USE flags in make.conf. Now that I'm installing KDE4, I need the qt4 flags enabled. I'm hoping I've overlooked something obvious here. Thanks for your assistance.

Reproducible: Always

Steps to Reproduce:
1.emerge -av @kdeadmin-4.4 @kdeartwork-4.4 @kdebase-4.4 @kdebindings-4.4 @kdegraphics-4.4 @kdelibs-4.4 @kdemultimedia-4.4 @kdenetwork-4.4 @kdesdk-4.4 @kdeutils-4.4
2.
3.
Actual Results:  
These are the packages that would be merged, in order:

Calculating dependencies... done!


[nomerge      ] kde-base/kdeartwork-sounds-4.3.98  USE="(-aqua) (-kdeenablefinal) (-kdeprefix)" 
[nomerge      ]  x11-libs/qt-gui-4.6.1  USE="accessibility cups dbus glib gtk mng qt3support tiff (-aqua) -debug -nas -nis -pch -raster -xinerama" 
[ebuild  N    ]   net-print/cups-1.4.2-r1  USE="X acl dbus jpeg ldap pam perl png python ssl tiff -debug -gnutls -java -kerberos -php -samba -slp -static -xinetd" LINGUAS="-da -de -es -eu -fi -fr -it -ja -ko -nl -no -pl -pt -pt_BR -ru -sv -zh -zh_TW" 
[ebuild  N    ]    virtual/poppler-utils-0.12.3-r1  USE="abiword png"                                                                                                                                                                                      
[ebuild  N    ]     app-text/poppler-0.12.3-r3  USE="abiword cairo jpeg lcms png qt4 utils xpdf-headers -cjk -debug -doc -exceptions -jpeg2k"                                                                                                              
[ebuild  N    ]      x11-libs/gtk+-2.18.6  USE="cups jpeg tiff (-aqua) -debug -doc -jpeg2k -test -vim-syntax -xinerama"                                                                                                                                    
[ebuild  N    ]      x11-libs/qt-gui-4.6.1  USE="accessibility cups dbus glib gtk mng qt3support tiff (-aqua) -debug -nas -nis -pch -raster -xinerama"                                                                                                     
[ebuild  N    ]      dev-util/cmake-2.8.0-r2  USE="ncurses qt4 -emacs -vim-syntax"                                                                                                                                                                         

 * Error: circular dependencies:

('ebuild', '/', 'x11-libs/gtk+-2.18.6', 'merge') depends on
  ('ebuild', '/', 'net-print/cups-1.4.2-r1', 'merge') (buildtime)
('ebuild', '/', 'virtual/poppler-utils-0.12.3-r1', 'merge') depends on
  ('ebuild', '/', 'app-text/poppler-0.12.3-r3', 'merge') (buildtime)  
('ebuild', '/', 'dev-util/cmake-2.8.0-r2', 'merge') depends on        
  ('ebuild', '/', 'x11-libs/qt-gui-4.6.1', 'merge') (buildtime)       
('ebuild', '/', 'app-text/poppler-0.12.3-r3', 'merge') depends on     
  ('ebuild', '/', 'x11-libs/qt-gui-4.6.1', 'merge') (buildtime)       
  ('ebuild', '/', 'dev-util/cmake-2.8.0-r2', 'merge') (buildtime)     
  ('ebuild', '/', 'x11-libs/gtk+-2.18.6', 'merge') (buildtime)        
('ebuild', '/', 'x11-libs/qt-gui-4.6.1', 'merge') depends on          
  ('ebuild', '/', 'net-print/cups-1.4.2-r1', 'merge') (buildtime)     
  ('ebuild', '/', 'x11-libs/gtk+-2.18.6', 'merge') (buildtime)        
('ebuild', '/', 'net-print/cups-1.4.2-r1', 'merge') depends on        
  ('ebuild', '/', 'virtual/poppler-utils-0.12.3-r1', 'merge') (buildtime)

 * Note that circular dependencies can often be avoided by temporarily
 * disabling USE flags that trigger optional dependencies.

Expected Results:  
successful Emerge

Portage 2.2_rc62 (default/linux/amd64/10.0/desktop, gcc-4.3.4, glibc-2.11-r1, 2.6.32-gentoo-r3 x86_64)
=================================================================                                     
System uname: Linux-2.6.32-gentoo-r3-x86_64-Intel-R-_Core-TM-_i7_CPU_920_@_2.67GHz-with-gentoo-2.0.1  
Timestamp of tree: Mon, 01 Feb 2010 16:00:01 +0000                                                    
app-shells/bash:     4.0_p37                                                                          
dev-lang/python:     2.6.4-r1, 3.1.1-r1                                                               
sys-apps/baselayout: 2.0.1                                                                            
sys-apps/openrc:     0.6.0-r1                                                                         
sys-apps/sandbox:    2.2                                                                              
sys-devel/autoconf:  2.65
sys-devel/automake:  1.10.3, 1.11.1
sys-devel/binutils:  2.20.51.0.5
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA PUEL dlj-1.1"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe -ggdb"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.mirrors.tds.net/gentoo http://open-systems.ufl.edu/mirrors/gentoo http://gentoo.llarian.net/ ftp://gentoo.llarian.net/pub/gentoo"
LDFLAGS="-Wl,-O1"
LINGUAS="en_US"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/kde"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 apache2 berkdb bluetooth branding bzip2 cairo cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam firefox flac fortran gd gdbm ggdb gif glib gnome gpm gstreamer gtk gzip hal hash iconv ipv6 jpeg kde kde4 ldap libnotify lm_sensors mad mhash mikmod mmx mng modules mp3 mp4 mpeg mssql mudflap multilib mysql ncurses nls nptl nptlonly offensive ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3 qt3support qt4 quicktime readline reflection rss sdl semantic-desktop session simplexml sockets spell spl sql sse sse2 ssl startup-notification svg sysfs tcpd threads thunar tidy tiff truetype unicode usb vorbis webkit x264 xcomposite xml xmlreader xmlwriter xorg xulrunner xv xvid zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias proxy proxy_http" APACHE2_MPMS="worker" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_US" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fglrx"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Ben Kohler gentoo-dev 2010-02-01 19:40:29 UTC
Try disabling the cups USE flag
Comment 2 Shaun Oleson 2010-02-01 19:49:01 UTC
I added -cups to my make.conf and I get the following result:

emerge -av @kdeadmin-4.4 @kdeartwork-4.4 @kdebase-4.4 @kdebindings-4.4 @kdegraphics-4.4 @kdelibs-4.4 @kdemultimedia-4.4   @kdenetwork-4.4 @kdenetwork-4.4 @kdesdk-4.4 @kdeutils-4.4

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy "app-text/ghostscript-gpl[cups]".
!!! One of the following packages is required to complete your request:
- app-text/ghostscript-gpl-8.70-r1 (Change USE: +cups)
(dependency required by "net-print/cups-1.4.2-r1" [ebuild])
(dependency required by "app-misc/hal-cups-utils-0.6.19" [ebuild])
(dependency required by "kde-base/printer-applet-4.3.98" [ebuild])
(dependency required by "@kdeutils-4.4" [argument])
Comment 3 Shaun Oleson 2010-02-01 20:04:02 UTC
I'm currently attempting to explicitly set the USE in make.conf to explicitly exclude gtk (-gtk). I'll post back as that result becomes avail. Then after emerging KDE4, I can re-add the flag and try to update world deep with new use.
Comment 4 Shaun Oleson 2010-02-01 20:15:31 UTC
ok, after pulling gtk out of the use flags, I still get the following result:
These are the packages that would be merged, in order:

Calculating dependencies... done!


[nomerge      ] kde-base/kdeartwork-sounds-4.3.98  USE="(-aqua) (-kdeenablefinal) (-kdeprefix)"
[nomerge      ]  x11-libs/qt-gui-4.6.1  USE="accessibility cups dbus glib mng qt3support tiff (-aqua) -debug -gtk -nas -nis -pch -raster -xinerama"
[ebuild  N    ]   net-print/cups-1.4.2-r1  USE="X acl dbus jpeg ldap pam perl png python ssl tiff -debug -gnutls -java -kerberos -php -samba -slp -static -xinetd" LINGUAS="-da -de -es -eu -fi -fr -it -ja -ko -nl -no -pl -pt -pt_BR -ru -sv -zh -zh_TW"
[ebuild  N    ]    virtual/poppler-utils-0.12.3-r1  USE="abiword png"
[ebuild  N    ]     app-text/poppler-0.12.3-r3  USE="abiword cairo jpeg lcms png qt4 utils xpdf-headers -cjk -debug -doc -exceptions -jpeg2k"
[ebuild  N    ]      x11-libs/gtk+-2.18.6  USE="cups jpeg tiff (-aqua) -debug -doc -jpeg2k -test -vim-syntax -xinerama"
[ebuild  N    ]      x11-libs/qt-gui-4.6.1  USE="accessibility cups dbus glib mng qt3support tiff (-aqua) -debug -gtk -nas -nis -pch -raster -xinerama"
[ebuild  N    ]      dev-util/cmake-2.8.0-r2  USE="ncurses qt4 -emacs -vim-syntax"

 * Error: circular dependencies:

('ebuild', '/', 'x11-libs/gtk+-2.18.6', 'merge') depends on
  ('ebuild', '/', 'net-print/cups-1.4.2-r1', 'merge') (buildtime)
('ebuild', '/', 'virtual/poppler-utils-0.12.3-r1', 'merge') depends on
  ('ebuild', '/', 'app-text/poppler-0.12.3-r3', 'merge') (buildtime)
('ebuild', '/', 'dev-util/cmake-2.8.0-r2', 'merge') depends on
  ('ebuild', '/', 'x11-libs/qt-gui-4.6.1', 'merge') (buildtime)
('ebuild', '/', 'app-text/poppler-0.12.3-r3', 'merge') depends on
  ('ebuild', '/', 'x11-libs/qt-gui-4.6.1', 'merge') (buildtime)
  ('ebuild', '/', 'dev-util/cmake-2.8.0-r2', 'merge') (buildtime)
  ('ebuild', '/', 'x11-libs/gtk+-2.18.6', 'merge') (buildtime)
('ebuild', '/', 'x11-libs/qt-gui-4.6.1', 'merge') depends on
  ('ebuild', '/', 'net-print/cups-1.4.2-r1', 'merge') (buildtime)
('ebuild', '/', 'net-print/cups-1.4.2-r1', 'merge') depends on
  ('ebuild', '/', 'virtual/poppler-utils-0.12.3-r1', 'merge') (buildtime)

 * Note that circular dependencies can often be avoided by temporarily
 * disabling USE flags that trigger optional dependencies.
Comment 5 Shaun Oleson 2010-02-01 21:38:24 UTC
OK, it seems I have found a resolve for now. I have added -cups to the package.use for gtk+ and qt-gui. I'll re-enable them after I have KDE 4 emerged. Thanks again for your help.
Comment 6 Peter Volkov (RETIRED) gentoo-dev 2010-02-02 07:02:37 UTC
gtk+ -> cups -> gtk+ is the most common circular dependency: to build cups gui  gtk+ is required while to build gtk+ with printing support cups is required. To resolve this conflict try to:

USE="-cups -doc" emerge -1 gtk+

after that proceed as normal.

*** This bug has been marked as a duplicate of bug 175808 ***

*** This bug has been marked as a duplicate of bug 175808 ***
Comment 7 Peter Volkov (RETIRED) gentoo-dev 2010-02-02 07:03:24 UTC
And I'm glad you found correct solution. I was a bit late :)