Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 303011 - [kde-sunset] app-text/poppler-0.12.3-r3: access violation on /usr/qt/3/etc/settings/.qtrc.lock
Summary: [kde-sunset] app-text/poppler-0.12.3-r3: access violation on /usr/qt/3/etc/se...
Status: VERIFIED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-31 19:04 UTC by Navid Zamani
Modified: 2010-02-10 21:15 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Navid Zamani 2010-01-31 19:04:40 UTC
As described in the summary. See below:

Reproducible: Always

Steps to Reproduce:
Just try to emerge the package. Everything up to and including configure is successful. Then the following happens:
Actual Results:  
^[[31;01m--------------------------- ACCESS VIOLATION SUMMARY ---------------------------^[[0m
^[[31;01mLOG FILE^[[0m "/var/log/sandbox/sandbox-14855.log"

VERSION 1.0
FORMAT: F - Function called
FORMAT: S - Access Status
FORMAT: P - Path as passed to function
FORMAT: A - Absolute Path (not canonical)
FORMAT: R - Canonical Path
FORMAT: C - Command Line

F: open_wr
S: deny
P: /usr/qt/3/etc/settings/.qtrc.lock
A: /usr/qt/3/etc/settings/.qtrc.lock
R: /usr/qt/3/etc/settings/.qtrc.lock
C: /usr/qt/3/bin/uic -version
^[[31;01m--------------------------------------------------------------------------------^[[0m
^G^G^G


Expected Results:  
The package should be getting installed.

Please refrain from questions about why I still use KDE 3.5. :)
Instead just imagine that from my p.o.v., I’d then ask the same about you and KDE 4. Which from my p.o.v. looks probably just as bad as 3.5 from yours. (Or worse.)
We would only end in a silly discussion. :)
Comment 1 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-01-31 19:09:26 UTC
As stated in http://kde.gentoo.org kde-sunset is a user-maintained overlay and bugs/problems/whatever should be reported to gentoo-desktop mailing list. Closing as invalid
Comment 2 Navid Zamani 2010-01-31 19:16:08 UTC
Ah, ok, didn’t know that. Then again, the fact that kde-sunset is just installable like that, without pointing me to http://kde.gentoo.org, is definitely a bug. (As nobody is born with that knowledge, or actively searches the web all day long for such knowledge that he does not even know it exists.) Could you please fix that then? :)
Comment 3 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-01-31 19:24:52 UTC
Although it is well documented in kde.gentoo.org, in the kde installation guide, in overlay's description (can be seen in git.overlays.gentoo.org) and in Documentation/commiters, i added one more README file in Documentation. thanks for spotting this
Comment 4 Navid Zamani 2010-01-31 19:28:47 UTC
Oh. Wow. :)
I think the problem is, that Layman does not automatically show the overlay’s description/info, upon adding it. That would be a cool hook, to guarantee that really nobody misses it. What do you think?
(Yes, we’re now a bit off-topic. But I think this is a good moment to ask. :)
Comment 5 Mickaël Bucas 2010-02-10 21:07:52 UTC
The problem is that the kde-sunset overlay contains an ebuild with the same name as in the portage tree, but they are not identical :

# diff /usr/portage/app-text/poppler/poppler-0.12.3-r3.ebuild /usr/local/portage/layman/kde3/app-text/poppler/poppler-0.12.3-r3.ebuild
3c3
< # $Header: /var/cvsroot/gentoo-x86/app-text/poppler/poppler-0.12.3-r3.ebuild,v 1.11 2010/02/09 23:41:01 yngwin Exp $
---
> # $Header: /var/cvsroot/gentoo-x86/app-text/poppler/poppler-0.12.3-r3.ebuild,v 1.10 2010/02/08 23:37:34 yngwin Exp $
15,16c15,16
< KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
< IUSE="+abiword cairo cjk debug doc exceptions jpeg jpeg2k +lcms png qt4 +utils +xpdf-headers"
---
> KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
> IUSE="+abiword cairo cjk debug doc exceptions jpeg jpeg2k +lcms png qt3 qt4 +utils +xpdf-headers"
27a28
>       qt3? ( >=x11-libs/qt-3.3:3 )
51c52
<               -DWITH_Qt3=OFF
---
>               $(cmake-utils_use_with qt3)

As it's an overlay, it takes precedence in dependencies resolution.

My solution : remove the offending ebuild
rm /usr/local/portage/layman/kde3/app-text/poppler/poppler-0.12.3-r3.ebuild

emerge -uND world is now using the ebuild from the portage tree, and the problem is gone.
Comment 6 Samuli Suominen (RETIRED) gentoo-dev 2010-02-10 21:15:48 UTC
For the sandbox violation, the ebuild in overlay should "inherit qt3", and the KEYWORDS should be fixed to stable.

But this doesn't belong here, as already explained, get in touch with the maintainers.