Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 302972 - media-sound/amarok-2.2.2 does not show track lengths (media-libs/taglib issue?)
Summary: media-sound/amarok-2.2.2 does not show track lengths (media-libs/taglib issue?)
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-31 12:04 UTC by Marco DR
Modified: 2010-02-01 10:24 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marco DR 2010-01-31 12:04:17 UTC
After updating from 2.2.0 to 2.2.2 track lengths are not shown anymore in the playlist. They are all shown as 0:00. media-libs/taglib was also updated to 1.6.1-r1, with use flags +asf, +mp4 (as needed). Maybe the something is wrong with taglib?

Reproducible: Always
Comment 1 Marco DR 2010-01-31 13:00:15 UTC
Ok, it's a known bug from Amarok 2.2.1:
https://bugs.kde.org/show_bug.cgi?id=214599

Reported as "FIXED" upstream, but it's only a workaround to me... and wasn't fixed in 2.2.2. It just requires to "Fully rescan collection". In my opinion this operation should be done automatically upon upgrade. Should I file another bug report upstream?
Comment 2 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2010-01-31 23:19:57 UTC
They did add a new button to fully rescan the collection.
You may try to open another upstream bug, but I'd expect it to be closed as a dupe. If something changes, feel free to reopen the bug.
Comment 3 Marco DR 2010-02-01 10:24:12 UTC
Ok, filed upstream: https://bugs.kde.org/show_bug.cgi?id=225117