Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 301918 - VLC 1.0.4 VLCPLUGIN fails to build because of missing declaration (uint16)
Summary: VLC 1.0.4 VLCPLUGIN fails to build because of missing declaration (uint16)
Status: RESOLVED DUPLICATE of bug 290318
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-23 13:41 UTC by Chuck Wegrzyn
Modified: 2010-01-23 17:08 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (build.log,1.40 MB, text/plain)
2010-01-23 13:42 UTC, Chuck Wegrzyn
Details
build environment (environment,155.39 KB, text/plain)
2010-01-23 13:43 UTC, Chuck Wegrzyn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chuck Wegrzyn 2010-01-23 13:41:22 UTC
emerge of vlc:0 failed during build of vlcplugin.

Reproducible: Always

Steps to Reproduce:
1.emerge -puvD world
2.revdep-rebuild
3.

Actual Results:  
vlcplugin.cpp:671: warning: deprecated conversion from string constant to 'char*'                                                                                                                                    
make[2]: *** [libvlcplugin_la-vlcplugin.lo] Error 1                                                                                                                                                                  
In file included from control/npolibvlc.cpp:36:                                                                                                                                                                      
./vlcplugin.h:85: error: 'uint16' has not been declared                                                                                                                                                              
In file included from control/npolibvlc.cpp:36:                                                                                                                                                                      
./vlcplugin.h:138: error: 'uint16' does not name a type                                                                                                                                                              
control/npolibvlc.cpp: In member function 'void LibvlcPlaylistNPObject::parseOptions(const NPString&, int*, char***)':                                                                                               
control/npolibvlc.cpp:952: error: 'const struct _NPString' has no member named 'utf8length'                                                                                                                          
control/npolibvlc.cpp:964: error: 'const struct _NPString' has no member named 'utf8length'                                                                                                                          
make[2]: *** [libvlcplugin_la-npolibvlc.lo] Error 1                                                                                                                                                                  
make[2]: Leaving directory `/var/tmp/portage/media-video/vlc-1.0.4/work/vlc-1.0.4/projects/mozilla'                                                                                                                  
make[1]: *** [all-recursive] Error 1                                                                                                                                                                                 
make[1]: Leaving directory `/var/tmp/portage/media-video/vlc-1.0.4/work/vlc-1.0.4'                                                                                                                                   
make: *** [all] Error 2     

Expected Results:  
Expected vlc to be replaced.

emerge --info                                                                       
Portage 2.1.7.16 (default/linux/x86/10.0, gcc-4.4.2, glibc-2.11-r1, 2.6.32-gentoo i686)                 
=================================================================                                       
System uname: Linux-2.6.32-gentoo-i686-Intel-R-_Core-TM-2_Duo_CPU_E8400_@_3.00GHz-with-gentoo-2.0.1     
Timestamp of tree: Fri, 22 Jan 2010 13:45:01 +0000                                                      
ccache version 2.4 [enabled]                                                                            
app-shells/bash:     4.0_p37                                                                            
dev-java/java-config: 1.3.7-r1, 2.1.10                                                                  
dev-lang/python:     2.4.6, 2.5.4-r3, 2.6.4, 3.1.1-r1                                                   
dev-python/pycrypto: 2.1.0                                                                              
dev-util/ccache:     2.4-r8                                                                             
dev-util/cmake:      2.8.0                                                                              
sys-apps/baselayout: 2.0.1                                                                              
sys-apps/openrc:     0.6.0-r1                                                                           
sys-apps/sandbox:    2.2                                                                                
sys-devel/autoconf:  2.13, 2.65                                                                         
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r3, 1.10.3, 1.11.1                                  
sys-devel/binutils:  2.20                                                                               
sys-devel/gcc-config: 1.4.1                                                                             
sys-devel/libtool:   2.2.6b                                                                             
virtual/os-headers:  2.6.30-r1                                                                          
ACCEPT_KEYWORDS="x86 ~x86"                                                                              
ACCEPT_LICENSE="*"                                                                                      
CBUILD="i686-pc-linux-gnu"                                                                              
CFLAGS="-O2 -march=i686 -pipe"                                                                          
CHOST="i686-pc-linux-gnu"                                                                               
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests ccache distlocks fixpackages metadata-transfer news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_US"
LC_ALL="en_US"
LDFLAGS="-Wl,-O1"
LINGUAS="en_US"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/sunrise /usr/local/portage/layman/nekoverlay"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="X acl additions alsa aspell asyncns bash-completion berkdb bidi bluetooth bzip2 cairo caps cdaudio cdda cddb cdio cdparanoia cli connectionstatus consolekit contactnotes cracklib crypt cups cxx dbus dga divx dmx doc dri dvd dvdread embedded encode examples expat extras firefox3 flac gdbm gif glib gnome gnutls gpm gtk hal htmlhandbook iconv inquisitio ipv6 jabber jadetex java java6 javacomm javamail javascript jce jde jdepend jpeg jpeg2k kde kde4 kdepim kdm lastfm lzo md5sum mecab mng modules mp3 mp4 mpeg mpeg2 mplayer msn mudflap mysql ncurses nls nowlistening nptl nptlonly nsplugin ntfs ogg opengl openmp oscar otr pam parted pcre pda pdf perl pink pipes plasma png postgres ppds pppd pulseaudio python qt3 qt3support qt4 qtdesigner quicktime readline realmedia redland reflection reiserfs rss samba scanner sdk session shout slp smbclient sms soundex spl sql sqlite3 ssl subversion svg sysfs tcpd texteffect threads threadsafe thumbnail thunderbird tiff tk tools truetype unicode usb v4l v4l2 valgrind vboxwebsrv virtualbox vorbis webinterface webkit webpresence wifi win32codecs wireshark wmf wmp wxwidgets wxwindows x86 xine xinerama xml xorg xrandr yahoo zeroconf zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_US" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev ati radeonhd vesa vga"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Chuck Wegrzyn 2010-01-23 13:42:39 UTC
Created attachment 217232 [details]
build log
Comment 2 Chuck Wegrzyn 2010-01-23 13:43:09 UTC
Created attachment 217233 [details]
build environment
Comment 3 Tobias Heinlein (RETIRED) gentoo-dev 2010-01-23 17:08:04 UTC
Thanks for reporting and providing the build logs. However, this is a duplicate of bug #290318.

*** This bug has been marked as a duplicate of bug 290318 ***