Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 3001 - No sound In Chromium
Summary: No sound In Chromium
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Games (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Dan Armak (RETIRED)
Depends on:
Reported: 2002-05-24 19:02 UTC by david mattatall
Modified: 2003-10-26 09:56 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description david mattatall 2002-05-24 19:02:03 UTC
I have compiled Chromium with openal and sdl-sound installed and I still get the following message when starting Chromium, The game works fine, but with no sound.  !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! !! ATTENTION !! - one or more errors were encountered during audio check. !!                Audio will be disabled. !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Comment 1 Dan Armak (RETIRED) gentoo-dev 2002-05-28 15:21:58 UTC
Please copy the complete output of chromium, so that I can get some context. 
Also, try running chromium-setup and configuring sound from there. 
Do other sdl apps work with sound? 
Do you use arts or esd? 
Comment 2 Matt Keadle 2002-05-29 01:53:05 UTC
In the src_compile() section of the Chromium ebuild, the $myconf variable is
built, but never used. The line:

     ./configure || die

Shoudl be changed to:

    econf ${myconf} || die

Without $myconf, SDL and vorbis never make it into the program.
Comment 3 Dan Armak (RETIRED) gentoo-dev 2002-05-29 14:26:47 UTC
Um, yes, that was an oversight :-) fixed now on cvs.  So, does this fix fix your problem? Also, please run chromium-setup and (1) note the console output (2) click on 'openal' in the music/playlist tab and check for any strange output or errors.  Finally, another idea - in the chromium output you sent me you had an audiocd enabled as music. Maybe if you remove it'll help?  
Comment 4 Dan Armak (RETIRED) gentoo-dev 2002-07-06 09:33:05 UTC
No reply --> I presume this is fixed. 
Comment 5 EJ Finneran 2003-10-26 09:56:42 UTC
I also had this problem, but that ebuild change didn't help.  I found a posting
on the forums that says if you have the openal package merged, it breaks
Chromiums internal openal or something to that effect.

Once I unmerged openal and remerged Chromium everything worked fine. 
Unfortunatly some other games required openal so this is just a temporary