Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 299771 - xorg-server segfaults when using xinerama
Summary: xorg-server segfaults when using xinerama
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-05 14:32 UTC by Richard Connon
Modified: 2010-01-19 21:21 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Connon 2010-01-05 14:32:44 UTC
With my xinerama setup xorg-server-1.7.3.902 I get a segfault when I move the mouse to the left of the main screen.
I'm not sure what information is needed to diagnose this issue so please ask for what is relevant.

Reproducible: Always

Steps to Reproduce:
Comment 1 Rémi Cardona gentoo-dev 2010-01-12 17:04:00 UTC
Without any backtraces, that's going to be hard to fix. Please read this guide [1] and try to get a proper backtrace out of Xorg. Those will be available in /var/log/Xorg.0.log.

Once you get a nice backtrace, please attach the full log here.

Thanks
Comment 2 Rémi Cardona gentoo-dev 2010-01-12 17:04:21 UTC
[1] http://www.gentoo.org/proj/en/qa/backtraces.xml
Comment 3 Richard Connon 2010-01-12 17:13:46 UTC
I'll do that ASAP. Probably tomorrow.
Comment 4 Richard Connon 2010-01-13 19:47:22 UTC
Program received signal SIGSEGV, Segmentation fault.
miDCSaveUnderCursor (pDev=0x26877c0, pScreen=0x2388d50, x=<value optimized out>, y=<value optimized out>, w=26, h=32) at midispcur.c:536
536	midispcur.c: No such file or directory.
	in midispcur.c
(gdb) bt
#0  miDCSaveUnderCursor (pDev=0x26877c0, pScreen=0x2388d50, x=<value optimized out>, y=<value optimized out>, w=26, h=32) at midispcur.c:536
#1  0x00000000005529e5 in miSpriteSaveUnderCursor (pDev=0x26877c0, pScreen=0x2388d50) at misprite.c:1039
#2  0x0000000000552c97 in miSpriteSetCursor (pDev=0x26877c0, pScreen=0x2388d50, pCursor=0x26eee00, x=<value optimized out>, 
    y=<value optimized out>) at misprite.c:902
#3  0x0000000000456d9b in miPointerUpdateSprite (pDev=0x26877c0) at mipointer.c:402
#4  0x0000000000456ed3 in miPointerSetCursorPosition (pDev=0x26877c0, pScreen=0x2388d50, x=0, y=0, generateEvent=0) at mipointer.c:241
#5  0x00000000004b06ef in AnimCurSetCursorPosition (pDev=0x26877c0, pScreen=0x2388d50, x=0, y=0, generateEvent=<value optimized out>)
    at animcur.c:266
#6  0x00000000004586bf in mieqProcessDeviceEvent (dev=0x26877c0, event=0x2844c20, screen=0x2388d50) at mieq.c:388
#7  0x000000000045876a in mieqProcessInputEvents () at mieq.c:471
#8  0x0000000000467a38 in ProcessInputEvents () at xf86Events.c:165
#9  0x000000000044d99a in Dispatch () at dispatch.c:371
#10 0x0000000000424f4a in main (argc=3, argv=0x7bc3a0, envp=<value optimized out>) at main.c:285
Comment 5 Richard Connon 2010-01-13 19:51:00 UTC
If there's information missing (the optimised out stuff) let me know. I can recompile without optimisation.

For reference that was done with -ggdb in CFLAGS and splitdebug in features.
Comment 6 Rémi Cardona gentoo-dev 2010-01-19 21:14:29 UTC
Please attach your Xorg.0.log from after the crash.

Thanks
Comment 7 Richard Connon 2010-01-19 21:18:03 UTC
I can no longer reproduce this since I've changed hardware (different GPU)
I now have X just not start if I turn Xinerama.
Should I attach the Xorg.0.log or should I start a new bug?
Comment 8 Rémi Cardona gentoo-dev 2010-01-19 21:21:31 UTC
Yes, please file a new bug. Don't forget to attach your Xorg.0.log.

Thanks