Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 298908 - xfce-base/libxfce4util-4.7.0 failed
Summary: xfce-base/libxfce4util-4.7.0 failed
Status: RESOLVED DUPLICATE of bug 297790
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-29 20:03 UTC by skobk.in
Modified: 2009-12-29 20:09 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description skobk.in 2009-12-29 20:03:21 UTC
config.status: creating xfce4-kiosk-query/Makefile
config.status: creating config.h
config.status: executing depfiles commands
config.status: executing libtool commands
config.status: executing default-1 commands
config.status: executing po/stamp-it commands

Build Configuration:

* Debug Support:  no
* GNU Visibility: yes

make -j3 
make  all-recursive
make[1]: Entering directory `/var/tmp/portage/xfce-base/libxfce4util-4.7.0/work/libxfce4util-4.7.0'
Making all in libxfce4util
make[2]: Entering directory `/var/tmp/portage/xfce-base/libxfce4util-4.7.0/work/libxfce4util-4.7.0/libxfce4util'
make  all-am
make[3]: Entering directory `/var/tmp/portage/xfce-base/libxfce4util-4.7.0/work/libxfce4util-4.7.0/libxfce4util'
  CC     libxfce4util_la-libxfce4util-aliasdef.lo
  CC     libxfce4util_la-libxfce4util-enum-types.lo
  CC     libxfce4util_la-libxfce4util-config.lo
  CC     libxfce4util_la-libxfce4util-private.lo
  CC     libxfce4util_la-xfce-desktopentry.lo
  CC     libxfce4util_la-xfce-fileutils.lo
  CC     libxfce4util_la-xfce-i18n.lo
  CC     libxfce4util_la-xfce-kiosk.lo
  CC     libxfce4util_la-xfce-license.lo
  CC     libxfce4util_la-xfce-miscutils.lo
  CC     libxfce4util_la-xfce-posix-signal-handler.lo
xfce-posix-signal-handler.c: В функции ‘xfce_posix_signal_handler’:
xfce-posix-signal-handler.c:109: предупреждение: результат ‘write’, декларированной с атрибутом warn_unused_result, игнорируется
  CC     libxfce4util_la-xfce-rc.lo
  CC     libxfce4util_la-xfce-rc-config.lo
  CC     libxfce4util_la-xfce-rc-simple.lo
  CC     libxfce4util_la-xfce-resource.lo
  CC     libxfce4util_la-xfce-utf8.lo
  CCLD   libxfce4util.la
make[3]: Leaving directory `/var/tmp/portage/xfce-base/libxfce4util-4.7.0/work/libxfce4util-4.7.0/libxfce4util'
make[2]: Leaving directory `/var/tmp/portage/xfce-base/libxfce4util-4.7.0/work/libxfce4util-4.7.0/libxfce4util'
Making all in docs
make[2]: Entering directory `/var/tmp/portage/xfce-base/libxfce4util-4.7.0/work/libxfce4util-4.7.0/docs'
make[2]: Цель `all' не требует выполнения команд.
make[2]: Leaving directory `/var/tmp/portage/xfce-base/libxfce4util-4.7.0/work/libxfce4util-4.7.0/docs'
Making all in po
make[2]: Entering directory `/var/tmp/portage/xfce-base/libxfce4util-4.7.0/work/libxfce4util-4.7.0/po'
make[2]: *** Нет правила для сборки цели `ru.gmo', требуемой для `all-yes'.  Останов.
make[2]: Leaving directory `/var/tmp/portage/xfce-base/libxfce4util-4.7.0/work/libxfce4util-4.7.0/po'
make[1]: *** [all-recursive] Ошибка 1
make[1]: Leaving directory `/var/tmp/portage/xfce-base/libxfce4util-4.7.0/work/libxfce4util-4.7.0'
make: *** [all] Ошибка 2
 * ERROR: xfce-base/libxfce4util-4.7.0 failed:
 *   emake failed
 * 
 * Call stack:
 *     ebuild.sh, line   48:  Called src_compile
 *   environment, line 2746:  Called xfce4_src_compile
 *   environment, line 3354:  Called die
 * The specific snippet of code:
 *       emake ${JOBS} || die "emake failed"
 * 
 * If you need support, post the output of 'emerge --info =xfce-base/libxfce4util-4.7.0',
 * the complete build log and the output of 'emerge -pqv =xfce-base/libxfce4util-4.7.0'.
 * This ebuild used the following eclasses from overlays:
 *   /usr/local/portage/layman/xfce-dev/eclass/xfce4.eclass
 * This ebuild is from an overlay named 'xfce-dev': '/usr/local/portage/layman/xfce-dev/'
 * The complete build log is located at '/var/tmp/portage/xfce-base/libxfce4util-4.7.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/xfce-base/libxfce4util-4.7.0/temp/environment'.
 * S: '/var/tmp/portage/xfce-base/libxfce4util-4.7.0/work/libxfce4util-4.7.0'

>>> Failed to emerge xfce-base/libxfce4util-4.7.0, Log file:

>>>  '/var/tmp/portage/xfce-base/libxfce4util-4.7.0/temp/build.log'

Reproducible: Always

Steps to Reproduce:
1. emerge xfce4-meta




skobkin-book ~ # emerge --info
Portage 2.2_rc61 (default/linux/x86/10.0, gcc-4.4.2, glibc-2.11-r1, 2.6.32-gentoo-r1 i686)
=================================================================
System uname: Linux-2.6.32-gentoo-r1-i686-AMD_Athlon-tm-_X2_Dual-Core_QL-65-with-gentoo-2.0.1
Timestamp of tree: Tue, 29 Dec 2009 13:15:03 +0000
app-shells/bash:     4.0_p35
dev-java/java-config: 2.1.10
dev-lang/python:     2.6.4, 3.1.1-r1
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.0
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.65
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=k8 -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=k8 -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages metadata-transfer news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror2.corbina.ru/gentoo-distfiles/ ftp://mirror2.corbina.ru/gentoo-distfiles/ ftp://gentoo-mirror.spb.ru/ "
LANG="ru_RU.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en ru"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/x11 /usr/local/portage/layman/sunrise /usr/local/portage/layman/xfce-dev"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X acl alsa aspell bzip2 cdr cli cracklib crypt cups cxx dbus dri dvd fortran gdbm gpm grub grub2 hal iconv java jpeg jpeg2k jre kde lm_sensors mmx modules mp3 mudflap ncurses nls nptl nptlonly opengl openmp pam pcre perl php png pppd python qt qt3 qt4 readline reflection samba session spell spl sse sse2 ssl synaptics sysfs tcpd unicode x86 xcomposite xine xorg xv zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en ru" RUBY_TARGETS="ruby18" SANE_BACKENDS="nothing" USERLAND="GNU" VIDEO_CARDS="ati radeon vesa" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Samuli Suominen gentoo-dev 2009-12-29 20:09:34 UTC
Sync. 4.7.1 is in Portage.

*** This bug has been marked as a duplicate of bug 297790 ***