Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 29835 - configure: error: Qt (>= Qt 3.0.3) (library qt-mt) not found.
Summary: configure: error: Qt (>= Qt 3.0.3) (library qt-mt) not found.
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo KDE team
Depends on:
Reported: 2003-09-28 14:24 UTC by sawanv
Modified: 2004-06-14 09:08 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

config.log for a failed configure (config.log,34.70 KB, text/plain)
2003-09-30 08:00 UTC, sawanv

Note You need to log in before you can comment on or make changes to this bug.
Description sawanv 2003-09-28 14:24:46 UTC
This happens every time I try to install any QT/KDE application. It happens when I try to 
emerge or manually download the source and try "configure".  I guess this means the 
scrit is not able to locate the qt-mt shared library, which is present in the system! 
The way to fix this if to unmerge QT AND freetype (dont ask). And then emerge QT 
again and then its fixed.....till the next time you try to install some other app... 
Frankly I am quite sick of this...I have tried to seek some help in the forums but no luck. 
Its frustating to have to emerge qt and freetype every time you want to install some 
QT/KDE app. 

Reproducible: Always
Steps to Reproduce:
1.try to emerge a QT/KDE app the stuff download and unpack		 
3.the problem kicks in when portage runs configure on the package 
Actual Results:  
emerge some_kde_package 
checking for extra libs... no 
checking for libz... -lz 
checking for libpng... -lpng -lz -lm 
checking for libjpeg6b... no 
checking for libjpeg... -ljpeg 
checking for Qt... configure: error: Qt (>= Qt 3.0.3) (library qt-mt) not found. Please 
check your installation! 
For more details about this problem, look at the end of config.log. 
Make sure that you have compiled Qt with thread support! 
Same problem every time. 

Expected Results:  
Should have compiled and installed the package. 

# emerge info 
Portage 2.0.49-r3 (default-x86-1.4, gcc-3.2.3, glibc-2.3.2-r1, 2.4.20-gentoo-r6) 
System uname: 2.4.20-gentoo-r6 i686 AMD Athlon(tm) processor 
CFLAGS="-march=athlon -O3 -pipe -fomit-frame-pointer" 
CONFIG_PROTECT="/etc /var/qmail/control /usr/kde/2/share/config 
/usr/kde/3/share/config /usr/X11R6/lib/X11/xkb /usr/kde/3.1/share/config 
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d" 
CXXFLAGS="-march=athlon -O3 -pipe -fomit-frame-pointer" 
FEATURES="sandbox ccache autoaddcvs" 
USE="x86 oss apm crypt encode gif libg++ mikmod mmx ncurses nls pdflib png 
quicktime xml2 xv directfb gdbm berkdb slang readline arts sdl gpm tcpd pam ssl perl 
python esd imlib oggvorbis gtk qt kde opengl 3dfx alsa avi cdr -doc fbcon libgd jpeg 
odbc pic mad mpeg libwww smooth sse usb vim-with-x xml aml2 spell svga 3dnow 
truetype xmms zlib X -cups -foomaticdb -java -gnome -motif"
Comment 1 Caleb Tennis (RETIRED) gentoo-dev 2003-09-28 20:31:40 UTC
Then something is wrong on your system because this is not normal behavior.

Have you taken a look in the config.log of the packages you're emerging to
see exactly how the failing is occurring?  It may be for different reasons
than you think.
Comment 2 sawanv 2003-09-28 21:29:37 UTC
Yes I did take a look and I dont really understand whats going on. Will
post the config.log here. Can you please tell me what relevant sections to
look at/post?


Comment 3 Caleb Tennis (RETIRED) gentoo-dev 2003-09-29 05:56:20 UTC
Most likely somewhere near the end.  You should see some form of error that
will explain why it died.
Comment 4 sawanv 2003-09-30 08:00:05 UTC
Created attachment 18536 [details]
config.log for a failed configure

This is a sample config.log, obtained by trying to install a package. This
contains the offending qt-mt failure, towards the end (about line 858).
Comment 5 sawanv 2003-09-30 08:01:53 UTC
I have attached the config.log (sorry a bit late). Can anyone please help
me spot the error, or where my system is misconfigured?

Thanks a lot.

Comment 6 sawanv 2003-09-30 08:18:34 UTC
Hang on.

configure:20899: rm -rf SunWS_cache; g++ -o conftest -O2 -fno-exceptions
-fno-check-new -I/usr/qt/3/include -I.  -DQT_THREAD_SUPPORT  -D_REENTRANT
-L/usr/qt/3/lib -L/usr/X11R6/lib  -lqt-mt -lpng -lz -lm -ljpeg
-ldl  -lXext -lX11 -lSM -lICE  -lresolv -lpthread
1>&5/usr/lib/ undefined reference to
`FT_Get_BDF_Property'collect2: ld returned 1 exit statusconfigure:20902:
$? =
1configure: failed program was:#include "confdefs.h"#include <qglobal.h>

Does `FT_Get_BDF_Property' have anything to do with fonts? 

Because if so, I am using a modified binary for Freetype fonts from here:

Its very good stuff and makes my fonts extremely nice. I downloaded the provided
file and copied over the binary as instructed. This was back for the previous
version of Freetype. I do teh same for the new Freetype too whenever I recompile
and install it.

Incidentally, after I install the binary, KDE gives me a "cannot start KDE,
please check your installation" message every time I startx BUT it does startup
after I click on the OK button. 
Comment 7 Caleb Tennis (RETIRED) gentoo-dev 2003-09-30 08:21:08 UTC
yep, that's your problem - you may need to reemerge Qt to fix this, or some
combination of fontconfig/freetype.
Comment 8 sawanv 2003-09-30 23:24:02 UTC
Thanks for your help. 
Comment 9 Paul de Vrieze (RETIRED) gentoo-dev 2003-10-02 02:29:06 UTC
Ok, marking this as fixed
Comment 10 Mathew Hennessy 2004-06-14 09:05:48 UTC
I saw this behavior when I tried to build the baghira theme ebuild as part of emerge -UD world last Friday.  I reemerged qt and now I have to reemerge kdelibs.  

Is there any way of restructuring ebuilds so freetype etc. don't collide with QT/KDE?  Having to reemerge kde/qt any time freetype or any other component is upgraded is extremely lame... 
Comment 11 Caleb Tennis (RETIRED) gentoo-dev 2004-06-14 09:08:47 UTC
There probably is.  If you figure it out, let me know.