Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 29833 - devfsd hangs-up the system completely while trying to login as non-root user
Summary: devfsd hangs-up the system completely while trying to login as non-root user
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High critical (vote)
Assignee: Martin Schlemmer (RETIRED)
Depends on:
Reported: 2003-09-28 13:14 UTC by funny
Modified: 2004-04-02 21:49 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description funny 2003-09-28 13:14:15 UTC
When I try to login to the system as non-root user the computer deadly hangs-up
and reboot is the only solution. Login as root behaves quite normally. Also if I
login as root, term the devfsd (killall -TERM devfsd), start it again (devfsd
/dev) and then try to login as non-root user it works perfectly.  

Reproducible: Always
Steps to Reproduce:
1. boot the system
2. try to login as non-root user
3. freezes

Actual Results:  
pc is completely dead

Expected Results:  
login me to the system :-)

running the latest versions of:

metalog (also tried sysklogd)

Portage 2.0.49-r7 (default-x86-1.4, gcc-3.3.1-r3, glibc-2.3.2-r5, 2.4.22-ac4)
System uname: 2.4.22-ac4 i586 
CFLAGS="-O3 -mcpu=pentium-mmx -funroll-loops -pipe"
CONFIG_PROTECT="/etc /var/qmail/control /usr/share/config
/usr/kde/2/share/config /usr/kde/3/share/config"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-O2 -mcpu=i686 -pipe"
FEATURES="sandbox ccache autoaddcvs"
USE="x86 oss apm arts avi crypt cups encode foomaticdb gif jpeg kde gnome libg++
libwww mad mikmod mmx motif mpeg ncurses nls pdflib png qt quicktime sdl spell
svga truetype xml2 xmms xv zlib gdbm berkdb slang readline java X gpm tcpd pam
ssl perl python esd imlib oggvorbis gtk opengl mozilla"
Comment 1 Tim Yamin (RETIRED) gentoo-dev 2003-10-01 08:57:38 UTC
... Can you explicitly point this to a kernel problem, i.e. if you try a
different kernel [such as vanilla/gentoo-sources] do you get this?
Comment 2 funny 2003-10-04 04:14:27 UTC
choice of kernel doesn's matter. i've already tried vanilla, original gentoo,
ac and ck.
Comment 3 Marc Gracia 2003-10-04 06:35:30 UTC
I must say that here is happening the same on PPC. Unfortunately killing/restarting
devfsd don-t work for me. Also tried multiple kerneles without success.
Comment 4 Tim Yamin (RETIRED) gentoo-dev 2003-10-04 08:43:08 UTC
Not a kernel bug: this seems to happen on a variety of kernels and even PPC,
reassigning to bug-wranglers...
Comment 5 Marc Gracia 2003-10-06 09:06:56 UTC
I also have the bug 30478 about keyboard mapping
Just in case is related...
(Those are my only two problems with gentoo installation)
Comment 6 Martin Schlemmer (RETIRED) gentoo-dev 2003-11-01 14:30:57 UTC
Do you use utf8 support in console ?
Comment 7 funny 2003-11-02 00:57:48 UTC
sorry, but what does it mean exactly to use utf8 support in cpnsole?
Comment 8 Andrew Cooks (RETIRED) gentoo-dev 2004-02-01 07:42:47 UTC
This bug has been inactive for 30 days, or more.

Can this bug still be reproduced? Please reopen if it's still relevant.
Comment 9 Marc Gracia 2004-02-10 01:20:17 UTC
I have a workaround, comment all references to console pam module in all the pam.d config files.
I suppose it's a problem with pam console module verification.
I've done this and all works OK.
Comment 10 Lars Weiler (RETIRED) gentoo-dev 2004-04-02 21:49:56 UTC
Closing this bug, as there is a workaround.