Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 297874 - Emerge blocker display needs improvement
Summary: Emerge blocker display needs improvement
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Portage team
: 310299 (view as bug list)
Depends on:
Blocks: 300071
  Show dependency tree
Reported: 2009-12-22 07:03 UTC by dE
Modified: 2010-03-19 23:37 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---

Full output of emerge --pretend --update --deep --complete-graph --tree world (depend,18.65 KB, text/plain)
2009-12-22 07:07 UTC, dE
The new output of emerge (new_out,16.84 KB, text/plain)
2009-12-22 14:30 UTC, dE
Output of emerge --pretend --update --deep --complete-graph --tree --debug world (compressed text file) (debug_out.lpaq9m,53.31 KB, application/octet-stream)
2009-12-22 14:47 UTC, dE
Output of emerge --pretend --update --deep --complete-graph --tree --debug world (compressed text file) (debug_out.bz2,306.11 KB, text/plain)
2009-12-24 02:39 UTC, Zac Medico

Note You need to log in before you can comment on or make changes to this bug.
Description dE 2009-12-22 07:03:00 UTC
Portage states - 
"[ebuild     U ] app-shells/bash-4.0_p35 [4.0_p28] USE="-mem-scramble%"
[blocks B     ]  <sys-libs/e2fsprogs-libs-1.41.8 ("<sys-libs/e2fsprogs-libs-1.41.8" is blocking sys-apps/util-linux-2.16.1)"

However masking sys-libs/e2fsprogs-libs-1.41.8 does not help.

Also notice that - 

"de@localhost / $ emerge --search e2fsprogs-libs
[ Results for search key : e2fsprogs-libs ]
[ Applications found : 1 ]

*  sys-libs/e2fsprogs-libs
      Latest version available: 1.41.9
      Latest version installed: 1.41.3-r1
      Size of files: 484 kB
      Description:   e2fsprogs libraries (common error and subsystem)
      License:       GPL-2

de@localhost / $ "

But portage somhow wants to install sys-libs/e2fsprogs-libs-1.41.8.

Notice, according to eix, sys-libs/e2fsprogs-libs-1.41.8 is masked - 

"e@localhost / $ eix e2fsprogs-libs
[U] sys-libs/e2fsprogs-libs
     Available versions:  1.41.3-r1 ~1.41.6 ~1.41.7 [m]~1.41.8 1.41.9 {nls}
     Installed versions:  1.41.3-r1(16:42:10 11/30/09)(nls)
     Description:         e2fsprogs libraries (common error and subsystem)

de@localhost / $ 
But portage still want to install it in prefference to sys-libs/e2fsprogs-libs-1.41.9...notice I've manually maked sys-libs/e2fsprogs-libs-1.41.8

So there are actually 2 bugs here, one, portage preffering sys-libs/e2fsprogs-libs-1.41.8 instead of sys-libs/e2fsprogs-libs-1.41.9 and second that portage wants to install sys-libs/e2fsprogs-libs-1.41.8 depite the fact that It's listed in pacakge.mask.

It should have atleast stated that sys-libs/e2fsprogs-libs-1.41.8 is a depency required by some pakage (if there are any) but it has been masked.

Reproducible: Always

Steps to Reproduce:
emerge --pretend --update --deep --complete-graph --tree world

(Above, I've posted relevant parts only)

Expected Results:  
It should have tried to install sys-libs/e2fsprogs-libs-1.41.9 instead of sys-libs/e2fsprogs-libs-1.41.8

Portage 2.2_rc50 (default/linux/amd64/10.0/desktop, gcc-4.3.4, glibc-2.9_p20081201-r2, 2.6.31-gentoo-r6 x86_64)
System uname: Linux-2.6.31-gentoo-r6-x86_64-AMD_Athlon-tm-_64_X2_Dual-Core_Processor_TK-55-with-gentoo-1.12.13
Timestamp of tree: Sun, 20 Dec 2009 01:45:02 +0000
app-shells/bash:     4.0_p28
dev-java/java-config: 2.1.9-r1
dev-lang/python:     2.6.2-r1
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.7.9-r1, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
CFLAGS="-march=athlon64 -O2 -pipe"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=athlon64 -O2 -pipe"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="3dnow X a52 aac acc acl acpi alib alsa amd64 bash-completion bcmath branding bzip2 cairo cdda cdparanoia cdr cli consolekit cracklib crypt css cxx dbus dga djvu dri dts dv dvd dvdr encode exif fam ffmpeg fftw firefox flac fortran ftp gdbm gif gpm gsl gsm gstreamer gtk hal iconv ipv6 jpeg jpeg2k lame latex ldap libnotify libsamplerate lzo mad matroska matrox memlimit mikmod mmx mng modules mozilla mp3 mp4 mpeg mplayer mudflap multilib musepack ncurses nls nptl nptlonly nsplugin oci8-instant-client offensive ogg openal openexr opengl openmp oss pam pcre pdf perl png ppds pppd python qt3support quicktime raw readline reflection samba sdl session sharedmem shorten slang smp speex spell spl sse sse2 ssl startup-notification svg symlink sysfs taglib tcpd theora thunar tiff truetype unicode vcd vorbis wavpack wmf x264 xml xorg xpm xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeonhd radeon" 
Comment 1 dE 2009-12-22 07:07:33 UTC
Created attachment 213730 [details]
Full output of emerge --pretend --update --deep --complete-graph --tree world
Comment 2 Zac Medico gentoo-dev 2009-12-22 10:26:29 UTC
(In reply to comment #0)
> Portage states - 
> "[ebuild     U ] app-shells/bash-4.0_p35 [4.0_p28] USE="-mem-scramble%"
> [blocks B     ]  <sys-libs/e2fsprogs-libs-1.41.8
> ("<sys-libs/e2fsprogs-libs-1.41.8" is blocking sys-apps/util-linux-2.16.1)"
> However masking sys-libs/e2fsprogs-libs-1.41.8 does not help.

You've misunderstood the message. Masking sys-libs/e2fsprogs-libs-1.41.8 is not the appropriate course of action. You currently have sys-fs/e2fsprogs-1.41.3-r1 installed, which is matched by <sys-libs/e2fsprogs-libs-1.41.8. You need to upgrade to the latest e2fsprogs-libs in order for this blocker to solve, and it looks like that is happening already here:

[ebuild     U ]   sys-libs/e2fsprogs-libs-1.41.9 [1.41.3-r1]

So, it seems like you can really ignore the e2fsprogs-libs blocker. It's probably just a display bug in portage. I suspect that you only need to solve the x11-libs/libXi blocker and the whole upgrade will succeed.

As for solving the x11-libs/libXi blocker, I don't understand why the older x11-libs/libXi-1.2.1 package got pulled into the dependency graph. Can you please post emerge output for the same command with the --debug option enabled?
Comment 3 Zac Medico gentoo-dev 2009-12-22 13:05:14 UTC
Also, please try with latest portage since that might affect the results (you posted with 2.2_rc50 but latest is 2.2_rc60).
Comment 4 dE 2009-12-22 14:29:18 UTC
"As for solving the x11-libs/libXi blocker, I don't understand why the older
x11-libs/libXi-1.2.1 package got pulled into the dependency graph."

That's cause I'm masked =x11-libs/libXi-1.2.99.

The display bug remains identical with portage-2.2_rc60

I've unmasked x11-libs/libXi and this is the new output (with portage-2.2_rc60) has been attached. 

As of this block -

[blocks B     ] <x11-libs/libXi-1.2.99 ("<x11-libs/libXi-1.2.99" is blocking x11-proto/inputproto-2.0)

I do not understand why does portage wants to install x11-libs/libXi-1.2.99 cause it's already being upgraded to - 

"[ebuild     U ]   x11-libs/libXi-1.3 [1.2.1]

As shown in the tree.

Furthermore there are no packages called libXi-1.2.99 - 

de@localhost / $ eix libxi 
[U] x11-libs/libXi
     Available versions:  1.1.2 1.1.3 ~1.2.0 1.2.1 (~)1.3 {debug}
     Installed versions:  1.2.1(09:04:00 11/30/09)(-debug)
     Description:         X.Org Xi library
Comment 5 dE 2009-12-22 14:30:21 UTC
Created attachment 213757 [details]
The new output of emerge
Comment 6 dE 2009-12-22 14:34:29 UTC
And I think this was the thing you where referring to.

Output of emerge --pretend --update --deep --complete-graph --tree --debug world has been attached.
Comment 7 dE 2009-12-22 14:47:19 UTC
Created attachment 213758 [details]
Output of emerge --pretend --update --deep --complete-graph --tree --debug world (compressed text file)

The text file has been compressed using lpaq9m algorithm, download the binary/sources from -


Compile the single c source code and run

./<binary file name that got compiled> d <path of debug_out.lpaq9m> <path of uncompressed output file>
Comment 8 Zac Medico gentoo-dev 2009-12-24 01:34:34 UTC
(In reply to comment #7)
Well, using some oddball compression like that is just stupid. :P
Comment 9 Zac Medico gentoo-dev 2009-12-24 02:39:16 UTC
Created attachment 214011 [details]
Output of emerge --pretend --update --deep --complete-graph --tree --debug world (compressed text file)

This is the same output as attachment 213758 [details] but with bz2 compression, so others can see this without having to use lpaq9m. Seriously, it's just wrong to make people use lpaq9m. :)

(In reply to comment #4)
> "As for solving the x11-libs/libXi blocker, I don't understand why the older
> x11-libs/libXi-1.2.1 package got pulled into the dependency graph."
> That's cause I'm masked =x11-libs/libXi-1.2.99.

No, you still have a fundamental misunderstanding of blocker atoms. Masking =x11-libs/libXi-1.2.99 doesn't really change anything because that package doesn't really exist and the !<x11-libs/libXi-1.2.99 blocker matches *all* versions lower than that.

Anyway, the debug output shows that libXi-1.2.1 got pulled in by xfce-base/xfce4-settings-4.6.3 since it has <x11-libs/libXi-1.3 in RDEPEND. Apparently you need to unmask xfce-base/xfce4-settings-4.6.3-r1 in order to solve that. If you do that then hopefully all blockers will resolve.
Comment 10 dE 2009-12-24 16:08:35 UTC
Well, it's is disputably the best compression in the world; I thought why not introduce it to the developers...very interesting stuff. It appears as if it took lots of time and memory for your system to decompress it...
Good thing I didn't use paq, it has many times the requirement of memory and time.:)

Thanks all problems have resolved now (all of a sudden, without masking or unmasking).
Comment 11 Zac Medico gentoo-dev 2009-12-24 21:30:17 UTC
Yeah that lpaq9m file was many times smaller than the bz2 file. It said decompression consumed 198 meg iirc (many times the file size).

NOTE: For smaller emerge --debug logs, use --backtrack=0.


This blocker should appear as solved:

	[blocks B     ]  <sys-libs/e2fsprogs-libs-1.41.8 ("<sys-libs/e2fsprogs-libs-1.41.8" is blocking sys-apps/util-linux-2.16.1)

This blocker message should show the <x11-libs/libXi-1.3 required by
xfce-base/xfce4-settings-4.6.3 RDEPEND:

	('installed', '/', 'x11-libs/libXi-1.2.1', 'nomerge') pulled in by
		x11-libs/libXi required by ('installed', '/', 'x11-libs/gtk+-2.16.6', 'nomerge')
		>=x11-libs/libXi-1.2.1 required by ('ebuild', '/', 'x11-base/xorg-server-1.6.5-r1', 'merge')
		x11-libs/libXi required by ('installed', '/', 'dev-python/pyopengl-3.0.0', 'nomerge')
		(and 10 more)
Comment 12 Zac Medico gentoo-dev 2010-03-19 23:37:56 UTC
*** Bug 310299 has been marked as a duplicate of this bug. ***