Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 297755 - >=sys-kernel/linux-headers-2.6.32 version bump needed
Summary: >=sys-kernel/linux-headers-2.6.32 version bump needed
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High enhancement with 4 votes (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
: 302829 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-12-21 10:26 UTC by Brian Harring
Modified: 2010-02-14 16:00 UTC (History)
13 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
KMS patch for linux-headers-2.6.30-r1 (2.6.30-ksm.patch,513 bytes, patch)
2010-01-26 13:55 UTC, piavlo
Details | Diff
KMS patch for glibc-2.11-r1 (glibc-2.11-ksm.patch,1.21 KB, patch)
2010-01-26 13:55 UTC, piavlo
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Harring gentoo-dev 2009-12-21 10:26:36 UTC
Specifically this is needed for KSM support- MADV_MERGEABLE awareness was released in qemu-kvm-0.12, kernel support is 2.6.32; just need to get the headers in order for this support.

Via the headers extraction script, I've been playing around w/ a build locally- unfortunately I don't know near enough about the patching that's done in the existing builds (specifically what should be preserved under 2.6.32, what shouldn't, etc) to comment if my local attempt is successful.

Stuff seems to work at least, although I've not done a full rebuild...

Reproducible: Always

Steps to Reproduce:
Comment 1 Brian Knoll 2009-12-24 04:35:37 UTC
As a suggestion, I think the severity for this ticket should probably be changed to "Normal" rather than "Enhancement".  The reason I say this is that this is a fairly significant feature that is simply unavailable without the newer headers, and there is no real workaround unless you take abnormal measures (outside of Gentoo ebuilds).  My reading of the severity level guidelines tells me that "Normal" is probably appropriate.
Comment 2 Brian Knoll 2009-12-24 13:21:11 UTC
I also want to add that, due to the nature of the situation, a lot of people could easily have a hard time knowing that this is even what they need.  In other words, I expect a lot of people could soon be wondering why their KSM isn't working on Gentoo, but not understanding that it's the missing newer version of the linux-headers that is causing the problem.  That, to me, adds to the urgency of this ticket as well, in addition to the reasons outlined above.
Comment 3 James Shaw (Simba7) 2010-01-08 05:32:35 UTC
Oh, believe me.. I've been asking and everyone is giving me the runaround.

http://forums.gentoo.org/viewtopic-t-794061.html

I'd really love to get my router working again.. It's been down for 4 months now.
Comment 4 RW 2010-01-18 13:34:07 UTC
Something new about this issue? We also want to use KSM. I just realized that KSM isn't working without newer linux-headers. I think it would be great if >=linux-headers-2.6.32 would be in ~arch. Since >=qemu-kvm-0.12 needs >=linux-headers-2.6.30 I've already unmasked it. Priority should be raised since I think I won't be the only one searching for some hours for the "bug" which causes KSM not to work under Gentoo.

Thanks!
Comment 5 Brian Harring gentoo-dev 2010-01-18 15:00:29 UTC
Keep in mind I'm certainly not advocating this for everyone, but in the interim, if you absolutely know the headers pkg is going to only be used on a 2.6.32 system... the modification to the headers for this is 4 lines across 2 files (just adding the madvice syscall flag defines).

This is what I've done while waiting since I needed KSM now.  I'd prefer to see a proper headers bump, but that does carry a fair bit of work/validation (hence why I reverted to the current 2.6.30 headers w/ a couple defines thrown in).

Just a thought.
Comment 6 James Shaw (Simba7) 2010-01-20 06:21:33 UTC
Can I make my own linux-headers-2.6.32 file and throw it into portage instead of waiting forever for this to get resolved?

I'd give me lots less of a headache and I'd be able to get my systems up to par.
Comment 7 Ken Rice 2010-01-23 17:48:15 UTC
2.6.32 has been selected for "long-term" support, likely for a period of two years plus. 

2.6.27 is going to be phased out over the next few months, AND, 2.6.27 will not have all backports because it is about 2 years old. QUOTE: "But, I do have to warn users of this tree, the older it gets, the less viable it becomes.  Not all bugfixes are being backported..." /QUOTE


You can read Greg KH's notice on LWN here: 
http://lwn.net/Articles/370236/ titled "Stable kernel tree status, January 18, 2010"

Comment 8 piavlo 2010-01-26 13:55:08 UTC
Created attachment 217465 [details, diff]
KMS patch for linux-headers-2.6.30-r1
Comment 9 piavlo 2010-01-26 13:55:49 UTC
Created attachment 217467 [details, diff]
KMS patch for glibc-2.11-r1
Comment 10 piavlo 2010-01-26 13:58:33 UTC
Hi,

I've added KSM patches for latest linux-headers-2.6.30-r1 and glibc-2.11-r1
with these patches applied the KSM is working.

If someone wants the modified ebuild diffs, I can attach them too.
Comment 11 Elias Probst 2010-02-02 10:33:57 UTC
*** Bug 302829 has been marked as a duplicate of this bug. ***
Comment 12 Maksim 'max_posedon' Melnikau 2010-02-10 02:31:19 UTC
Hi! I would like to have linux-headers-2.6.32 for linux/rfkill.h 
Comment 13 SpanKY gentoo-dev 2010-02-13 08:51:58 UTC
linux-headers-2.6.32 now in the tree.  Brian owes OSCON now.
Comment 14 James Shaw (Simba7) 2010-02-13 17:11:48 UTC
OMG!!! I've been waiting a half a year for this!

TTTTT  H   H   AAA   N   N  K   K       Y   Y   OOO   U   U  !!!
  T    H   H  A   A  NN  N  K  K         Y Y   O   O  U   U  !!!
  T    HHHHH  AAAAA  N N N  KKK           Y    O   O  U   U  !!!
  T    H   H  A   A  N  NN  K  K          Y    O   O  U   U
  T    H   H  A   A  N   N  K   K         Y     OOO    UUU   !!!
Comment 15 SpanKY gentoo-dev 2010-02-14 00:41:47 UTC
http://bash.org/?4281
Comment 16 Xake 2010-02-14 02:45:29 UTC
(In reply to comment #15)
> http://bash.org/?4281
> 

What is this? Do you not appreciate the ASCII art?;)
(yeah, I know there are better ways to say thank you.:-P)
Comment 17 SpanKY gentoo-dev 2010-02-14 16:00:20 UTC
just messing man.  browse bash.org for a while and get a laugh :p.