Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 297740 - Shift and ctrl don't work in tigervnc server
Summary: Shift and ctrl don't work in tigervnc server
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Raúl Porcel (RETIRED)
Depends on:
Reported: 2009-12-21 06:41 UTC by Simon Matthews
Modified: 2010-04-26 18:55 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

emerge --info (emerge_info.txt,3.79 KB, text/plain)
2009-12-21 06:43 UTC, Simon Matthews

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Matthews 2009-12-21 06:41:51 UTC
Since upgrading Xfree, Gnome and tigervnc (from vnc), the shift and ctrl modifiers don't work in a vnc session. It doesn't matter what client I use to connect to the session, I can only type lower case letters and can't get any ctrl-key keystrokes. 

Actually, the shift key behavior is a little more odd: I can type "<", which requires the shift-key, but the shift key does not modify any other keys. 

Reproducible: Always

Steps to Reproduce:
1.install tigervnc (with server option)
2.start vnc session ("vncserver ...."
3.Connect to session
4. In a terminal or any other window that accepts text, attempt to type "A"

Actual Results:  
Lowercase "a" is displayed. 

Expected Results:  
Uppercase "A" should be displayed.
Comment 1 Simon Matthews 2009-12-21 06:43:20 UTC
Created attachment 213659 [details]
emerge --info 

Results of emerge --info
Comment 2 Erich Boleyn 2010-03-16 07:00:32 UTC
Your problem may be a missing dependency on an x11-proto package that either
needs rebuilding or updating.

I had problems with tigervnc's Ctrl and Shift keys til I updated the x11-proto
and some other affected libs and it went away.

To be specific, I kept updating til I had solved the dependencies to use tigervnc-1.0.1_pre(something), and the problems went away.  Then right afterward, on a different system with newer Xorg-server setup, tigervnc-1.0.0-r2 worked correctly.

I think this is also related to bug 297722.
Comment 3 Simon Matthews 2010-03-16 18:35:32 UTC
I don't have x11-proto on my system. Should something pull it in? I have the "server" use flag defined in /etc/portage/package.use:
$  grep tigervnc /etc/portage/*
/etc/portage/package.use:net-misc/tigervnc server
Comment 4 Simon Matthews 2010-03-16 19:18:25 UTC
Update -- I don't have x11-proto, but I do have x11-proto/xproto and a bunch of other packages that are x11-proto/*, so I'll try "emerge -e xproto"
Comment 5 Simon Matthews 2010-03-31 00:24:03 UTC
I have done a complete "emerge -e system" followed by "emerge -e world"
Then I cleaned up a few packages listed by "emerge -p --depclean" and ran "emerge -e tigervnc", yet this problem persists. 
Comment 6 Simon Matthews 2010-04-26 18:54:54 UTC
After the recent update, this bug seems to be fixed