Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 297019 - sys-kernel/gentoo-sources-2.6.32 modeprobe radeon modeset=1 => blank screen (dual 4850 in X-FireX)
Summary: sys-kernel/gentoo-sources-2.6.32 modeprobe radeon modeset=1 => blank screen (...
Status: VERIFIED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Gentoo X packagers
URL: http://bugs.freedesktop.org/show_bug....
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-15 11:58 UTC by 404 Error
Modified: 2010-06-20 22:25 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
/var/log/messages when inserting the radeon kernel module with modeset=1 (messages.radeon-kms.txt,18.81 KB, text/plain)
2009-12-15 11:59 UTC, 404 Error
Details

Note You need to log in before you can comment on or make changes to this bug.
Description 404 Error 2009-12-15 11:58:50 UTC
On a machine with two 4850 connected in CrossFireX, loading the kernel module radeon with modeset=1 makes the screen go blank. The machine is still alive as I can access it via ssh.

Didn't tried with a single card in the machine.

Reproducible: Always

Actual Results:  
The screen connected on the machine becomes blank (a signal seems to be detected as the led on the front panel of the screen does not blink) and the following appears in /var/log/messages :
Comment 1 404 Error 2009-12-15 11:59:56 UTC
Created attachment 213075 [details]
/var/log/messages when inserting the radeon kernel module with modeset=1
Comment 3 Mike Pagano gentoo-dev 2009-12-30 13:24:33 UTC
Thanks for reporting upstream. We'll follow that bug.
Comment 4 404 Error 2009-12-30 18:59:49 UTC
If I can do something to make things advance, please, let me know.
Comment 5 Rémi Cardona gentoo-dev 2009-12-30 19:29:36 UTC
You could try the latest drm-next kernel from "airlied" on kernel.org [1], he's the DRM maintainer. Maybe the bug is already fixed there. And if not, upstream will ask you to test that kernel anyway...

Thanks

[1] http://git.kernel.org/?p=linux/kernel/git/airlied/drm-2.6.git with branches "drm-next", "drm-linus", "drm-radeon-testing", etc.
Comment 6 404 Error 2010-01-15 14:35:47 UTC
Tested again with Linux 2.6.33-rc4 : All quiet on the western front but a slight difference (my monitor's LED now blinks when the screen becomes blank).

Joined a new log excerpt in the upstream report.
Comment 7 404 Error 2010-02-09 18:29:28 UTC
Tested with  2.6.33-rc7, I still get a blank screen :-(
Comment 8 Rémi Cardona gentoo-dev 2010-02-09 18:53:01 UTC
Ping the upstream bug, that's where the fix is going to come from. Don't hesitate to reopen this bug once upstream fixes this issue.

Closing upstream.

Thanks
Comment 9 404 Error 2010-06-20 22:25:19 UTC
A follow-up on this one : the problem is solved !

Simply upgrade the kernel to Linux 2.6.35 (-rc3 at this date), install the latest revision of  x11-drivers/radeon-ucode and you should see a nice framebuffer with a lot of text inside :-) Also, note that if you don't use initramfs images, you *must* set 'radeon' as being a module (it requires to load several firmware files).


Note : Blank screen on every releases prior to 2.6.35