Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 297008 - dev-libs/libxslt-1.1.26: no version information available
Summary: dev-libs/libxslt-1.1.26: no version information available
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-15 09:24 UTC by Mike Hammill
Modified: 2010-01-10 22:20 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
requested build log (dev-libs:libxslt-1.1.26:20100108-091354.log,89.56 KB, text/plain)
2010-01-08 09:39 UTC, Mike Hammill
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Hammill 2009-12-15 09:24:34 UTC
Newly installed dev-libs/libxslt-1.1.26 triggers revdep-rebuild to want to rebuild it, apparently because version information is not available.

From revdep-rebuild -ip
* Generated new 2_ldpath.rr
* Checking dynamic linking consistency
[ 100% ]                 
*   broken /usr/bin/xsltproc (no version information available)
*   broken /usr/lib64/libexslt.so.0.8.15 (no version information available)
*   broken /usr/lib64/python2.6/site-packages/libxsltmod.so (no version information available)
* Generated new 3_broken.rr
* Assigning files to packages
*   /usr/bin/xsltproc -> dev-libs/libxslt
*   /usr/lib64/libexslt.so.0.8.15 -> dev-libs/libxslt
*   /usr/lib64/python2.6/site-packages/libxsltmod.so -> dev-libs/libxslt

(Side node #296430)
Comment 1 Gilles Dartiguelongue gentoo-dev 2009-12-15 10:39:27 UTC
emerge --info please. libxslt is not expected to change soname and co so my guess is that somehow your package manager installed broken files. Could you please re-emerge libxslt and see if it solves the problem ?
Comment 2 Mike Hammill 2009-12-15 15:33:40 UTC
# emerge --info dev-libs/libxslt
Portage 2.1.6.13 (default/linux/amd64/10.0/no-multilib, gcc-4.3.4, glibc-2.9_p20081201-r2, 2.6.32-gentoo x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.32-gentoo-x86_64-Intel-R-_Pentium-R-_D_CPU_2.80GHz-with-gentoo-2.0.1
Timestamp of tree: Tue, 15 Dec 2009 12:15:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p35
dev-lang/python:     2.6.4, 3.1.1-r1
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.5.3
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.63-r1
sys-devel/automake:  1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="buildpkg ccache collision-protect distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp.linux.ee/pub/gentoo/distfiles/ http://ftp.rhnet.is/pub/gentoo/ http://mirror.gentoo.no/ http://gentoo.osuosl.org/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j3"
PKGDIR="/var/pkg"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="acl afs amd64 apache2 bash-completion berkdb bzip2 cgi cli cracklib crypt cups curl cxx dri emacs fam fortran gdbm geoip gnutls gpm iconv ipv6 kerberos ldap mailwrapper mmx modules mudflap nagios-ssh ncurses network-cron nls nptl nptlonly openmp openssl pam pcre perl pppd python readline reflection sasl session spl sse sse2 ssl sysfs tcpd threads unicode vhosts webdav xattr xml xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="access actions alias asis   auth auth_anon auth_dbm auth_digest authz_default authz_host   autoindex cache case_filter_in case_filter cern_meta cgi cgid charset_lite   dav dav_fs dav_lock deflate dir disk_cache echo env expires ext_filter   file_cache filter headers imap include info log_config logio   mem_cache mime mime_magic negotiation   proxy proxy_connect proxy_ftp proxy_http rewrite   setenvif so speling status   unique_id unique_id userdir usertrack vhost_alias   authn_file    authz_groupfile   authz_user" APACHE2_MPMS=" worker" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nv r128 radeon savage sis tdfx trident vesa via vmware voodoo"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

dev-libs/libxslt-1.1.26 was built with the following:
USE="crypt python -debug"
Comment 3 Mike Hammill 2009-12-15 15:43:24 UTC
(In reply to comment #1)
> emerge --info please. libxslt is not expected to change soname and co so my
> guess is that somehow your package manager installed broken files. Could you
> please re-emerge libxslt and see if it solves the problem ?
> 
I re-emerged libxslt successfully then did "revdep-rebuild -ip again.  Same result as before, I assume because of the "(no version information available)" message.  This is a fairly simple and stable system, running stable Gentoo, no X.  Note: I did *not* rsync before re-emerging, so nothing new was downloaded.

# eix -I libxslt
[I] dev-libs/libxslt
     Available versions:  1.1.24-r1 1.1.26 {crypt debug examples python}
     Installed versions:  1.1.26(04:36:43 PM 12/15/2009)(crypt python -debug)
     Homepage:            http://www.xmlsoft.org/
     Description:         XSLT libraries and tools

# eix -I gentoolkit
[I] app-portage/gentoolkit
     Available versions:  0.2.4.5!t ~0.3.0_rc5 ~0.3.0_rc6 ~0.3.0_rc7 **9999
     Installed versions:  0.2.4.5!t(09:43:58 AM 07/02/2009)
     Homepage:            http://www.gentoo.org/proj/en/portage/tools/index.xml
     Description:         Collection of administration scripts for Gentoo

Comment 4 Gilles Dartiguelongue gentoo-dev 2009-12-15 16:31:10 UTC
Seeing bug #296979 which looks just as weird, could you downgrade to libtool-2.2.6a and try again ?
Comment 5 Mike Hammill 2009-12-16 20:51:21 UTC
(In reply to comment #4)
> Seeing bug #296979 which looks just as weird, could you downgrade to
> libtool-2.2.6a and try again ?
> 
I just tried this, but unfortunately, it's still the same result.  Specifically, I:
added to package.mask =sys-devel/libtool-2.2.6b
emerge -vauDN world do downgrade
hash -r
env-update
source /etc/profile
emerge -v1 libxslt  (gave no errors)
revdep-rebuild -ip  (gave exactly same errors as reported 1st time)

Comment 6 Mike Hammill 2009-12-16 20:53:05 UTC
Forgot to say that masking libtool-2.2.6b put me at 2.2.6a (as you requested). 
Comment 7 Samuli Suominen gentoo-dev 2009-12-16 20:56:46 UTC
There's really no reason to be running revdep-rebuild between the 2 libxslt versions, looks like a gentoolkit bug to me until proven otherwise. And also note that you seem to be the only person with this problem. 

my 2cents
Comment 8 Mike Hammill 2009-12-16 21:02:30 UTC
(In reply to comment #7)
> There's really no reason to be running revdep-rebuild between the 2 libxslt
> versions, looks like a gentoolkit bug to me until proven otherwise. And also
> note that you seem to be the only person with this problem. 
> 
> my 2cents

The reason to run revdep-rebuild is to show that there is a problem (either in revdep-rebuild (gentoolkit) or with libxslt.  As you recall from reading the bug report, the error occurs when running revdep-rebuild.  If I don't run it, how am I testing anything?

I am the only one with the problem.  Are you sure about that?  Have you checked?  Or am I the only one who has taken the time to report it?
Comment 9 Mike Hammill 2009-12-17 10:48:56 UTC
(In reply to comment #7)
> ...looks like a gentoolkit bug to me until proven otherwise

Same exact problem with gentoolkit-0.3.0_rc7.

> And also note that you seem to be the only person with this problem. 

I really hope the gentoo team does not use the "how many people report this" as a criteria for fixing problems.

This all began when libxslt-1.1.26 was made stable for my profile
  [4]   default/linux/amd64/10.0/no-multilib *
I simply masked 1.1.26 and went back to 1.1.24-r1 and the problem is solved.  No change was necessary to any other software and they are back to the stable version they were at when libxslt-1.1.26 did NOT work, namely:
libtool-2.2.6b
gentoolkit-0.2.4.5

So masking 1.1.26 solves the problem for me.  If you want to count this problem solved because "I am the only one with the problem" feel free to do so.  
Comment 10 Rafał Mużyło 2010-01-04 00:31:11 UTC
Any chance you could attach full build log from
the build that creates broken version ?
Comment 11 Mike Hammill 2010-01-08 09:39:35 UTC
Created attachment 215626 [details]
requested build log

Here is the build log using a stable environment:
sys-devel/libtool-2.2.6b 
app-portage/gentoolkit-0.2.4.5

As far as "version" in the build log, could it be how this line works or doesn't work?

sed -e 's?\@XSLT_LIBDIR\@?-L/usr/lib64?g' \
	    -e 's?\@XSLT_INCLUDEDIR\@?-I/usr/include?g' \
	    -e 's?\@VERSION\@?1.1.26?g' \
	    -e 's?\@XSLT_LIBS\@?-lxslt  -L/usr/local/lib -lxml2 -lz -lm -lm?g' \
	       < ./xsltConf.sh.in > xsltConf.tmp \
	&& mv xsltConf.tmp xsltConf.sh
Comment 12 Rafał Mużyło 2010-01-09 13:51:05 UTC
Lets strart with a trivial question:
what's this: "-I/usr/local/include/libxml2" ?
Clean up your /usr/local, try again.
Comment 13 Mike Hammill 2010-01-10 21:55:55 UTC
(In reply to comment #12)
> Lets strart with a trivial question:
> what's this: "-I/usr/local/include/libxml2" ?
> Clean up your /usr/local, try again.

What I have in /usr/local/include is:
# ls -l /usr/local/include
total 92
drwxr-xr-x 2 root root  4096 2008-04-27 14:04 libexslt
drwxr-xr-x 3 root root  4096 2007-11-17 10:52 libxml2
drwxr-xr-x 2 root root  4096 2008-04-27 14:04 libxslt
-rw-r--r-- 1 root root  9544 2007-11-17 10:45 zconf.h
-rw-r--r-- 1 root root 66188 2007-11-17 10:45 zlib.h

# for i in `ls /usr/local/include`; do equery b $i; done
[ Searching for file(s) libexslt in *... ]
dev-libs/libxslt-1.1.26 (/usr/include/libexslt)
[ Searching for file(s) libxml2 in *... ]
dev-libs/libxml2-2.7.3-r2 (/usr/include/libxml2)
[ Searching for file(s) libxslt in *... ]
dev-libs/libxslt-1.1.26 (/usr/include/libxslt)
[ Searching for file(s) zconf.h in *... ]
sys-boot/syslinux-3.71 (/usr/share/syslinux/com32/include/zconf.h)
sys-kernel/gentoo-sources-2.6.32-r1 (/usr/src/linux-2.6.32-gentoo-r1/include/linux/zconf.h)
sys-libs/zlib-1.2.3-r1 (/usr/include/zconf.h)
[ Searching for file(s) zlib.h in *... ]
sys-boot/syslinux-3.71 (/usr/share/syslinux/com32/include/zlib.h)
sys-kernel/gentoo-sources-2.6.32-r1 (/usr/src/linux-2.6.32-gentoo-r1/include/linux/zlib.h)
sys-libs/zlib-1.2.3-r1 (/usr/include/zlib.h)

In other words, nothing out of place, as far as I can tell.  Are you suggesting I unmerge all these packages and re-install them?  I don't really see what to clear out.  Just let me know and I'll try it.
Comment 14 Mike Hammill 2010-01-10 22:03:18 UTC
(In reply to comment #12)
# for i in `ls /usr/local/include`; do echo /usr/local/include/$i; equery b /usr/local/include/$i; done
/usr/local/include/libexslt
[ Searching for file(s) /usr/local/include/libexslt in *... ]
/usr/local/include/libxml2
[ Searching for file(s) /usr/local/include/libxml2 in *... ]
/usr/local/include/libxslt
[ Searching for file(s) /usr/local/include/libxslt in *... ]
/usr/local/include/zconf.h
[ Searching for file(s) /usr/local/include/zconf.h in *... ]
/usr/local/include/zlib.h
[ Searching for file(s) /usr/local/include/zlib.h in *... ]

Opps, just caught my mistake.  So, I move out everything in /usr/local/include and try again.

Comment 15 Mike Hammill 2010-01-10 22:16:11 UTC
(In reply to comment #12)
I moved stuff not associated (any long) with any package from /usr/local/{include, bin, lib64} and the problem is solved.  I take it by your use of the term "trivial" you always thought it was user error anyway.  Well, you are right, and sorry for taking your valuable time.  It's news to me that ebuilds would care or could ever end up depending on (by way of configure, I guess) what was in /usr/local.  Further, I really didn't think I had put anything there, but it was probably from some the Plone universal installer.  In any case, thanks, because at least I learned something.  I will assume from now on that ebuilds could well look to /usr/local when building.

Comment 16 Gilles Dartiguelongue gentoo-dev 2010-01-10 22:20:07 UTC
A lot of build systems use PATH to discover some stuff they use during build process. PATH often has /usr/local entries before system locations that's why it might fail if what it finds is broken or out of date wrt your system. Thanks for reporting anyway.