Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 296942 - app-editors/nedit could ship Icon= for .desktop file
Summary: app-editors/nedit could ship Icon= for .desktop file
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL: http://sourceforge.net/tracker/?func=...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-14 21:43 UTC by John Stile
Modified: 2013-05-15 13:10 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Stile 2009-12-14 21:43:46 UTC
kde-base/kdebase-menu-icons-4.3.1:  should include icon for package nedit (and others).

Applicaiton icon for nedit (and other apps) where included in =kde-base/kdebase-data-3.5.10 (/usr/kde/3.5/share/icons/crystalsvg/16x16/apps/nedit.png)

Could the new kde icon package included these icons out of the box as well?

Reproducible: Always

Steps to Reproduce:
1. upgrade from kde-3.5.10 to kde-4*
Now a question mark appears for this app.
This may be true for other apps as well (audacity,aumix, pptpconfig, ...).
Actual Results:  
Nedit has the icon of a question mark

Expected Results:  
I expect to seethe icon for nedit rather than a question mark.
Comment 1 Samuli Suominen gentoo-dev 2009-12-14 22:58:25 UTC
No, 

app-editors/nedit should ship this icon, not some random theme pack.

Comment 2 John Stile 2009-12-14 23:36:00 UTC
This seems a little schisophrenic.  
Icons for some applications are included, and until kde4, Nedit was on the list.
Was there a bug requesting the removal of nedit's icon from the kde icon package?

Comment 3 John Stile 2009-12-14 23:38:19 UTC
(In reply to comment #2)
> This seems a little schisophrenic.  
> Icons for some applications are included, and until kde4, Nedit was on the
> list.
> Was there a bug requesting the removal of nedit's icon from the kde icon
> package?
> 

I'm sorry.  it looks like all app icons where removed....
Does this leave my problem in a black hole?
Comment 4 John Stile 2010-01-20 22:13:39 UTC
I filed a bug (and icon) in the nedit project bug tracking system:

http://sourceforge.net/tracker/?func=detail&aid=2935361&group_id=11005&atid=111005
Comment 5 Michael Weber (RETIRED) gentoo-dev 2013-05-15 13:10:48 UTC
+*nedit-5.5_p20110116-r1 (15 May 2013)
+
+  15 May 2013; Michael Weber <xmw@gentoo.org> +files/nedit.svg,
+  +nedit-5.5_p20110116-r1.ebuild:
+  Add desktop file and iocon (thanks johnny99, bug 296942). Respect AR (bug
+  468172)
+