Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 29666 - KWrite font zooming doesn't work before switching font manually
Summary: KWrite font zooming doesn't work before switching font manually
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: Gentoo KDE team
Depends on:
Reported: 2003-09-26 05:14 UTC by Janne Pikkarainen
Modified: 2004-05-18 16:21 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Janne Pikkarainen 2003-09-26 05:14:33 UTC
I tried to use the font zoom tool in KWrite, but as a big surprise for me it
didn't work at all. After switching font from Helvetica to Courier New zoom 
started to work. In fact, after I switched back to Helvetica, zoom still worked
and now I'm unable to repeat to bug. 

So it seems that default font setting for KWrite is borked somehow and after one
manual switch it magically starts to work. Maybe this applies to KDE text editor
framework in general? I don't know all the gory details of KDE. 

Anyway, this started when my friend mailed me and asked why's the zoom is not
working. I installed Gentoo to her AMD Athlon XP box earlier this week by using
Athlon XP GRP packages from live-cd's. The same bug applies at least to my box
at work, and this is my own-compiled Gentoo Box, running with Pentium 4.

I do have KDE 3.1.2 installed and I think the other box has KDE 3.1.3
installed... anyway it's the version which ships with latest AMD Athlon XP
optimized live-cd's. Sorry to bother you if this bug has already been fixed in
KDE 3.1.4, I'll let it compile over this weekend.

Reproducible: Couldn't Reproduce
Steps to Reproduce:
1. Install KDE
2. Run KWrite
3. Write some text and try to zoom it by using the toolbar icons.
4. See how nothing happens.
5. Change font to any other font from Settings --> Configure Editor --> Fonts
6. Try using zoom tool and behold, it works!
7. Switch back to previous font and see how zoom still works.
Comment 1 Paul de Vrieze (RETIRED) gentoo-dev 2003-09-26 05:58:33 UTC
Depending on your exact font config the helvetica font is a bitmap font that
is not scalable. As such zooming should only work in case there is a font
of the correct size. In general the easiest way to handle this is to avoid
bitmap fonts alltogether.
Comment 2 Janne Pikkarainen 2003-09-27 08:07:45 UTC
Yes, but my point is that it seems the default font in Gentoo's KDE is a
bitmap font. If possible, that should be changed to some scalable font.
Comment 3 Caleb Tennis (RETIRED) gentoo-dev 2004-05-18 16:21:22 UTC
i don't see this one getting fixed, lest someone else wants to take it under their arms.