Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 296548 - Dropped Keywords due to sys-auth/polkit
Summary: Dropped Keywords due to sys-auth/polkit
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Freedesktop bugs
URL:
Whiteboard:
Keywords: KEYWORDREQ
: 307395 349714 (view as bug list)
Depends on: 289017
Blocks: gnome2.28 308971
  Show dependency tree
 
Reported: 2009-12-11 18:55 UTC by Nirbheek Chauhan (RETIRED)
Modified: 2012-08-26 18:48 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
polkit keywordreq list (polkit-keywordreq,819 bytes, text/plain)
2009-12-11 18:57 UTC, Nirbheek Chauhan (RETIRED)
Details
Updated list (polkit-keywordreq,981 bytes, text/plain)
2009-12-27 02:41 UTC, Nirbheek Chauhan (RETIRED)
Details
NetworkManager has joined the list (polkit-keywordreq,1.14 KB, text/plain)
2010-01-25 07:26 UTC, Nirbheek Chauhan (RETIRED)
Details
Addition of empathy to the list (polkit-keywordreq,1.29 KB, text/plain)
2010-02-28 12:47 UTC, Nirbheek Chauhan (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nirbheek Chauhan (RETIRED) gentoo-dev 2009-12-11 18:55:33 UTC
Upstream rewrote policykit to a completely new codebase and architecture and renamed it to polkit. All of GNOME 2.28.0 uses sys-auth/polkit, which is only keyworded on amd64 and x86. Follows a list of packages that need keywording with arches.

There are some packages such as gnome-power-manager and gnome-disk-utility that also need keywords for separate reasons (and they also need keywords on polkit). They will be handled on separate bugs depending on this bug.

# Dropped Keywords due to polkit
dev-libs/eggdbus-0.6               ~alpha ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc
sys-auth/consolekit-0.4.1          ~alpha ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc
sys-auth/polkit-0.95               ~alpha ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc
gnome-extra/polkit-gnome-0.95      ~alpha ~arm ~hppa ~ia64             ~ppc ~ppc64       ~sh ~sparc
gnome-base/gnome-panel-2.28.0      ~alpha ~arm ~hppa ~ia64             ~ppc ~ppc64           ~sparc
gnome-base/gnome-applets-2.28.0    ~alpha      ~hppa ~ia64             ~ppc ~ppc64           ~sparc
gnome-base/gconf-2.28.0-r1         ~alpha ~arm ~hppa ~ia64       ~mips ~ppc ~ppc64       ~sh ~sparc
gnome-base/gnome-session-2.28.0    ~alpha      ~hppa ~ia64             ~ppc ~ppc64           ~sparc

@m68k, @mips, @s390: you won't lose anything if you choose not to keyword polkit/consolekit; nothing you have keyworded depends on these (gconf-2.28.0 is an exception; but it doesn't have anything special)
Comment 1 Nirbheek Chauhan (RETIRED) gentoo-dev 2009-12-11 18:57:57 UTC
Created attachment 212725 [details]
polkit keywordreq list

List got wrapped in the previous comment; here's an attachment with the same contents for ease of viewing.
Comment 2 Nirbheek Chauhan (RETIRED) gentoo-dev 2009-12-27 02:41:32 UTC
Created attachment 214254 [details]
Updated list

Here's an updated list; adds gnome-control-center. 

Arches, please note that 2.28 is essentially useless for you without sys-auth/polkit and we don't intend to change 2.28's dependence on it.
Comment 3 Nirbheek Chauhan (RETIRED) gentoo-dev 2010-01-25 07:26:08 UTC
Created attachment 217369 [details]
NetworkManager has joined the list

Here's an updated list; recently added networkmanager-0.7.999 and nm-applet-0.7.999 have also joined the list. They will soon be unmasked and later become 0.8.0 .
Comment 4 Nirbheek Chauhan (RETIRED) gentoo-dev 2010-02-28 12:47:15 UTC
Created attachment 221531 [details]
Addition of empathy to the list

Empathy has joined the list due to a new dependency on NM-0.8 (starting from 2.28.2-r1, due to bug 306977). The addition of empathy has added three new keywords to networkmanager and nm-applet too.

Folks, you need to get this done quickly otherwise the virus of polkit will spread further and cause even *more* dropped keywords.
Comment 5 Nirbheek Chauhan (RETIRED) gentoo-dev 2010-03-03 09:36:58 UTC
*** Bug 307395 has been marked as a duplicate of this bug. ***
Comment 6 Joe Jezak (RETIRED) gentoo-dev 2010-03-10 09:57:38 UTC
Everything should be done for ppc/ppc64 except gnome-session. It deps on devicekit-power, which then also checks for ACPI support. Obviously, this makes no sense on any arches besides x86/amd64.

If this is a hard dep, this check will need to be removed. I will leave our arches on the CC list until I get a chance to test the package on a ppc laptop. 
Comment 7 Nirbheek Chauhan (RETIRED) gentoo-dev 2010-03-11 13:34:43 UTC
(In reply to comment #6)
> Everything should be done for ppc/ppc64 except gnome-session. It deps on
> devicekit-power, which then also checks for ACPI support. Obviously, this makes
> no sense on any arches besides x86/amd64.
> 

I've restricted the testto x86/amd64

> If this is a hard dep, this check will need to be removed. I will leave our
> arches on the CC list until I get a chance to test the package on a ppc laptop. 
> 

Thanks, although APM is probably not supported, it's best to be sure.
Comment 8 Gilles Dartiguelongue gentoo-dev 2010-03-11 14:34:26 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > Everything should be done for ppc/ppc64 except gnome-session. It deps on
> > devicekit-power, which then also checks for ACPI support. Obviously, this makes
> > no sense on any arches besides x86/amd64.
> > 
> 
> I've restricted the testto x86/amd64

please don't do that, bug #289017 is here to handle this
Comment 9 Andrew John Hughes 2010-03-11 14:49:50 UTC
As bug #289017 says, devicekit-power builds on ppc (when the check is removed) but doesn't have the expected functionality.  That suggests (at least to me) that it could be keyworded and allowed to build, so it as least not a blocker for other packages.
Comment 10 Gilles Dartiguelongue gentoo-dev 2010-03-11 16:44:48 UTC
(In reply to comment #9)
> As bug #289017 says, devicekit-power builds on ppc (when the check is removed)
> but doesn't have the expected functionality.  That suggests (at least to me)
> that it could be keyworded and allowed to build, so it as least not a blocker
> for other packages.

no, clearly no. A package keyword reflects that it works on said arch, not that it builds fine. Otherwise we'd do stabilization tests with cross-compilers and break every other arch regularly.
Comment 11 Raúl Porcel (RETIRED) gentoo-dev 2010-04-25 20:40:28 UTC
alpha/arm/ia64/sh/sparc done
Comment 12 Alex Buell 2010-05-14 18:55:32 UTC
I have a G3 iMAC which I installed Gnome 2.30.x on. Gnome-session seems to work fine, after forcing ~* on. If you want me to carry out further tests, the G3 iMac is hot and ready :)
Comment 13 gringo 2010-06-14 17:57:08 UTC
(In reply to comment #12)
> I have a G3 iMAC which I installed Gnome 2.30.x on. Gnome-session seems to work
> fine, after forcing ~* on. If you want me to carry out further tests, the G3
> iMac is hot and ready :)

gnome-session isnt the problem i think, but devicekit-power ( or upower or whatever it is called now): does gnome-power-manager work for you f.ex. ?
I have gnome-2.30.x running again in my wifes g4 powerbook and it has no clue about power management. Kde4 had the same problem btw, im not sure if there maybe is another more generic issue somewhere else.

pls. let me know if you want me to do some tests.

cheers guys
Comment 14 Alex Buell 2010-06-24 23:13:53 UTC
This is regarding the PPC port. I have gnome-power-manager unmasked and installed. Gnome 2.30.x seems to work well although all devicekit-* (disks and power) are masked. I will try and unmask these at some point in time and test with gnome-power-manager. Is this OK for you? 
Comment 15 Samuli Suominen (RETIRED) gentoo-dev 2010-07-06 10:16:08 UTC
~ppc64 had everything except gnome-session keyworded here, and found no reason why the keyword for that was missing -> keyworded the one package
Comment 16 Joe Jezak (RETIRED) gentoo-dev 2010-08-11 15:52:35 UTC
Marked ~ppc.
Comment 17 Jeroen Roovers (RETIRED) gentoo-dev 2011-01-21 17:12:51 UTC
*** Bug 349714 has been marked as a duplicate of this bug. ***
Comment 18 Jeroen Roovers (RETIRED) gentoo-dev 2011-01-21 17:15:50 UTC
Marked ~hppa.
Comment 19 Mart Raudsepp gentoo-dev 2011-04-08 00:44:29 UTC
I use.mask'ed policykit for mips for now, to be able to actually move forward for now, and deal with polkit later.
Re-keyworded gnome-base/gconf-2.32.0-r1 ~mips, so that now we can get other newer GNOME packages keyworded, and eventually also those that help testing polkit properly - to eventually still keyword it.
So ~mips will eventually still deal with the consolekit/polkit KEYWORDREQ.
Comment 20 Matt Turner gentoo-dev 2011-07-10 23:47:53 UTC
Added ~mips and removed policykit from use.mask.
Comment 21 Raúl Porcel (RETIRED) gentoo-dev 2012-08-26 18:48:44 UTC
m68k/s390 is happy with the mask