Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 296478 - x11-base/libXext blocking xorg-server upgrade from 1.6.4 to 1.7.3 (emerge --update --deep options are essential)
Summary: x11-base/libXext blocking xorg-server upgrade from 1.6.4 to 1.7.3 (emerge --u...
Status: RESOLVED OBSOLETE
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Dependencies (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 300071
  Show dependency tree
 
Reported: 2009-12-11 00:30 UTC by Jim Ramsay (lack) (RETIRED)
Modified: 2012-06-11 07:04 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
xorg-server build.log (xorg-server-block-build.log,12.57 KB, text/plain)
2009-12-11 01:28 UTC, Jim Ramsay (lack) (RETIRED)
Details
Debug log requested in comment 11 (debug.log,160.82 KB, text/plain)
2010-12-16 14:15 UTC, Adam
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Ramsay (lack) (RETIRED) gentoo-dev 2009-12-11 00:30:50 UTC
As requested, here is the output of 'emerge -pv', with portage-2.1.7.13:


These are the packages that would be merged, in order:

Calculating dependencies  ... done!
[ebuild     U ] x11-proto/xextproto-7.1.1 [7.0.5] 70 kB
[ebuild     U ] x11-proto/bigreqsproto-1.1.0 [1.0.2] 48 kB
[ebuild     U ] x11-proto/xf86driproto-2.1.0 [2.0.4] 49 kB
[ebuild     U ] x11-proto/xcmiscproto-1.2.0 [1.1.2] 48 kB
[ebuild     U ] x11-base/xorg-drivers-1.7 [1.6] INPUT_DEVICES="evdev keyboard mouse -acecad -aiptek -joystick -synaptics -tslib -virtualbox -vmmouse -void -wacom (-citron%) (-elographics%) (-fpit%) (-hyperpen%) (-mutouch%) (-penmount%)" VIDEO_CARDS="nvidia vesa -apm -ark -ast -chips -cirrus -dummy -epson -fbdev -fglrx -geode -glint -i128 -i740 (-impact) -intel -mach64 -mga -neomagic (-newport) -nv -r128 -radeon -radeonhd -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v4l -via -virtualbox -vmware (-voodoo) -xgi (-imstt%) (-vermilion%)" 0 kB
[ebuild     U ] x11-proto/fixesproto-4.1.1 [4.0] 90 kB
[ebuild     U ] x11-proto/xf86vidmodeproto-2.3 [2.2.2] 83 kB
[uninstall    ] x11-libs/libXxf86vm-1.0.2  USE="-debug" 
[blocks b     ] <x11-libs/libXxf86vm-1.0.99.1 ("<x11-libs/libXxf86vm-1.0.99.1" is blocking x11-proto/xf86vidmodeproto-2.3)
[ebuild     U ] x11-proto/recordproto-1.14 [1.13.2] 83 kB
[uninstall    ] x11-libs/libXtst-1.0.3  USE="-debug" 
[blocks b     ] <x11-libs/libXtst-1.0.99.2 ("<x11-libs/libXtst-1.0.99.2" is blocking x11-proto/recordproto-1.14)
[ebuild     U ] x11-proto/inputproto-2.0 [1.5.1] 137 kB
[uninstall    ] x11-libs/libXi-1.2.1  USE="-debug" 
[blocks b     ] <x11-libs/libXi-1.2.99 ("<x11-libs/libXi-1.2.99" is blocking x11-proto/inputproto-2.0)
[ebuild     U ] x11-proto/xineramaproto-1.2 [1.1.2] 82 kB
[uninstall    ] x11-libs/libXinerama-1.0.3  USE="-debug" 
[blocks b     ] <x11-libs/libXinerama-1.0.99.1 ("<x11-libs/libXinerama-1.0.99.1" is blocking x11-proto/xineramaproto-1.2)
[ebuild     U ] x11-proto/xf86dgaproto-2.1 [2.0.3] 84 kB
[uninstall    ] x11-libs/libXxf86dga-1.0.2  USE="-debug" 
[blocks b     ] <x11-libs/libXxf86dga-1.0.99.1 ("<x11-libs/libXxf86dga-1.0.99.1" is blocking x11-proto/xf86dgaproto-2.1)
[ebuild     U ] x11-base/xorg-server-1.7.3 [1.6.4] USE="hal kdrive nptl sdl xorg -debug -dmx -ipv6 -minimal -tslib" 4,800 kB
[blocks B     ] <x11-libs/libXext-1.0.99 ("<x11-libs/libXext-1.0.99" is blocking x11-proto/xextproto-7.1.1)

Total: 12 packages (12 upgrades, 5 uninstalls), Size of downloads: 5,571 kB
Conflict: 6 blocks (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  ('ebuild', '/', 'x11-proto/xextproto-7.1.1', 'merge') pulled in by
    >=x11-proto/xextproto-7.0.99.1 required by ('ebuild', '/', 'x11-proto/fixesproto-4.1.1', 'merge')
    >=x11-proto/xextproto-7.0.99.3 required by ('ebuild', '/', 'x11-base/xorg-server-1.7.3', 'merge')

  ('installed', '/', 'x11-libs/libXext-1.0.5', 'nomerge') pulled in by
    >=x11-libs/libXext-1.0.5 required by ('ebuild', '/', 'x11-base/xorg-server-1.7.3', 'merge')


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked
Comment 1 Jim Ramsay (lack) (RETIRED) gentoo-dev 2009-12-11 00:51:09 UTC
After 'emerge --unmerge x11-base/libXext' (and x11-drivers/nvidia-drivers) we have more blockers!

These are the packages that would be merged, in order:

Calculating dependencies  .... done!
[ebuild     U ] x11-proto/xextproto-7.1.1 [7.0.5] 70 kB
[ebuild     U ] x11-proto/inputproto-2.0 [1.5.1] 137 kB
[ebuild     U ] x11-proto/recordproto-1.14 [1.13.2] 83 kB
[ebuild     U ] x11-proto/bigreqsproto-1.1.0 [1.0.2] 48 kB
[ebuild     U ] x11-proto/xineramaproto-1.2 [1.1.2] 82 kB
[ebuild     U ] x11-proto/xf86driproto-2.1.0 [2.0.4] 49 kB
[ebuild     U ] x11-proto/xcmiscproto-1.2.0 [1.1.2] 48 kB
[ebuild     U ] x11-proto/xf86vidmodeproto-2.3 [2.2.2] 83 kB
[ebuild  N    ] x11-libs/libXext-1.1.1  USE="-debug" 312 kB
[ebuild     U ] x11-proto/fixesproto-4.1.1 [4.0] 90 kB
[ebuild     U ] x11-base/xorg-drivers-1.7 [1.6] INPUT_DEVICES="evdev keyboard mouse -acecad -aiptek -joystick -synaptics -tslib -virtualbox -vmmouse -void -wacom (-citron%) (-elographics%) (-fpit%) (-hyperpen%) (-mutouch%) (-penmount%)" VIDEO_CARDS="nvidia vesa -apm -ark -ast -chips -cirrus -dummy -epson -fbdev -fglrx -geode -glint -i128 -i740 (-impact) -intel -mach64 -mga -neomagic (-newport) -nv -r128 -radeon -radeonhd -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v4l -via -virtualbox -vmware (-voodoo) -xgi (-imstt%) (-vermilion%)" 0 kB
[ebuild     U ] app-admin/eselect-opengl-1.1.1-r2 [1.0.8-r1] 58 kB
[ebuild  N    ] x11-drivers/nvidia-drivers-173.14.22  USE="acpi gtk -custom-cflags (-multilib)" 11,976 kB
[ebuild     U ] x11-proto/xf86dgaproto-2.1 [2.0.3] 84 kB
[uninstall    ] x11-libs/libXxf86dga-1.0.2  USE="-debug" 
[blocks b     ] <x11-libs/libXxf86dga-1.0.99.1 ("<x11-libs/libXxf86dga-1.0.99.1" is blocking x11-proto/xf86dgaproto-2.1)
[ebuild     U ] x11-base/xorg-server-1.7.3 [1.6.4] USE="hal kdrive nptl sdl xorg -debug -dmx -ipv6 -minimal -tslib" 4,800 kB
[blocks B     ] <x11-libs/libXi-1.2.99 ("<x11-libs/libXi-1.2.99" is blocking x11-proto/inputproto-2.0)
[blocks B     ] <x11-libs/libXinerama-1.0.99.1 ("<x11-libs/libXinerama-1.0.99.1" is blocking x11-proto/xineramaproto-1.2)
[blocks B     ] <x11-libs/libXtst-1.0.99.2 ("<x11-libs/libXtst-1.0.99.2" is blocking x11-proto/recordproto-1.14)
[blocks B     ] <x11-libs/libXxf86vm-1.0.99.1 ("<x11-libs/libXxf86vm-1.0.99.1" is blocking x11-proto/xf86vidmodeproto-2.3)

Total: 15 packages (13 upgrades, 2 new, 1 uninstall), Size of downloads: 17,914 kB
Conflict: 5 blocks (4 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  ('ebuild', '/', 'x11-proto/xineramaproto-1.2', 'merge') pulled in by
    >=x11-proto/xineramaproto-1.1.3 required by ('ebuild', '/', 'x11-base/xorg-server-1.7.3', 'merge')

  ('ebuild', '/', 'x11-proto/xf86vidmodeproto-2.3', 'merge') pulled in by
    >=x11-proto/xf86vidmodeproto-2.2.99.1 required by ('ebuild', '/', 'x11-base/xorg-server-1.7.3', 'merge')

  ('installed', '/', 'x11-libs/libXtst-1.0.3', 'nomerge') pulled in by
    x11-libs/libXtst required by ('installed', '/', 'media-sound/pulseaudio-0.9.19-r50', 'nomerge')
    x11-libs/libXtst required by ('installed', '/', 'kde-base/kdelibs-4.3.2-r1', 'nomerge')
    x11-libs/libXtst required by ('installed', '/', 'x11-plugins/gkrellm-leds-0.8.1', 'nomerge')
    (and 7 more)

  ('installed', '/', 'x11-libs/libXinerama-1.0.3', 'nomerge') pulled in by
    x11-libs/libXinerama required by ('installed', '/', 'x11-libs/fltk-1.1.9-r1', 'nomerge')
    x11-libs/libXinerama required by ('installed', '/', 'media-video/xine-ui-0.99.5-r2', 'nomerge')
    x11-libs/libXinerama required by ('installed', '/', 'app-mobilephone/kmobiletools-0.4.3.3', 'nomerge')
    (and 16 more)

  ('installed', '/', 'x11-libs/libXi-1.2.1', 'nomerge') pulled in by
    x11-libs/libXi required by ('installed', '/', 'x11-libs/gtk+-2.16.6', 'nomerge')
    x11-libs/libXi required by ('installed', '/', 'dev-python/pyopengl-3.0.1_alpha4', 'nomerge')
    x11-libs/libXi required by ('installed', '/', 'www-client/opera-10.00', 'nomerge')
    (and 14 more)

  ('installed', '/', 'x11-libs/libXxf86vm-1.0.2', 'nomerge') pulled in by
    x11-libs/libXxf86vm required by ('installed', '/', 'x11-libs/wxGTK-2.6.4.0-r6', 'nomerge')
    x11-libs/libXxf86vm required by ('installed', '/', 'app-emulation/wine-1.1.30', 'nomerge')
    x11-libs/libXxf86vm required by ('installed', '/', 'x11-libs/wxGTK-2.8.10.1-r3', 'nomerge')
    (and 13 more)

  ('ebuild', '/', 'x11-proto/inputproto-2.0', 'merge') pulled in by
    >=x11-proto/inputproto-1.5 required by ('installed', '/', 'x11-libs/libXi-1.2.1', 'nomerge')
    >=x11-proto/inputproto-1.9.99.902 required by ('ebuild', '/', 'x11-base/xorg-server-1.7.3', 'merge')

  ('ebuild', '/', 'x11-proto/recordproto-1.14', 'merge') pulled in by
    x11-proto/recordproto required by ('installed', '/', 'x11-libs/libXtst-1.0.3', 'nomerge')
    >=x11-proto/recordproto-1.13.99.1 required by ('ebuild', '/', 'x11-base/xorg-server-1.7.3', 'merge')


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


!!! The following installed packages are masked:
- games-action/glaxium-0.5-r1 (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Michael Sterrett <mr_bones_@gentoo.org> (04 Dec 2009)
# The "game" part of the experience is missing.
# Abandoned by upstream in 2002.  Removal on 20100103

- media-libs/netpbm-10.48.00 (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Luca Barbato <lu_zero@gentoo.org (07 Dec 2009)
# bad regression https://bugs.gentoo.org/287725

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

Comment 2 Jim Ramsay (lack) (RETIRED) gentoo-dev 2009-12-11 01:26:53 UTC
Next, after removing those blocks:
emerge --unmerge x11-libs/libXi x11-libs/libXinerama x11-libs/libXtst
x11-libs/libXxf86vm

The install was ready to go, but none of those 4 blockers above were re-added
automatically, with a result that everything merged fine up to but not include
xorg-server itself, where the configure failed. (Attaching build log next)

Here is emerge -pv xorg-server after removing those 4 blockers:


These are the packages that would be merged, in order:

Calculating dependencies  .... done!
[ebuild     U ] x11-proto/xextproto-7.1.1 [7.0.5] 70 kB
[ebuild     U ] x11-proto/bigreqsproto-1.1.0 [1.0.2] 48 kB
[ebuild     U ] x11-proto/xineramaproto-1.2 [1.1.2] 82 kB
[ebuild     U ] x11-proto/xf86driproto-2.1.0 [2.0.4] 49 kB
[ebuild     U ] x11-proto/inputproto-2.0 [1.5.1] 137 kB
[ebuild     U ] x11-proto/xcmiscproto-1.2.0 [1.1.2] 48 kB
[ebuild     U ] x11-proto/recordproto-1.14 [1.13.2] 83 kB
[ebuild     U ] x11-proto/xf86vidmodeproto-2.3 [2.2.2] 83 kB
[ebuild  N    ] x11-libs/libXext-1.1.1  USE="-debug" 312 kB
[ebuild     U ] x11-proto/fixesproto-4.1.1 [4.0] 90 kB
[ebuild     U ] x11-base/xorg-drivers-1.7 [1.6] INPUT_DEVICES="evdev keyboard mouse -acecad -aiptek -joystick -synaptics -tslib -virtualbox -vmmouse -void -wacom (-citron%) (-elographics%) (-fpit%) (-hyperpen%) (-mutouch%) (-penmount%)" VIDEO_CARDS="nvidia vesa -apm -ark -ast -chips -cirrus -dummy -epson -fbdev -fglrx -geode -glint -i128 -i740 (-impact) -intel -mach64 -mga -neomagic (-newport) -nv -r128 -radeon -radeonhd -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v4l -via -virtualbox -vmware (-voodoo) -xgi (-imstt%) (-vermilion%)" 0 kB
[ebuild     U ] app-admin/eselect-opengl-1.1.1-r2 [1.0.8-r1] 58 kB
[ebuild  N    ] x11-drivers/nvidia-drivers-173.14.22  USE="acpi gtk -custom-cflags (-multilib)" 11,976 kB
[ebuild     U ] x11-proto/xf86dgaproto-2.1 [2.0.3] 84 kB
[uninstall    ] x11-libs/libXxf86dga-1.0.2  USE="-debug" 
[blocks b     ] <x11-libs/libXxf86dga-1.0.99.1 ("<x11-libs/libXxf86dga-1.0.99.1" is blocking x11-proto/xf86dgaproto-2.1)
[ebuild     U ] x11-base/xorg-server-1.7.3 [1.6.4] USE="hal kdrive nptl sdl xorg -debug -dmx -ipv6 -minimal -tslib" 4,800 kB

Total: 15 packages (13 upgrades, 2 new, 1 uninstall), Size of downloads: 17,914 kB
Conflict: 1 block

!!! The following installed packages are masked:
- games-action/glaxium-0.5-r1 (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Michael Sterrett <mr_bones_@gentoo.org> (04 Dec 2009)
# The "game" part of the experience is missing.
# Abandoned by upstream in 2002.  Removal on 20100103

- media-libs/netpbm-10.48.00 (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Luca Barbato <lu_zero@gentoo.org (07 Dec 2009)
# bad regression https://bugs.gentoo.org/287725

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

Comment 3 Jim Ramsay (lack) (RETIRED) gentoo-dev 2009-12-11 01:28:12 UTC
Created attachment 212665 [details]
xorg-server build.log

Aforementioned build.log from xorg-server when it failed due to missing
dependencies.
Comment 4 Jim Ramsay (lack) (RETIRED) gentoo-dev 2009-12-11 01:31:49 UTC
Finally, after re-emerging those 4 missed libraries manually, the
xorg-server-1.7.3 is now compiling, and they all lived happily ever after.

Thank you for reading this epic story, I hope someone will find it useful :)
Comment 5 Rémi Cardona gentoo-dev 2009-12-11 07:11:23 UTC
The blocks we've put in all the lib and proto packages are EAPI=2 "soft-blocks" that portage is supposed to deal with on its own.

@Zac, is there something we messed up? Is Jim's version of portage capable of taking care of soft-blocks?

Cheers
Comment 6 Zac Medico gentoo-dev 2009-12-12 08:11:35 UTC
This looks like a variant of bug 281008. Since portage-2.1.7, you need to use --update more often. Ultimately, the plan is to solve these kinds of blockers regardless of the options given (bug 290818).
Comment 7 Adam 2010-12-14 20:15:01 UTC
(In reply to comment #6)

I got similar blockages, but I used emerge -pud world.  So it doesn't seem like it could be the problem where --update is required.

[blocks B     ] <x11-libs/libXext-1.0.99 ("<x11-libs/libXext-1.0.99" is blocking x11-proto/xextproto-7.1.1)
[blocks B     ] <x11-libs/libXi-1.2.99 ("<x11-libs/libXi-1.2.99" is blocking x11-proto/inputproto-2.0)
[blocks B     ] <x11-libs/libXtst-1.0.99.2 ("<x11-libs/libXtst-1.0.99.2" is blocking x11-proto/recordproto-1.14)
[blocks B     ] <x11-libs/libXxf86vm-1.0.99.1 ("<x11-libs/libXxf86vm-1.0.99.1" is blocking x11-proto/xf86vidmodeproto-2.3)

Is there a workaround?  The above comments mention that there were build errors when removing those blocking packages, so I don't want to do so and screw up my system, but I can't update my system in the current state either...

I don't think I've updated my system in about a year, which may be related.
Comment 8 Zac Medico gentoo-dev 2010-12-14 20:24:18 UTC
(In reply to comment #7)
The part of the message that you posted isn't very useful without the part showing parent packages that usually comes later, like this part from comment #0:

  ('ebuild', '/', 'x11-proto/xextproto-7.1.1', 'merge') pulled in by
    >=x11-proto/xextproto-7.0.99.1 required by ('ebuild', '/', 'x11-proto/fixesproto-4.1.1', 'merge')
    >=x11-proto/xextproto-7.0.99.3 required by ('ebuild', '/', 'x11-base/xorg-server-1.7.3', 'merge')

  ('installed', '/', 'x11-libs/libXext-1.0.5', 'nomerge') pulled in by
    >=x11-libs/libXext-1.0.5 required by ('ebuild', '/', 'x11-base/xorg-server-1.7.3', 'merge')
Comment 9 Adam 2010-12-14 22:03:50 UTC
[blocks B     ] <x11-libs/libXext-1.0.99 ("<x11-libs/libXext-1.0.99" is blocking x11-proto/xextproto-7.1.1)
[blocks B     ] <x11-libs/libXi-1.2.99 ("<x11-libs/libXi-1.2.99" is blocking x11-proto/inputproto-2.0)
[blocks B     ] <x11-libs/libXtst-1.0.99.2 ("<x11-libs/libXtst-1.0.99.2" is blocking x11-proto/recordproto-1.14)
[blocks B     ] <x11-libs/libXxf86vm-1.0.99.1 ("<x11-libs/libXxf86vm-1.0.99.1" is blocking x11-proto/xf86vidmodeproto-2.3)

Total: 114 packages (101 upgrades, 8 new, 5 in new slots, 1 uninstall), Size of downloads: 651,708 kB
Conflict: 5 blocks (4 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (x11-proto/xf86vidmodeproto-2.3, ebuild scheduled for merge) pulled in by
    >=x11-proto/xf86vidmodeproto-2.2.99.1 required by (x11-base/xorg-server-1.7.7-r1, ebuild scheduled for merge)
    x11-proto/xf86vidmodeproto required by (app-emulation/wine-1.2, ebuild scheduled for merge)

  (x11-libs/libXtst-1.0.3, installed) pulled in by
    x11-libs/libXtst required by (dev-java/sun-jre-bin-1.6.0.22, ebuild scheduled for merge)

  (x11-libs/libXi-1.2.1, installed) pulled in by
    x11-libs/libXi required by (app-emulation/wine-1.2, ebuild scheduled for merge)
    x11-libs/libXi required by (media-libs/mesa-7.5.2, installed)
    x11-libs/libXi required by (x11-libs/gtk+-2.20.1-r1, ebuild scheduled for merge)
    (and 1 more)

  (x11-libs/libXext-1.0.5, installed) pulled in by
    x11-libs/libXext required by (app-text/gv-3.7.1, ebuild scheduled for merge)
    x11-libs/libXext required by (x11-libs/libwnck-2.26.2-r2, installed)
    x11-libs/libXext required by (media-libs/imlib2-1.4.2-r1, installed)
    (and 23 more)

  (x11-proto/inputproto-2.0, ebuild scheduled for merge) pulled in by
    x11-proto/inputproto required by (app-emulation/wine-1.2, ebuild scheduled for merge)
    x11-proto/inputproto required by (x11-libs/gtk+-2.20.1-r1, ebuild scheduled for merge)
    >=x11-proto/inputproto-1.9.99.902 required by (x11-base/xorg-server-1.7.7-r1, ebuild scheduled for merge)
    (and 1 more)

  (x11-proto/recordproto-1.14, ebuild scheduled for merge) pulled in by
    x11-proto/recordproto required by (x11-libs/libXtst-1.0.3, installed)
    >=x11-proto/recordproto-1.13.99.1 required by (x11-base/xorg-server-1.7.7-r1, ebuild scheduled for merge)

  (x11-proto/xextproto-7.1.1, ebuild scheduled for merge) pulled in by
    x11-proto/xextproto required by (x11-wm/metacity-2.30.1, ebuild scheduled for merge)
    x11-proto/xextproto required by (gnome-extra/gnome-utils-2.30.0, ebuild scheduled for merge)
    >=x11-proto/xextproto-7.0.99.1 required by (x11-proto/fixesproto-4.1.1, ebuild scheduled for merge)
    (and 6 more)

  (x11-libs/libXxf86vm-1.0.2, installed) pulled in by
    x11-libs/libXxf86vm required by (app-emulation/wine-1.2, ebuild scheduled for merge)
    x11-libs/libXxf86vm required by (media-libs/mesa-7.5.2, installed)
Comment 10 Adam 2010-12-15 20:43:07 UTC
(In reply to comment #8)

(The previous comment was supposed to be a reply to comment #8 - I'm not sure if you get notified otherwise.)
Comment 11 Zac Medico gentoo-dev 2010-12-15 21:29:55 UTC
(In reply to comment #9)
Unfortunately, the output still isn't very helpful in this case. We could definitely improve the analysis to give a better message. Since you're already using --update, it leads me to suspect that you may have some unusual package.keywords settings that are triggering this.

Please make sure that you have the latest version of portage (2.1.9.24 is latest stable now) and post a debug log created like this:

  emerge -puD --backtrack=0 --debug world &> debug.log
Comment 12 Adam 2010-12-16 14:15:29 UTC
Created attachment 257322 [details]
Debug log requested in comment 11
Comment 13 Adam 2010-12-16 14:16:57 UTC
(In reply to comment #11)

OK, I attached it.  It's giving an error about udev, strangely.

I removed my package.keywords file (didn't need it anyway), but the problem is the same.  I have portage 2.1.9.24.
Comment 14 Adam 2010-12-16 14:31:07 UTC
(In reply to comment #11)

Hmm, OK... I guess my problem is I wasn't using the --deep option, i.e. I was using emerge -pud world instead of emerge -puD world.  So I guess I haven't reproduced this bug with --update after all.  Sorry about that.