Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 296442 - media-libs/libreplaygain-458 configure error
Summary: media-libs/libreplaygain-458 configure error
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-10 19:38 UTC by 白川間瀬流
Modified: 2009-12-10 22:27 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,2.47 KB, text/plain)
2009-12-10 19:39 UTC, 白川間瀬流
Details

Note You need to log in before you can comment on or make changes to this bug.
Description 白川間瀬流 2009-12-10 19:38:45 UTC
tell me, is someone cheking ebuilds like these after bumping the version? seems not :/

Portage 2.1.6.13 (default/linux/x86/10.0/desktop, gcc-4.4.2, glibc-2.11-r1, 2.6.31.6-Vamp898 i686)
=================================================================
System uname: Linux-2.6.31.6-Vamp898-i686-Pentium-R-_Dual-Core_CPU_T4200_@_2.00GHz-with-gentoo-2.0.1
Timestamp of tree: Thu, 10 Dec 2009 18:45:01 +0000
app-shells/bash:     4.0_p35
dev-java/java-config: 2.1.10
dev-lang/python:     2.6.4, 3.1.1-r1
dev-util/cmake:      2.8.0
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.5.3
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.13, 2.64
sys-devel/automake:  1.8.5-r3, 1.9.6-r2, 1.10.2, 1.11.1
sys-devel/binutils:  2.20
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://de-mirror.org/distro/gentoo"
LANG="de_DE.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="de"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/pro-audio /overlay /usr/local/portage/layman/gnome /usr/local/portage/layman/sunrise /usr/local/portage/layman/desktop-effects /usr/local/portage/layman/dev-zero /usr/local/portage/layman/anarchy"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa berkdb bluetooth branding bzip2 cairo cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss encode evo fam firefox flac fortran gdbm gif gnome gpm gstreamer gtk hal iconv jack jpeg kde ldap libnotify lzma mad mikmod mmx modules mp3 mp4 mpeg mudflap ncurses networkmanager nls nptl nptlonly ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3support qt4 quicktime readline reflection sdl session smp spell spl sse sse2 ssl startup-notification svg sysfs tcpd threads thunar tiff truetype unicode usb v4l v4l2 vorbis win32codecs x264 x86 xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" QEMU_SOFTMMU_TARGETS="i386 x86_64 ppc sparc" QEMU_USER_TARGETS="i386 x86_64 ppc sparc" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Reproducible: Always

Steps to Reproduce:
Comment 1 白川間瀬流 2009-12-10 19:39:07 UTC
Created attachment 212641 [details]
build.log
Comment 2 白川間瀬流 2009-12-10 19:44:02 UTC
beceause media-sound/musepack-tools-458 depends on this package, the compiling of media-sound/musepack-tools-458 wont work too
Comment 3 Samuli Suominen gentoo-dev 2009-12-10 20:20:02 UTC
Yes, libreplaygain/libcuefile and musepack-tools are all tested. 
It's working fine here with "dev-util/cmake-2.8.0".
Comment 4 白川間瀬流 2009-12-10 20:21:12 UTC
(In reply to comment #3)
> Yes, libreplaygain/libcuefile and musepack-tools are all tested. 
> It's working fine here with "dev-util/cmake-2.8.0".
> 

[I] dev-util/cmake (2.8.0@15.11.2009): Cross platform Make

im using this version of cmake and as you can see in the build.log. It does not work here^^
Comment 5 Samuli Suominen gentoo-dev 2009-12-10 21:14:08 UTC
emerge --sync first, then retry, if it still doesn't work, attach the failing CMakeLists.txt here from

/var/tmp/portage/media-libs/libreplaygain-458/work/libreplaygain-458/CMakeLists.txt

Comment 6 白川間瀬流 2009-12-10 22:15:58 UTC
Amazing.

After emerge --sync it worked Ö_Ö

i synced 1 hour before and it did not worked :/ seemd to be an sync or mirror error.

but now it works^^
Comment 7 Samuli Suominen gentoo-dev 2009-12-10 22:27:22 UTC
(In reply to comment #6)
> Amazing.
> 
> After emerge --sync it worked Ö_Ö

I suspected something like that, because /usr/portage/eclass/cmake-utils.eclass had some minor changes today, so *I guess* the *first* commit broke it for a while and the *second* one fixed it. It was really only a missing empty new line (\n) issue.